DoubleTake.Web.Models Namespace

Classes
 | Class | Description
Public class | ActionInputFlatModel | Represents input into a monitor action.
Public class | ActionInputModel | Represents input into a monitor action.
Public class | ActionResultFlatModel | Represents the result of a monitor action.
Public class | ActionResultModel | Represents the result of a monitor action.
Public class | ActivationCodeInfoModel | Activation code information on appliance for V2V push install
Public class | AddressPersistedStateModel | Address persisted state.
Public class | AnalyticsInfoModel |
Public class | AnalyticsServerHardwareModel |
Public class | AnalyticsServerOSModel |
Public class | AnalyticsVolumeModel |
Public class | BackConnectionResultsModel |
Public class | BooleanSettingModel | Boolean setting.
Public class | ClusteredVirtualMachineModel | A clustered VM
Public class | ClusteredVirtualMachineResourceInfoModel | Clustered virtual machine resource information.
Public class | ClusteredVirtualMachinesInfoModel | Clustered VM Groups
Public class | ClusterGroupInfoModel | Cluster group information.
Public class | ClusterResourceInfoModel | Cluster resource information.
Public class | CompositeActionInputModel | Represents the input to a Composite action agent.
Public class | CompositeActionResultModel | Represents the results of a composite action.
Public class | CompositeQueryInputModel | Represents the input to a Composite query agent.
Public class | CompositeQueryResultModel | Represents the results of a composite query.
Public class | ConnectionConfigurationModel | Connection configuration model.
Public class | ConnectionInfoModel | Connection information.
Public class | ConnectionParametersModel | Connection parameters.
Public class | ConnectionQualificationResultModel | Connection qualification result.
Public class | ConnectionStatisticsModel | Connection statistics.
Public class | ConnectionStatusModel | The connection status model.
Public class | ControlledServerInfoModel | Represents information about a server managed by Controller Service
Public class | ControlledServerInfoSimpleModel | Represents information about a server managed by Controller Service
Public class | CoreClusterInfoModel | Data specific to the cluster. This is data that stays with the cluster during roll-over.
Public class | CoreConnectionPersistedStateModel | The core connection persisted state.
Public class | CreateConnectionModel | This class represents the parameters passed into the api/connections/create call
Public class | CreateFromExistingJobModel | Contains the information needed to create a new job from and existing job.
Public class | CreateRepsetRequestModel | Create repset request.
Public class | DeleteOptionsModel | Delete options.
Public class | DiagnosticsPersistedStateModel | Diagnostics persisted state.
Public class | DiskLayoutInitializeModel | Disk layout initialize.
Public class | DiskLayoutModel | Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Public class | DiskLayoutResultModel | Disk layout extraction result from a source system state scrape.
Public class | DiskLayoutStatusResultModel | Disk layout status result.
Public class | DiskLayoutVerifyResultsModel | Results of disk layout verification.
Public class | DiskLayoutWithEnvironmentModel | Disk layout environment constraints.
Public class | DiskPartitionLayoutModel | Disk partition layout model.
Public class | DnsDomainDetailsPrototypeModel | DNS domain details prototype model.
Public class | DTAVPersistedStateModel | DTAV persisted state.
Public class | DTHVPersistedStateModel | DTHV persisted state.
Public class | DtInfoCollectionStatusModel | DTInfo collection status.
Public class | DtmuActivationStatusModel | DTMU activation status.
Public class | DtscStatusQueryInputModel | Inputs for a DtscStatus monitor
Public class | DtscStatusQueryResultModel | Represents the results of a Dtsc status query.
Public class | DTTargetResourceQueryInputModel | The Input parameters to monitor a resource on a Target machine
Public class | EmailNotificationSettingsModel | Email notification settings model
Public class | EmailNotificationTestParametersModel | Email notification test parameters.
Public class | ErrorInfoModel | Represents job error properties.
Public class | ESXInfoModel | This class represents the general information about an ESX server.
Public class | FailoverPersistedStateModel | Failover persisted state.
Public class | FailoverReportingModel | Failover reporting data model
Public class | FailoverReportMachineInfoModel | Data about the target machine
Public class | FailoverReportTimesModel | Time at various points of the failover.
Public class | FilesAndFoldersPersistedStateModel | Files and Folders persisted state.
Public class | FullServerPersistedStateModel | Full server persisted state.
Public class | HeartbeatPingQueryInputModel | Represents the input to a Double-Take heartbeat ping query agent.
Public class | HeartbeatPingQueryResultModel | Represents the results of a heartbeat ping query.
Public class | IcmpPingQueryInputModel | Represents the input to an ICMP ping query agent.
Public class | IcmpPingQueryResultModel | Represents the results of an ICMP ping query.
Public class | ImageProtectionPersistedStateModel | Image protection persisted state.
Public class | ImageRecoveryPersistedStateModel | Image recovery persisted state.
Public class | IntegerSettingModel | Integer setting.
Public class | IPAddressModel | IP address.
Public class | JobInfoPrivateModel | Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Public class | JobParametersModel | Job parameters.
Public class | JobStateModel | Represents job state information.
Public class | JobUsageDataModel | Job usage data.
Public class | LinuxJobPersistedStateModel | Linux job persisted state.
Public class | LinuxJobStateFlagModel | String representation of a JobStateFlag, defined privately by the Linux job implementation
Public class | LinuxJobStateFlagStackLevelModel | Linux job state flag stack level.
Public class | LinuxJobStateFlagStackModel | A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Public class | LogActionInputModel | Represents the input to a log action.
Public class | ModifyReplicationSetRulesRequestModel | Modify replication set rules request.
Public class | MonitorableAddressInfoModel | Used to specify a monitorable IP address that can be used to configure a failover monitor.
Public class | MonitorActionFlatModel | Represents an action that is run in the context of a monitor.
Public class | MonitorActionModel | Represents an action that is run in the context of a monitor.
Public class | MonitorInfoModel | Monitor information.
Public class | MonitorQualificationResultModel | An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Public class | MonitorQueryFlatModel | Monitor query flat.
Public class | MonitorQueryModel | This class is part of the MonitorActivity class which contains both query and action.
Public class | MonitorStatusModel | Monitor status.
Public class | MultiStringSettingModel | Multi-string setting.
Public class | NamedSettingModel | Named setting.
Public class | NicMappingsModel | NIC mapping.
Public class | OptionRequestModel | Options request.
Public class | OptionValueModel | Options value.
Public class | PathBlockingEntryModel | A path blocking entry.
Public class | PerformanceCounterQueryInputModel | Represents the input to a performance counter query.
Public class | PerformanceCounterQueryResultModel | Represents the results of a Performance Counter Query
Public class | PhysicalRulesModel | Physical rules model
Public class | PITSnapshotRecordModel | PIT snapshot record.
Public class | PropertyModel | Represents an association between a name and another string
Public class | QueryInputFlatModel | Query input flat.
Public class | QueryInputModel | Represents arguments to a monitoring query.
Public class | QueryResultFlatModel | Represents the result of a monitoring query.
Public class | QueryResultModel | Represents the result of a monitoring query.
Public class | QueueTaskParametersModel | Queue task parameters.
Public class | RecommendedRestoreOptionsModel | Recommended restore options.
Public class | ReplicationSetInfoModel | Replication set information.
Public class | ResourceAndPassiveNodesModel | Resource and passive nodes.
Public class | ScriptActionInputModel | Represents the input to execute a script
Public class | ScriptActionResultModel | Represents the results of a Script action.
Public class | ScriptQueryInputModel | Defines the input into the script query.
Public class | ServiceInfoModel | Service information.
Public class | ServiceMetadataModel | Service metadata.
Public class | ServiceOperationActionInputModel | The inputs for a Service operation
Public class | ServiceOperationActionResultModel | Represents the result of a service operation action.
Public class | ServiceStatusQueryInputModel | Represents the input to a service query
Public class | ServiceStatusQueryResultModel | Represents the results of a Service Status Query
Public class | ServicesToStopModel | Services to stop.
Public class | ShareQueryInputModel | The inputs required for a share monitor
Public class | ShareQueryResultModel | Represents the results of a share query.
Public class | SqlDatabasePersistedInfoModel | SQL database persisted information.
Public class | StorageInfoModel | Core.StorageInfo
Public class | StringSettingModel | String setting.
Public class | SwitchPortInfoModel | Switch port info.
Public class | SystemStateConfigurationModel | Holds the system state definitions for both the source and target
Public class | SystemStateCutoverStatusModel | System state cutover status.
Public class | SystemStateDefinitionModel | System state definition.
Public class | SystemStateDumpNonDiskSystemStateInfoStatusModel | System state dump non-disk system state information.
Public class | SystemStatePathModel | System state path.
Public class | SystemStatePropertyValueModel | System state property.
Public class | SystemStateVerificationResultModel | System state verification result.
Public class | SystemStateVerificationStepModel | System state verification step.
Public class | TaskParametersModel | Specifies a script or executable to be run along with its corresponding command-line arguments.
Public class | UpdateCredentialsModel | Information required to update the credentials for a job
Public class | UsageDataModel | Usage data.
Public class | UVRAPersistedStateModel | UVRA persisted state.
Public class | UVRAVolumePersistedStateModel | UVRA volume persisted state.
Public class | V2VVirtualMachineModel | Describes a virtual machine to be protected by the V2V feature.
Public class | VHDMappingModel | Represents source and target VHD mappings
Public class | VirtualizationConnectionInfoModel | Virtualization connection information.
Public class | VirtualMachineResourceInfoModel | Virtual machine resource information.
Public class | VirtualSwitchConfigQueryInputModel | Inputs for a Virtual Switch monitor
Public class | VirtualSwitchConfigQueryResultModel | Represents the results of a Virtual Switch config query.
Public class | VmCfgSimpleInfoModel | VM configuration simple information.
Public class | VmConfigQueryInputModel | Query inputs for monitoring a VmConfig
Public class | VmConfigQueryResultModel | Represents the results of a Vm config query
Public class | VmdkInfoModel | VMDK information.
Public class | VmHealthQueryInputModel | Query input for monitoring the health of a vm
Public class | VmHealthQueryResultModel | Represents the results of a Vm health query
Public class | VRAInternalVirtualNetworkInterfaceInfoModel | VRA internal virtual network interface information.
Public class | VRAVolumePersistedStateModel | VRA volume persisted state.
Public class | WinServiceInfoModel | Service information.
Enumerations
 | Enumeration | Description
Public enumeration | AnalyticsOSTypeModelEnum |
Public enumeration | AnalyticsPlatformModelEnum |
Public enumeration | ComparisonOperationEnum | Represents the types of comparison operations.
Public enumeration | CompositeQueryOperationEnum | Defines how to evaluate a composite query.
Public enumeration | ConnectionModeEnum | Connectio nmode.
Public enumeration | ConnectionQualificationFailuresEnum | Connection qualification failures
Public enumeration | ControlOperationEnum | Control operation.
Public enumeration | CoreClusteredResourceStateEnum | Core clustered resource state
Public enumeration | DriveTypeEnum | Drive type
Public enumeration | DtInfoCollectionProgressEnum | Double-Take information collection progress
Public enumeration | DtmuJobStatusEnum | DTMU job status
Public enumeration | EmailNotificationCategoriesEnum | Email notification categories
Public enumeration | FailoverReportTypeEnum | Type of failover being used.
Public enumeration | FullServerJobTypeEnum | This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection
Public enumeration | MonitorResultEnum | Monitor result
Public enumeration | PathBlockingModeEnum | This value represents if the path is blocked.
Public enumeration | QueueStateEnum | The operational state of a queue.
Public enumeration | RebootActionEnum | An enumeration specifying the desired reboot behavior after a cutover.
Public enumeration | ReMonitorActionEnum | Used to specify the action to take after a failback has completed.
Public enumeration | ServiceOperationEnum | Represents the different types of Windows service operations.
Public enumeration | ServicesStartModeEnum | Represents the startup mode of a Windows service.
Public enumeration | ShortNameBehaviorSettingEnum | Defines values of the system short name behavior setting
Public enumeration | ShutdownOptionEnum | Shutdown option
Public enumeration | VmHealthEnum | VM health
Public enumeration | WinServiceStartModeEnum | Service start mode


ActionInputFlatModel Class

Represents input into a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ActionInputFlatModel
Public Class ActionInputFlatModel
public ref class ActionInputFlatModel
type ActionInputFlatModel =  class end

The ActionInputFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionInputFlatModel | Initializes a new instance of the ActionInputFlatModel class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | ClassName | Gets or sets the name of the class.
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | EventType | Gets or sets the type of the event.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionInputFlatModel Constructor

Initializes a new instance of the ActionInputFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionInputFlatModel()
Public Sub New
public:
ActionInputFlatModel()
new : unit -> ActionInputFlatModel
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel Properties

The ActionInputFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | ClassName | Gets or sets the name of the class.
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | EventType | Gets or sets the type of the event.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Actions Property

Double-Take REST SDK 8.2

ActionInputFlatModelActions Property

Gets or sets the enumerable collection of actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<MonitorActionFlatModel> Actions { get; set; }
Public Property Actions As IEnumerable(Of MonitorActionFlatModel)
    Get
    Set
public:
property IEnumerable<MonitorActionFlatModel^>^ Actions {
    IEnumerable<MonitorActionFlatModel^>^ get ();
    void set (IEnumerable<MonitorActionFlatModel^>^ value);
}
member Actions : IEnumerable<MonitorActionFlatModel> with get, set

Property Value

Type: IEnumerable MonitorActionFlatModel
The enumerable collection of actions.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Arguments Property

ActionInputFlatModelArguments Property

Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ClassName Property

ActionInputFlatModelClassName Property

Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The name of the class.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Credentials Property

ActionInputFlatModelCredentials Property

Gets or sets the credentials to be used by the action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.EventType Property

ActionInputFlatModelEventType Property

Gets or sets the type of the event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TraceEventType EventType { get; set; }
Public Property EventType As TraceEventType
    Get
    Set
public:
property TraceEventType EventType {
    TraceEventType get ();
    void set (TraceEventType value);
}
member EventType : TraceEventType with get, set

Property Value

Type: TraceEventType
The type of the event.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.FileName Property

ActionInputFlatModelFileName Property

Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Message Property

ActionInputFlatModelMessage Property

Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.MessageFormatParameters Property

ActionInputFlatModelMessageFormatParameters Property

Gets or sets the message format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
The message format parameters.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ParallelExecution Property

ActionInputFlatModelParallelExecution Property

Gets or sets a value indicating whether the actions are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the actions are to be executed in parallel; otherwise, .
Remarks
If this property is set to , the actions are executed synchronously in the order they exist in the Actions property.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.QueryResult Property

ActionInputFlatModelQueryResult Property

Gets or sets the query result.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel QueryResult { get; set; }
Public Property QueryResult As QueryResultFlatModel
    Get
    Set
public:
property QueryResultFlatModel^ QueryResult {
    QueryResultFlatModel^ get ();
    void set (QueryResultFlatModel^ value);
}
member QueryResult : QueryResultFlatModel with get, set

Property Value

Type: QueryResultFlatModel
The query result.
Remarks
This property will be automatically populated in for all actions being executed as a CorrectiveAction for a MonitorActivity. It may be helpful for the action to have contextual information concerning why the query failed when performing the corrective action.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.RunAs Property

ActionInputFlatModelRunAs Property

Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ServiceName Property

ActionInputFlatModelServiceName Property

Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ServiceOperation Property

ActionInputFlatModelServiceOperation Property

Gets or sets the service operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationEnum ServiceOperation { get; set; }
Public Property ServiceOperation As ServiceOperationEnum
    Get
    Set
public:
property ServiceOperationEnum ServiceOperation {
    ServiceOperationEnum get ();
    void set (ServiceOperationEnum value);
}
member ServiceOperation : ServiceOperationEnum with get, set

Property Value

Type: ServiceOperationEnum
The service operation.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.StartArguments Property

ActionInputFlatModelStartArguments Property

Gets or sets the arguments for the Start operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] StartArguments { get; set; }
Public Property StartArguments As String()
    Get
    Set
public:
property array<String^>^ StartArguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member StartArguments : string[] with get, set

Property Value

Type: String
The arguments for the Start operation.
Remarks
This property is ignored for all [F:ServiceOperation] values other than the Start operation.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Timeout Property

ActionInputFlatModelTimeout Property

Gets or sets the timeout for the wait operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Timeout { get; set; }
Public Property Timeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Timeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Timeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The timeout for the wait operation.
Remarks
If this value is , the action agent will wait indefinitely for the status to change.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForCompletion Property

ActionInputFlatModelWaitForCompletion Property

Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForCompletionTimeout Property

ActionInputFlatModelWaitForCompletionTimeout Property

Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForStatus Property

ActionInputFlatModelWaitForStatus Property

Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForStatus { get; set; }
Public Property WaitForStatus As Boolean
    Get
    Set
public:
property bool WaitForStatus {
    bool get ();
    void set (bool value);
}
member WaitForStatus : bool with get, set

Property Value

Type: Boolean
to wait for the service status to change; otherwise, .
Remarks
There is a corresponding service status change for each operation. For instance, if you've requested the Start operation, this action will wait for the service status to change to Running.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WorkingDirectory Property

ActionInputFlatModelWorkingDirectory Property

Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel Methods

The ActionInputFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionInputFlatModel Class


ActionInputModel Class

Represents input into a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsCompositeActionInputModel
DoubleTake.Web.ModelsLogActionInputModel
DoubleTake.Web.ModelsScriptActionInputModel
DoubleTake.Web.ModelsServiceOperationActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ActionInputModel
Public Class ActionInputModel
public ref class ActionInputModel
type ActionInputModel =  class end

The ActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionInputModel | Initializes a new instance of the ActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | QueryResult | Gets or sets the query result.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionInputModel Constructor

Initializes a new instance of the ActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionInputModel()
Public Sub New
public:
ActionInputModel()
new : unit -> ActionInputModel
See Also

Reference

ActionInputModel Class


ActionInputModel Properties

The ActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | QueryResult | Gets or sets the query result.
Top
See Also

Reference

ActionInputModel Class


ActionInputModel.Credentials Property

ActionInputModelCredentials Property

Gets or sets the credentials to be used by the action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

ActionInputModel Class


ActionInputModel.QueryResult Property

ActionInputModelQueryResult Property

Gets or sets the query result.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryResultModel QueryResult { get; set; }
Public Property QueryResult As QueryResultModel
    Get
    Set
public:
property QueryResultModel^ QueryResult {
    QueryResultModel^ get ();
    void set (QueryResultModel^ value);
}
member QueryResult : QueryResultModel with get, set

Property Value

Type: QueryResultModel
The query result.
Remarks
This property will be automatically populated in for all actions being executed as a CorrectiveAction for a MonitorActivity. It may be helpful for the action to have contextual information concerning why the query failed when performing the corrective action.
See Also

Reference

ActionInputModel Class


ActionInputModel Methods

The ActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionInputModel Class


ActionResultFlatModel Class

Represents the result of a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ActionResultFlatModel
Public Class ActionResultFlatModel
public ref class ActionResultFlatModel
type ActionResultFlatModel =  class end

The ActionResultFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResultFlatModel | Initializes a new instance of the ActionResultFlatModel class
Top
Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | ClassName | Gets or sets the name of the class.
Public property | Exception | Gets or sets the action exception.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionResultFlatModel Constructor

Initializes a new instance of the ActionResultFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionResultFlatModel()
Public Sub New
public:
ActionResultFlatModel()
new : unit -> ActionResultFlatModel
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel Properties

The ActionResultFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | ClassName | Gets or sets the name of the class.
Public property | Exception | Gets or sets the action exception.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ActionResults Property

ActionResultFlatModelActionResults Property

Gets or sets the action results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ActionResultFlatModel> ActionResults { get; set; }
Public Property ActionResults As IEnumerable(Of ActionResultFlatModel)
    Get
    Set
public:
property IEnumerable<ActionResultFlatModel^>^ ActionResults {
    IEnumerable<ActionResultFlatModel^>^ get ();
    void set (IEnumerable<ActionResultFlatModel^>^ value);
}
member ActionResults : IEnumerable<ActionResultFlatModel> with get, set

Property Value

Type: IEnumerable ActionResultFlatModel
The action results.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ClassName Property

ActionResultFlatModelClassName Property

Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The name of the class.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.Exception Property

ActionResultFlatModelException Property

Gets or sets the action exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The action exception.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ExitCode Property

ActionResultFlatModelExitCode Property

Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ExitTime Property

ActionResultFlatModelExitTime Property

Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ServiceStatus Property

ActionResultFlatModelServiceStatus Property

Gets or sets the service status after the operation has been executed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceStatus { get; set; }
Public Property ServiceStatus As String
    Get
    Set
public:
property String^ ServiceStatus {
    String^ get ();
    void set (String^ value);
}
member ServiceStatus : string with get, set

Property Value

Type: String
The service status after the operation has been executed.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.StartTime Property

ActionResultFlatModelStartTime Property

Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel Methods

The ActionResultFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionResultFlatModel Class


ActionResultModel Class

Represents the result of a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsCompositeActionResultModel
DoubleTake.Web.ModelsScriptActionResultModel
DoubleTake.Web.ModelsServiceOperationActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ActionResultModel
Public Class ActionResultModel
public ref class ActionResultModel
type ActionResultModel =  class end

The ActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResultModel | Initializes a new instance of the ActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionResultModel Constructor

Initializes a new instance of the ActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionResultModel()
Public Sub New
public:
ActionResultModel()
new : unit -> ActionResultModel
See Also

Reference

ActionResultModel Class


ActionResultModel Properties

The ActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Top
See Also

Reference

ActionResultModel Class


ActionResultModel.Exception Property

ActionResultModelException Property

Gets or sets the action exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The action exception.
See Also

Reference

ActionResultModel Class


ActionResultModel Methods

The ActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionResultModel Class


ActivationCodeInfoModel Class

Activation code information on appliance for V2V push install
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationCodeInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ActivationCodeInfoModel
Public Class ActivationCodeInfoModel
public ref class ActivationCodeInfoModel
type ActivationCodeInfoModel =  class end

The ActivationCodeInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeInfoModel | Initializes a new instance of the ActivationCodeInfoModel class
Top
Properties
 | Name | Description
Public property | ActivationCode | Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | DaysToExpire | Gets or sets the number of days until the license expires.
Public property | IsEval | Gets or sets a value indicating whether the license key is an evaluation license.
Public property | IsNodeLocked | Gets or sets a value indicating whether the license key must be activated.
Public property | IsValid | Gets or sets a value indicating whether the license key is valid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationCodeInfoModel Constructor

Initializes a new instance of the ActivationCodeInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeInfoModel()
Public Sub New
public:
ActivationCodeInfoModel()
new : unit -> ActivationCodeInfoModel
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel Properties

The ActivationCodeInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode | Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | DaysToExpire | Gets or sets the number of days until the license expires.
Public property | IsEval | Gets or sets a value indicating whether the license key is an evaluation license.
Public property | IsNodeLocked | Gets or sets a value indicating whether the license key must be activated.
Public property | IsValid | Gets or sets a value indicating whether the license key is valid.
Top
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.ActivationCode Property

ActivationCodeInfoModelActivationCode Property

Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ActivationCode { get; set; }
Public Property ActivationCode As String
    Get
    Set
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}
member ActivationCode : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.DaysToExpire Property

ActivationCodeInfoModelDaysToExpire Property

Gets or sets the number of days until the license expires.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int DaysToExpire { get; set; }
Public Property DaysToExpire As Integer
    Get
    Set
public:
property int DaysToExpire {
    int get ();
    void set (int value);
}
member DaysToExpire : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsEval Property

ActivationCodeInfoModelIsEval Property

Gets or sets a value indicating whether the license key is an evaluation license.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsEval { get; set; }
Public Property IsEval As Boolean
    Get
    Set
public:
property bool IsEval {
    bool get ();
    void set (bool value);
}
member IsEval : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsNodeLocked Property

ActivationCodeInfoModelIsNodeLocked Property

Gets or sets a value indicating whether the license key must be activated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsValid Property

ActivationCodeInfoModelIsValid Property

Gets or sets a value indicating whether the license key is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel Methods

The ActivationCodeInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationCodeInfoModel Class


AddressPersistedStateModel Class

Address persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAddressPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class AddressPersistedStateModel
Public NotInheritable Class AddressPersistedStateModel
public ref class AddressPersistedStateModel sealed
[<SealedAttribute>]
type AddressPersistedStateModel =  class end

The AddressPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | AddressPersistedStateModel | Initializes a new instance of the AddressPersistedStateModel class
Top
Properties
 | Name | Description
Public property | NteContext | Gets or sets the NTE context.
Public property | SourceAddresss | Gets or sets the source address.
Public property | TargetNic | Gets or sets the target NIC.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AddressPersistedStateModel Constructor

Initializes a new instance of the AddressPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AddressPersistedStateModel()
Public Sub New
public:
AddressPersistedStateModel()
new : unit -> AddressPersistedStateModel
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel Properties

The AddressPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | NteContext | Gets or sets the NTE context.
Public property | SourceAddresss | Gets or sets the source address.
Public property | TargetNic | Gets or sets the target NIC.
Top
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.NteContext Property

AddressPersistedStateModelNteContext Property

Gets or sets the NTE context.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int NteContext { get; set; }
Public Property NteContext As Integer
    Get
    Set
public:
property int NteContext {
    int get ();
    void set (int value);
}
member NteContext : int with get, set

Property Value

Type: Int32
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.SourceAddresss Property

AddressPersistedStateModelSourceAddresss Property

Gets or sets the source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddresss { get; set; }
Public Property SourceAddresss As String
    Get
    Set
public:
property String^ SourceAddresss {
    String^ get ();
    void set (String^ value);
}
member SourceAddresss : string with get, set

Property Value

Type: String
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.TargetNic Property

AddressPersistedStateModelTargetNic Property

Gets or sets the target NIC.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
member TargetNic : string with get, set

Property Value

Type: String
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel Methods

The AddressPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddressPersistedStateModel Class


AnalyticsInfoModel Class

Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAnalyticsInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class AnalyticsInfoModel
Public NotInheritable Class AnalyticsInfoModel
public ref class AnalyticsInfoModel sealed
[<SealedAttribute>]
type AnalyticsInfoModel =  class end

The AnalyticsInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | AnalyticsInfoModel | Initializes a new instance of the AnalyticsInfoModel class
Top
Properties
 | Name | Description
Public property | DoubleTakeVersion | Double Take version installed
Public property | HardwareInfo | Information about the server hardware.
Public property | OsInfo | Information about the server hardware.
Public property | ServerID | ID assigned to the server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsInfoModel Constructor

Initializes a new instance of the AnalyticsInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsInfoModel()
Public Sub New
public:
AnalyticsInfoModel()
new : unit -> AnalyticsInfoModel
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel Properties

The AnalyticsInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | DoubleTakeVersion | Double Take version installed
Public property | HardwareInfo | Information about the server hardware.
Public property | OsInfo | Information about the server hardware.
Public property | ServerID | ID assigned to the server.
Top
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel.DoubleTakeVersion Property

AnalyticsInfoModelDoubleTakeVersion Property

Double Take version installed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DoubleTakeVersion { get; set; }
Public Property DoubleTakeVersion As String
    Get
    Set
public:
property String^ DoubleTakeVersion {
    String^ get ();
    void set (String^ value);
}
member DoubleTakeVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel.HardwareInfo Property

AnalyticsInfoModelHardwareInfo Property

Information about the server hardware.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsServerHardwareModel HardwareInfo { get; set; }
Public Property HardwareInfo As AnalyticsServerHardwareModel
    Get
    Set
public:
property AnalyticsServerHardwareModel^ HardwareInfo {
    AnalyticsServerHardwareModel^ get ();
    void set (AnalyticsServerHardwareModel^ value);
}
member HardwareInfo : AnalyticsServerHardwareModel with get, set

Property Value

Type: AnalyticsServerHardwareModel
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel.OsInfo Property

AnalyticsInfoModelOsInfo Property

Information about the server hardware.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsServerOSModel OsInfo { get; set; }
Public Property OsInfo As AnalyticsServerOSModel
    Get
    Set
public:
property AnalyticsServerOSModel^ OsInfo {
    AnalyticsServerOSModel^ get ();
    void set (AnalyticsServerOSModel^ value);
}
member OsInfo : AnalyticsServerOSModel with get, set

Property Value

Type: AnalyticsServerOSModel
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel.ServerID Property

AnalyticsInfoModelServerID Property

ID assigned to the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServerID { get; set; }
Public Property ServerID As String
    Get
    Set
public:
property String^ ServerID {
    String^ get ();
    void set (String^ value);
}
member ServerID : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsInfoModel Class


AnalyticsInfoModel Methods

The AnalyticsInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnalyticsInfoModel Class


AnalyticsOSTypeModelEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum AnalyticsOSTypeModelEnum
Public Enumeration AnalyticsOSTypeModelEnum
public enum class AnalyticsOSTypeModelEnum
type AnalyticsOSTypeModelEnum
Members
Member name | Value | Description
WINDOWS | 0 | Server is running Windows
UBUNTU | 1 | Server is running Ubuntu
SUSE | 2 | Server is running SuSE
CENTOS | 3 | Server is running Centos or Red Hat
UNKNOWN | 4 | Don't know what the server is running.
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsPlatformModelEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum AnalyticsPlatformModelEnum
Public Enumeration AnalyticsPlatformModelEnum
public enum class AnalyticsPlatformModelEnum
type AnalyticsPlatformModelEnum
Members
Member name | Value | Description
PHYSICAL | 0 | Server is a physical as far as we can tell.
HYPERV_HOST | 1 | Server is a Hyper-V host.
HYPERV_GUEST | 2 | Server is a Hyper-V guest.
VMWARE | 3 | Server is running under VMware.
XEN | 4 | Server is running under Xen.
AZURE | 5 | Server is hosted by Azure.
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsServerHardwareModel Class

Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAnalyticsServerHardwareModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class AnalyticsServerHardwareModel
Public NotInheritable Class AnalyticsServerHardwareModel
public ref class AnalyticsServerHardwareModel sealed
[<SealedAttribute>]
type AnalyticsServerHardwareModel =  class end

The AnalyticsServerHardwareModel type exposes the following members.

Constructors
 | Name | Description
Public method | AnalyticsServerHardwareModel | Initializes a new instance of the AnalyticsServerHardwareModel class
Top
Properties
 | Name | Description
Public property | HardwarePlatform | Whether this is a physical or some form of virtual machine we understand.
Public property | Is32Bit | Is this a 32 bit server?
Public property | NumCPUs | Number of CPUs on the machine.
Public property | PhysicalMemory | Amount of physical memory installed on the machine.
Public property | VolumeInfo | Volume information for the machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsServerHardwareModel Constructor

Initializes a new instance of the AnalyticsServerHardwareModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsServerHardwareModel()
Public Sub New
public:
AnalyticsServerHardwareModel()
new : unit -> AnalyticsServerHardwareModel
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel Properties

The AnalyticsServerHardwareModel type exposes the following members.

Properties
 | Name | Description
Public property | HardwarePlatform | Whether this is a physical or some form of virtual machine we understand.
Public property | Is32Bit | Is this a 32 bit server?
Public property | NumCPUs | Number of CPUs on the machine.
Public property | PhysicalMemory | Amount of physical memory installed on the machine.
Public property | VolumeInfo | Volume information for the machine.
Top
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel.HardwarePlatform Property

AnalyticsServerHardwareModelHardwarePlatform Property

Whether this is a physical or some form of virtual machine we understand.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsPlatformModelEnum HardwarePlatform { get; set; }
Public Property HardwarePlatform As AnalyticsPlatformModelEnum
    Get
    Set
public:
property AnalyticsPlatformModelEnum HardwarePlatform {
    AnalyticsPlatformModelEnum get ();
    void set (AnalyticsPlatformModelEnum value);
}
member HardwarePlatform : AnalyticsPlatformModelEnum with get, set

Property Value

Type: AnalyticsPlatformModelEnum
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel.Is32Bit Property

AnalyticsServerHardwareModelIs32Bit Property

Is this a 32 bit server?

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Is32Bit { get; set; }
Public Property Is32Bit As Boolean
    Get
    Set
public:
property bool Is32Bit {
    bool get ();
    void set (bool value);
}
member Is32Bit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel.NumCPUs Property

AnalyticsServerHardwareModelNumCPUs Property

Number of CPUs on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int NumCPUs { get; set; }
Public Property NumCPUs As Integer
    Get
    Set
public:
property int NumCPUs {
    int get ();
    void set (int value);
}
member NumCPUs : int with get, set

Property Value

Type: Int32
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel.PhysicalMemory Property

AnalyticsServerHardwareModelPhysicalMemory Property

Amount of physical memory installed on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long PhysicalMemory { get; set; }
Public Property PhysicalMemory As Long
    Get
    Set
public:
property long long PhysicalMemory {
    long long get ();
    void set (long long value);
}
member PhysicalMemory : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel.VolumeInfo Property

AnalyticsServerHardwareModelVolumeInfo Property

Volume information for the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public List<AnalyticsVolumeModel> VolumeInfo { get; set; }
Public Property VolumeInfo As List(Of AnalyticsVolumeModel)
    Get
    Set
public:
property List<AnalyticsVolumeModel^>^ VolumeInfo {
    List<AnalyticsVolumeModel^>^ get ();
    void set (List<AnalyticsVolumeModel^>^ value);
}
member VolumeInfo : List<AnalyticsVolumeModel> with get, set

Property Value

Type: List AnalyticsVolumeModel
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerHardwareModel Methods

The AnalyticsServerHardwareModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnalyticsServerHardwareModel Class


AnalyticsServerOSModel Class

Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAnalyticsServerOSModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class AnalyticsServerOSModel
Public NotInheritable Class AnalyticsServerOSModel
public ref class AnalyticsServerOSModel sealed
[<SealedAttribute>]
type AnalyticsServerOSModel =  class end

The AnalyticsServerOSModel type exposes the following members.

Constructors
 | Name | Description
Public method | AnalyticsServerOSModel | Initializes a new instance of the AnalyticsServerOSModel class
Top
Properties
 | Name | Description
Public property | BootLoader | Grub Version (Linux)
Public property | IsClustered | Is the server a node in a cluster
Public property | KernelVersion | OS Version
Public property | MaxDotNetVersion | Maximum .Net version supported on the machine.
Public property | MaxPowerShellVersion | Maximum version of PowerShell supported on the server.
Public property | MinDotNetVersion | Minimum .Net version supported on the machine.
Public property | MinPowerShellVersion | Minimum version of PowerShell supported on the server.
Public property | OsType | What type of OS is installed on the machine.
Public property | OsVersion | OS Version
Public property | PowerShellRemoting | Whether PowerShell remoting is enabled.
Public property | ServerEdition | OS Edition
Public property | ServicePack | OS service pack
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsServerOSModel Constructor

Initializes a new instance of the AnalyticsServerOSModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsServerOSModel()
Public Sub New
public:
AnalyticsServerOSModel()
new : unit -> AnalyticsServerOSModel
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel Properties

The AnalyticsServerOSModel type exposes the following members.

Properties
 | Name | Description
Public property | BootLoader | Grub Version (Linux)
Public property | IsClustered | Is the server a node in a cluster
Public property | KernelVersion | OS Version
Public property | MaxDotNetVersion | Maximum .Net version supported on the machine.
Public property | MaxPowerShellVersion | Maximum version of PowerShell supported on the server.
Public property | MinDotNetVersion | Minimum .Net version supported on the machine.
Public property | MinPowerShellVersion | Minimum version of PowerShell supported on the server.
Public property | OsType | What type of OS is installed on the machine.
Public property | OsVersion | OS Version
Public property | PowerShellRemoting | Whether PowerShell remoting is enabled.
Public property | ServerEdition | OS Edition
Public property | ServicePack | OS service pack
Top
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.BootLoader Property

AnalyticsServerOSModelBootLoader Property

Grub Version (Linux)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string BootLoader { get; set; }
Public Property BootLoader As String
    Get
    Set
public:
property String^ BootLoader {
    String^ get ();
    void set (String^ value);
}
member BootLoader : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.IsClustered Property

AnalyticsServerOSModelIsClustered Property

Is the server a node in a cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
member IsClustered : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.KernelVersion Property

AnalyticsServerOSModelKernelVersion Property

OS Version

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string KernelVersion { get; set; }
Public Property KernelVersion As String
    Get
    Set
public:
property String^ KernelVersion {
    String^ get ();
    void set (String^ value);
}
member KernelVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.MaxDotNetVersion Property

AnalyticsServerOSModelMaxDotNetVersion Property

Maximum .Net version supported on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MaxDotNetVersion { get; set; }
Public Property MaxDotNetVersion As String
    Get
    Set
public:
property String^ MaxDotNetVersion {
    String^ get ();
    void set (String^ value);
}
member MaxDotNetVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.MaxPowerShellVersion Property

AnalyticsServerOSModelMaxPowerShellVersion Property

Maximum version of PowerShell supported on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MaxPowerShellVersion { get; set; }
Public Property MaxPowerShellVersion As String
    Get
    Set
public:
property String^ MaxPowerShellVersion {
    String^ get ();
    void set (String^ value);
}
member MaxPowerShellVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.MinDotNetVersion Property

AnalyticsServerOSModelMinDotNetVersion Property

Minimum .Net version supported on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MinDotNetVersion { get; set; }
Public Property MinDotNetVersion As String
    Get
    Set
public:
property String^ MinDotNetVersion {
    String^ get ();
    void set (String^ value);
}
member MinDotNetVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.MinPowerShellVersion Property

AnalyticsServerOSModelMinPowerShellVersion Property

Minimum version of PowerShell supported on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MinPowerShellVersion { get; set; }
Public Property MinPowerShellVersion As String
    Get
    Set
public:
property String^ MinPowerShellVersion {
    String^ get ();
    void set (String^ value);
}
member MinPowerShellVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.OsType Property

AnalyticsServerOSModelOsType Property

What type of OS is installed on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsOSTypeModelEnum OsType { get; set; }
Public Property OsType As AnalyticsOSTypeModelEnum
    Get
    Set
public:
property AnalyticsOSTypeModelEnum OsType {
    AnalyticsOSTypeModelEnum get ();
    void set (AnalyticsOSTypeModelEnum value);
}
member OsType : AnalyticsOSTypeModelEnum with get, set

Property Value

Type: AnalyticsOSTypeModelEnum
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.OsVersion Property

AnalyticsServerOSModelOsVersion Property

OS Version

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OsVersion { get; set; }
Public Property OsVersion As String
    Get
    Set
public:
property String^ OsVersion {
    String^ get ();
    void set (String^ value);
}
member OsVersion : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.PowerShellRemoting Property

AnalyticsServerOSModelPowerShellRemoting Property

Whether PowerShell remoting is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool PowerShellRemoting { get; set; }
Public Property PowerShellRemoting As Boolean
    Get
    Set
public:
property bool PowerShellRemoting {
    bool get ();
    void set (bool value);
}
member PowerShellRemoting : bool with get, set

Property Value

Type: Boolean
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.ServerEdition Property

AnalyticsServerOSModelServerEdition Property

OS Edition

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServerEdition { get; set; }
Public Property ServerEdition As String
    Get
    Set
public:
property String^ ServerEdition {
    String^ get ();
    void set (String^ value);
}
member ServerEdition : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel.ServicePack Property

AnalyticsServerOSModelServicePack Property

OS service pack

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServicePack { get; set; }
Public Property ServicePack As String
    Get
    Set
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
member ServicePack : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsServerOSModel Methods

The AnalyticsServerOSModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnalyticsServerOSModel Class


AnalyticsVolumeModel Class

Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAnalyticsVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class AnalyticsVolumeModel
Public NotInheritable Class AnalyticsVolumeModel
public ref class AnalyticsVolumeModel sealed
[<SealedAttribute>]
type AnalyticsVolumeModel =  class end

The AnalyticsVolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | AnalyticsVolumeModel | Initializes a new instance of the AnalyticsVolumeModel class
Top
Properties
 | Name | Description
Public property | FreeSpace | Amount of free space on the volume.
Public property | MountPoint | Mount point for the volume.
Public property | TotalSpace | Total space on the volume.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AnalyticsVolumeModel Constructor

Initializes a new instance of the AnalyticsVolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public AnalyticsVolumeModel()
Public Sub New
public:
AnalyticsVolumeModel()
new : unit -> AnalyticsVolumeModel
See Also

Reference

AnalyticsVolumeModel Class


AnalyticsVolumeModel Properties

The AnalyticsVolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | FreeSpace | Amount of free space on the volume.
Public property | MountPoint | Mount point for the volume.
Public property | TotalSpace | Total space on the volume.
Top
See Also

Reference

AnalyticsVolumeModel Class


AnalyticsVolumeModel.FreeSpace Property

AnalyticsVolumeModelFreeSpace Property

Amount of free space on the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
member FreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AnalyticsVolumeModel Class


AnalyticsVolumeModel.MountPoint Property

AnalyticsVolumeModelMountPoint Property

Mount point for the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
See Also

Reference

AnalyticsVolumeModel Class


AnalyticsVolumeModel.TotalSpace Property

AnalyticsVolumeModelTotalSpace Property

Total space on the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TotalSpace { get; set; }
Public Property TotalSpace As Long
    Get
    Set
public:
property long long TotalSpace {
    long long get ();
    void set (long long value);
}
member TotalSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

AnalyticsVolumeModel Class


AnalyticsVolumeModel Methods

The AnalyticsVolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnalyticsVolumeModel Class


BackConnectionResultsModel Class

Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBackConnectionResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class BackConnectionResultsModel
Public NotInheritable Class BackConnectionResultsModel
public ref class BackConnectionResultsModel sealed
[<SealedAttribute>]
type BackConnectionResultsModel =  class end

The BackConnectionResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | BackConnectionResultsModel | Initializes a new instance of the BackConnectionResultsModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Id | Gets or sets the identifier.
Public property | IsReady | Gets or sets a value indicating whether this instance is ready.
Public property | Log | Gets or sets the log.
Public property | StatusCode | Gets or sets the status code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BackConnectionResultsModel Constructor

Initializes a new instance of the BackConnectionResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public BackConnectionResultsModel()
Public Sub New
public:
BackConnectionResultsModel()
new : unit -> BackConnectionResultsModel
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel Properties

The BackConnectionResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Id | Gets or sets the identifier.
Public property | IsReady | Gets or sets a value indicating whether this instance is ready.
Public property | Log | Gets or sets the log.
Public property | StatusCode | Gets or sets the status code.
Top
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Exception Property

BackConnectionResultsModelException Property

Gets or sets the exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
member Exception : Exception with get, set

Property Value

Type: Exception
The exception.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Id Property

BackConnectionResultsModelId Property

Gets or sets the identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
The identifier.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.IsReady Property

BackConnectionResultsModelIsReady Property

Gets or sets a value indicating whether this instance is ready.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsReady { get; set; }
Public Property IsReady As Boolean
    Get
    Set
public:
property bool IsReady {
    bool get ();
    void set (bool value);
}
member IsReady : bool with get, set

Property Value

Type: Boolean
true if this instance is ready; otherwise, false.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Log Property

BackConnectionResultsModelLog Property

Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Log { get; set; }
Public Property Log As String
    Get
    Set
public:
property String^ Log {
    String^ get ();
    void set (String^ value);
}
member Log : string with get, set

Property Value

Type: String
The log.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.StatusCode Property

BackConnectionResultsModelStatusCode Property

Gets or sets the status code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public HttpStatusCode StatusCode { get; set; }
Public Property StatusCode As HttpStatusCode
    Get
    Set
public:
property HttpStatusCode StatusCode {
    HttpStatusCode get ();
    void set (HttpStatusCode value);
}
member StatusCode : HttpStatusCode with get, set

Property Value

Type: HttpStatusCode
The status code.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel Methods

The BackConnectionResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BackConnectionResultsModel Class


BooleanSettingModel Class

Boolean setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsBooleanSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class BooleanSettingModel : NamedSettingModel
Public Class BooleanSettingModel
    Inherits NamedSettingModel
public ref class BooleanSettingModel : public NamedSettingModel
type BooleanSettingModel =
    class
        inherit NamedSettingModel
    end

The BooleanSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanSettingModel | Initializes a new instance of the BooleanSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets a value indicating whether the setting is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BooleanSettingModel Constructor

Initializes a new instance of the BooleanSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public BooleanSettingModel()
Public Sub New
public:
BooleanSettingModel()
new : unit -> BooleanSettingModel
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel Properties

The BooleanSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets a value indicating whether the setting is true.
Top
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel.Value Property

BooleanSettingModelValue Property

Gets or sets a value indicating whether the setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Value { get; set; }
Public Property Value As Boolean
    Get
    Set
public:
property bool Value {
    bool get ();
    void set (bool value);
}
member Value : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel Methods

The BooleanSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BooleanSettingModel Class


ClusteredVirtualMachineModel Class

A clustered VM
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachineModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachineModel
Public Class ClusteredVirtualMachineModel
public ref class ClusteredVirtualMachineModel
type ClusteredVirtualMachineModel =  class end

The ClusteredVirtualMachineModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachineModel | Initializes a new instance of the ClusteredVirtualMachineModel class
Top
Properties
 | Name | Description
Public property | Id | Gets or sets the unique identifier.
Public property | Name | Gets or sets the name of the VM.
Public property | OwningNode | Gets or sets the current owning node.
Public property | StoragePath | Gets or sets the storage location.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachineModel Constructor

Initializes a new instance of the ClusteredVirtualMachineModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineModel()
Public Sub New
public:
ClusteredVirtualMachineModel()
new : unit -> ClusteredVirtualMachineModel
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel Properties

The ClusteredVirtualMachineModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets or sets the unique identifier.
Public property | Name | Gets or sets the name of the VM.
Public property | OwningNode | Gets or sets the current owning node.
Public property | StoragePath | Gets or sets the storage location.
Top
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.Id Property

ClusteredVirtualMachineModelId Property

Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.Name Property

ClusteredVirtualMachineModelName Property

Gets or sets the name of the VM.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.OwningNode Property

ClusteredVirtualMachineModelOwningNode Property

Gets or sets the current owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.StoragePath Property

ClusteredVirtualMachineModelStoragePath Property

Gets or sets the storage location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string StoragePath { get; set; }
Public Property StoragePath As String
    Get
    Set
public:
property String^ StoragePath {
    String^ get ();
    void set (String^ value);
}
member StoragePath : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel Methods

The ClusteredVirtualMachineModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineResourceInfoModel Class

Clustered virtual machine resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachineResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachineResourceInfoModel
Public Class ClusteredVirtualMachineResourceInfoModel
public ref class ClusteredVirtualMachineResourceInfoModel
type ClusteredVirtualMachineResourceInfoModel =  class end

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachineResourceInfoModel | Initializes a new instance of the ClusteredVirtualMachineResourceInfoModel class
Top
Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets the cluster VM configuration resource name.
Public property | VmGuid | Gets or sets the cluster VM GUID.
Public property | VmResourceName | Gets or sets the cluster VM resource name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachineResourceInfoModel Constructor

Initializes a new instance of the ClusteredVirtualMachineResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineResourceInfoModel()
Public Sub New
public:
ClusteredVirtualMachineResourceInfoModel()
new : unit -> ClusteredVirtualMachineResourceInfoModel
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel Properties

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets the cluster VM configuration resource name.
Public property | VmGuid | Gets or sets the cluster VM GUID.
Public property | VmResourceName | Gets or sets the cluster VM resource name.
Top
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmCfgResourceName Property

ClusteredVirtualMachineResourceInfoModelVmCfgResourceName Property

Gets or sets the cluster VM configuration resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmCfgResourceName { get; set; }
Public Property VmCfgResourceName As String
    Get
    Set
public:
property String^ VmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member VmCfgResourceName : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmGuid Property

ClusteredVirtualMachineResourceInfoModelVmGuid Property

Gets or sets the cluster VM GUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmGuid { get; set; }
Public Property VmGuid As String
    Get
    Set
public:
property String^ VmGuid {
    String^ get ();
    void set (String^ value);
}
member VmGuid : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmResourceName Property

ClusteredVirtualMachineResourceInfoModelVmResourceName Property

Gets or sets the cluster VM resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmResourceName { get; set; }
Public Property VmResourceName As String
    Get
    Set
public:
property String^ VmResourceName {
    String^ get ();
    void set (String^ value);
}
member VmResourceName : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel Methods

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachinesInfoModel Class

Clustered VM Groups
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachinesInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachinesInfoModel
Public Class ClusteredVirtualMachinesInfoModel
public ref class ClusteredVirtualMachinesInfoModel
type ClusteredVirtualMachinesInfoModel =  class end

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachinesInfoModel | Initializes a new instance of the ClusteredVirtualMachinesInfoModel class
Top
Properties
 | Name | Description
Public property | Group | Gets or sets the group name.
Public property | OwningNode | Gets or sets the owning node of the group.
Public property | VirtualMachine | Gets or sets the virtual machine information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachinesInfoModel Constructor

Initializes a new instance of the ClusteredVirtualMachinesInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachinesInfoModel()
Public Sub New
public:
ClusteredVirtualMachinesInfoModel()
new : unit -> ClusteredVirtualMachinesInfoModel
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel Properties

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Group | Gets or sets the group name.
Public property | OwningNode | Gets or sets the owning node of the group.
Public property | VirtualMachine | Gets or sets the virtual machine information.
Top
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.Group Property

ClusteredVirtualMachinesInfoModelGroup Property

Gets or sets the group name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.OwningNode Property

ClusteredVirtualMachinesInfoModelOwningNode Property

Gets or sets the owning node of the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.VirtualMachine Property

ClusteredVirtualMachinesInfoModelVirtualMachine Property

Gets or sets the virtual machine information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineModel[] VirtualMachine { get; set; }
Public Property VirtualMachine As ClusteredVirtualMachineModel()
    Get
    Set
public:
property array<ClusteredVirtualMachineModel^>^ VirtualMachine {
    array<ClusteredVirtualMachineModel^>^ get ();
    void set (array<ClusteredVirtualMachineModel^>^ value);
}
member VirtualMachine : ClusteredVirtualMachineModel[] with get, set

Property Value

Type: ClusteredVirtualMachineModel
The virtual machine information.
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel Methods

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusterGroupInfoModel Class

Cluster group information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterGroupInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ClusterGroupInfoModel
Public Class ClusterGroupInfoModel
public ref class ClusterGroupInfoModel
type ClusterGroupInfoModel =  class end

The ClusterGroupInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterGroupInfoModel | Initializes a new instance of the ClusterGroupInfoModel class
Top
Properties
 | Name | Description
Public property | Disks | Gets or sets the disks.
Public property | Group | Gets or sets the group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterGroupInfoModel Constructor

Initializes a new instance of the ClusterGroupInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusterGroupInfoModel()
Public Sub New
public:
ClusterGroupInfoModel()
new : unit -> ClusterGroupInfoModel
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel Properties

The ClusterGroupInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Disks | Gets or sets the disks.
Public property | Group | Gets or sets the group.
Top
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel.Disks Property

ClusterGroupInfoModelDisks Property

Gets or sets the disks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] Disks { get; set; }
Public Property Disks As String()
    Get
    Set
public:
property array<String^>^ Disks {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Disks : string[] with get, set

Property Value

Type: String
The disks.
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel.Group Property

ClusterGroupInfoModelGroup Property

Gets or sets the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
The group.
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel Methods

The ClusterGroupInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterGroupInfoModel Class


ClusterResourceInfoModel Class

Cluster resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ClusterResourceInfoModel
Public Class ClusterResourceInfoModel
public ref class ClusterResourceInfoModel
type ClusterResourceInfoModel =  class end

The ClusterResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterResourceInfoModel | Initializes a new instance of the ClusterResourceInfoModel class
Top
Properties
 | Name | Description
Public property | Class | Gets or sets the class.
Public property | Group | Gets or sets the group.
Public property | IsStorageCSV | Obsolete. Gets or sets a value indicating whether the storage is CSV.
Public property | Name | Gets or sets the name.
Public property | Owner | Gets or sets the owner.
Public property | PossibleOwners | Gets or sets the possible owners.
Public property | Type | Gets or sets the type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterResourceInfoModel Constructor

Initializes a new instance of the ClusterResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ClusterResourceInfoModel()
Public Sub New
public:
ClusterResourceInfoModel()
new : unit -> ClusterResourceInfoModel
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel Properties

The ClusterResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Class | Gets or sets the class.
Public property | Group | Gets or sets the group.
Public property | IsStorageCSV | Obsolete. Gets or sets a value indicating whether the storage is CSV.
Public property | Name | Gets or sets the name.
Public property | Owner | Gets or sets the owner.
Public property | PossibleOwners | Gets or sets the possible owners.
Public property | Type | Gets or sets the type.
Top
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Class Property

ClusterResourceInfoModelClass Property

Gets or sets the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Class { get; set; }
Public Property Class As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Class {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Class : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Group Property

ClusterResourceInfoModelGroup Property

Gets or sets the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.IsStorageCSV Property

ClusterResourceInfoModelIsStorageCSV Property

Note: This API is now obsolete.

Gets or sets a value indicating whether the storage is CSV.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)]
public bool IsStorageCSV { get; set; }
<ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)>
Public Property IsStorageCSV As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)]
property bool IsStorageCSV {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)>]
member IsStorageCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Name Property

ClusterResourceInfoModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Owner Property

ClusterResourceInfoModelOwner Property

Gets or sets the owner.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Owner { get; set; }
Public Property Owner As String
    Get
    Set
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}
member Owner : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.PossibleOwners Property

ClusterResourceInfoModelPossibleOwners Property

Gets or sets the possible owners.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] PossibleOwners { get; set; }
Public Property PossibleOwners As String()
    Get
    Set
public:
property array<String^>^ PossibleOwners {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PossibleOwners : string[] with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Type Property

ClusterResourceInfoModelType Property

Gets or sets the type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel Methods

The ClusterResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterResourceInfoModel Class


ComparisonOperationEnum Enumeration

Represents the types of comparison operations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ComparisonOperationEnum
Public Enumeration ComparisonOperationEnum
public enum class ComparisonOperationEnum
type ComparisonOperationEnum
Members
Member name | Value | Description
Equal | 0 | Indicates that the comparison operation succeeds of the items are equal.
LessThan | 1 | Indicates that the comparison operation succeeds if the first item is less than the second item.
LessThanOrEqual | 2 | Indicates that the comparison operation succeeds if the first item is less than or equal to the second item.
GreatherThan | 3 | Indicates that the comparison operation succeeds if the first item is greater than the second item.
GreatherThanOrEqual | 4 | Indicates that the comparison operation succeeds if the first item is greater than or equal to the second item.
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionInputModel Class

Represents the input to a Composite action agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsCompositeActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class CompositeActionInputModel : ActionInputModel
Public Class CompositeActionInputModel
    Inherits ActionInputModel
public ref class CompositeActionInputModel : public ActionInputModel
type CompositeActionInputModel =
    class
        inherit ActionInputModel
    end

The CompositeActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionInputModel | Initializes a new instance of the CompositeActionInputModel class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionInputModel Constructor

Initializes a new instance of the CompositeActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeActionInputModel()
Public Sub New
public:
CompositeActionInputModel()
new : unit -> CompositeActionInputModel
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel Properties

The CompositeActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel.Actions Property

CompositeActionInputModelActions Property

Gets or sets the enumerable collection of actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<MonitorActionModel> Actions { get; set; }
Public Property Actions As IEnumerable(Of MonitorActionModel)
    Get
    Set
public:
property IEnumerable<MonitorActionModel^>^ Actions {
    IEnumerable<MonitorActionModel^>^ get ();
    void set (IEnumerable<MonitorActionModel^>^ value);
}
member Actions : IEnumerable<MonitorActionModel> with get, set

Property Value

Type: IEnumerable MonitorActionModel
The enumerable collection of actions.
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel.ParallelExecution Property

CompositeActionInputModelParallelExecution Property

Gets or sets a value indicating whether the actions are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the actions are to be executed in parallel; otherwise, .
Remarks
If this property is set to , the actions are executed synchronously in the order they exist in the Actions property.
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel Methods

The CompositeActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeActionInputModel Class


CompositeActionResultModel Class

Represents the results of a composite action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsCompositeActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class CompositeActionResultModel : ActionResultModel
Public Class CompositeActionResultModel
    Inherits ActionResultModel
public ref class CompositeActionResultModel : public ActionResultModel
type CompositeActionResultModel =
    class
        inherit ActionResultModel
    end

The CompositeActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionResultModel | Initializes a new instance of the CompositeActionResultModel class
Top
Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionResultModel Constructor

Initializes a new instance of the CompositeActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeActionResultModel()
Public Sub New
public:
CompositeActionResultModel()
new : unit -> CompositeActionResultModel
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel Properties

The CompositeActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Top
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel.ActionResults Property

CompositeActionResultModelActionResults Property

Gets or sets the action results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ActionResultModel> ActionResults { get; set; }
Public Property ActionResults As IEnumerable(Of ActionResultModel)
    Get
    Set
public:
property IEnumerable<ActionResultModel^>^ ActionResults {
    IEnumerable<ActionResultModel^>^ get ();
    void set (IEnumerable<ActionResultModel^>^ value);
}
member ActionResults : IEnumerable<ActionResultModel> with get, set

Property Value

Type: IEnumerable ActionResultModel
The action results.
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel Methods

The CompositeActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeActionResultModel Class


CompositeQueryInputModel Class

Represents the input to a Composite query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsCompositeQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class CompositeQueryInputModel : QueryInputModel
Public Class CompositeQueryInputModel
    Inherits QueryInputModel
public ref class CompositeQueryInputModel : public QueryInputModel
type CompositeQueryInputModel =
    class
        inherit QueryInputModel
    end

The CompositeQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryInputModel | Initializes a new instance of the CompositeQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryInputModel Constructor

Initializes a new instance of the CompositeQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryInputModel()
Public Sub New
public:
CompositeQueryInputModel()
new : unit -> CompositeQueryInputModel
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel Properties

The CompositeQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.Operation Property

CompositeQueryInputModelOperation Property

Gets or sets the mode of query aggregation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryOperationEnum Operation { get; set; }
Public Property Operation As CompositeQueryOperationEnum
    Get
    Set
public:
property CompositeQueryOperationEnum Operation {
    CompositeQueryOperationEnum get ();
    void set (CompositeQueryOperationEnum value);
}
member Operation : CompositeQueryOperationEnum with get, set

Property Value

Type: CompositeQueryOperationEnum
The mode.
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.ParallelExecution Property

CompositeQueryInputModelParallelExecution Property

Gets or sets a value indicating whether the queries are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the queries are to be executed in parallel; otherwise, .
Remarks
If this property is set to
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.Queries Property

CompositeQueryInputModelQueries Property

Gets or sets the enumerable collection of queries.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryModel[] Queries { get; set; }
Public Property Queries As MonitorQueryModel()
    Get
    Set
public:
property array<MonitorQueryModel^>^ Queries {
    array<MonitorQueryModel^>^ get ();
    void set (array<MonitorQueryModel^>^ value);
}
member Queries : MonitorQueryModel[] with get, set

Property Value

Type: MonitorQueryModel
The the numerable collection of queries.
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel Methods

The CompositeQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryOperationEnum Enumeration

Defines how to evaluate a composite query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum CompositeQueryOperationEnum
Public Enumeration CompositeQueryOperationEnum
public enum class CompositeQueryOperationEnum
type CompositeQueryOperationEnum
Members
Member name | Value | Description
And | 0 | Conjunctive operation that fails the query if any of the queries fail.
Or | 1 | Disjunctive operation that fails the query if all of the queries fail.
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryResultModel Class

Represents the results of a composite query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsCompositeQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class CompositeQueryResultModel : QueryResultModel
Public Class CompositeQueryResultModel
    Inherits QueryResultModel
public ref class CompositeQueryResultModel : public QueryResultModel
type CompositeQueryResultModel =
    class
        inherit QueryResultModel
    end

The CompositeQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryResultModel | Initializes a new instance of the CompositeQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryResultModel Constructor

Initializes a new instance of the CompositeQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryResultModel()
Public Sub New
public:
CompositeQueryResultModel()
new : unit -> CompositeQueryResultModel
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel Properties

The CompositeQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel.QueryResults Property

CompositeQueryResultModelQueryResults Property

Gets or sets the query results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<QueryResultModel> QueryResults { get; set; }
Public Property QueryResults As IEnumerable(Of QueryResultModel)
    Get
    Set
public:
property IEnumerable<QueryResultModel^>^ QueryResults {
    IEnumerable<QueryResultModel^>^ get ();
    void set (IEnumerable<QueryResultModel^>^ value);
}
member QueryResults : IEnumerable<QueryResultModel> with get, set

Property Value

Type: IEnumerable QueryResultModel
The query results.
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel Methods

The CompositeQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeQueryResultModel Class


ConnectionConfigurationModel Class

Connection configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionConfigurationModel
Public NotInheritable Class ConnectionConfigurationModel
public ref class ConnectionConfigurationModel sealed
[<SealedAttribute>]
type ConnectionConfigurationModel =  class end

The ConnectionConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionConfigurationModel | Initializes a new instance of the ConnectionConfigurationModel class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionAlgorithm | Gets or sets the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Gets or sets a value indicating whether transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Gets or sets a value indicating whether transmitted data is encrypted.
Public property | JobType | Gets or sets a product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | Gets or sets the file path transformations applied to files replicated by this connection.
Public property | ReplicationSetName | Gets or sets the name of the replication set used for this connection.
Public property | SourceRoute | Gets or sets the source endpoint used by the target for this connection.
Public property | TargetLoaded | Gets or sets a value indicating whether the target is loaded.
Public property | TargetName | Gets or sets the host name of the target, if available.
Public property | TargetRoute | Gets or sets the target endpoint used by the source for this connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionConfigurationModel Constructor

Initializes a new instance of the ConnectionConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionConfigurationModel()
Public Sub New
public:
ConnectionConfigurationModel()
new : unit -> ConnectionConfigurationModel
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel Properties

The ConnectionConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionAlgorithm | Gets or sets the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Gets or sets a value indicating whether transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Gets or sets a value indicating whether transmitted data is encrypted.
Public property | JobType | Gets or sets a product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | Gets or sets the file path transformations applied to files replicated by this connection.
Public property | ReplicationSetName | Gets or sets the name of the replication set used for this connection.
Public property | SourceRoute | Gets or sets the source endpoint used by the target for this connection.
Public property | TargetLoaded | Gets or sets a value indicating whether the target is loaded.
Public property | TargetName | Gets or sets the host name of the target, if available.
Public property | TargetRoute | Gets or sets the target endpoint used by the source for this connection.
Top
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.BandwidthCollar Property

ConnectionConfigurationModelBandwidthCollar Property

Gets or sets the current bandwidth limit.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
member BandwidthCollar : int with get, set

Property Value

Type: Int32
Remarks
The bandwidth limit may vary according to the configured limit schedule.
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionAlgorithm Property

ConnectionConfigurationModelCompressionAlgorithm Property

Gets or sets the code for the compression algorithm being used for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As Integer
    Get
    Set
public:
property int CompressionAlgorithm {
    int get ();
    void set (int value);
}
member CompressionAlgorithm : int with get, set

Property Value

Type: Int32
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionEnabled Property

ConnectionConfigurationModelCompressionEnabled Property

Gets or sets a value indicating whether transmitted data is compressed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
member CompressionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionLevel Property

ConnectionConfigurationModelCompressionLevel Property

Gets or sets the level of compression configured on the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
member CompressionLevel : int with get, set

Property Value

Type: Int32
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.ConnectionId Property

ConnectionConfigurationModelConnectionId Property

Gets or sets a one-based index for each connection established in a Double-Take instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
member ConnectionId : int with get, set

Property Value

Type: Int32
Remarks
This series is reset each time the Double-Take service is restarted.
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.Encrypt Property

ConnectionConfigurationModelEncrypt Property

Gets or sets a value indicating whether transmitted data is encrypted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Encrypt { get; set; }
Public Property Encrypt As Boolean
    Get
    Set
public:
property bool Encrypt {
    bool get ();
    void set (bool value);
}
member Encrypt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.JobType Property

ConnectionConfigurationModelJobType Property

Gets or sets a product specific string indicating the type of job or workload protected by this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.PathTransformations Property

ConnectionConfigurationModelPathTransformations Property

Gets or sets the file path transformations applied to files replicated by this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.ReplicationSetName Property

ConnectionConfigurationModelReplicationSetName Property

Gets or sets the name of the replication set used for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.SourceRoute Property

ConnectionConfigurationModelSourceRoute Property

Gets or sets the source endpoint used by the target for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceRoute { get; set; }
Public Property SourceRoute As String
    Get
    Set
public:
property String^ SourceRoute {
    String^ get ();
    void set (String^ value);
}
member SourceRoute : string with get, set

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetLoaded Property

ConnectionConfigurationModelTargetLoaded Property

Gets or sets a value indicating whether the target is loaded.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
member TargetLoaded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetName Property

ConnectionConfigurationModelTargetName Property

Gets or sets the host name of the target, if available.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
member TargetName : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetRoute Property

ConnectionConfigurationModelTargetRoute Property

Gets or sets the target endpoint used by the source for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel Methods

The ConnectionConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionConfigurationModel Class


ConnectionInfoModel Class

Connection information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionInfoModel
Public NotInheritable Class ConnectionInfoModel
public ref class ConnectionInfoModel sealed
[<SealedAttribute>]
type ConnectionInfoModel =  class end

The ConnectionInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionInfoModel | Initializes a new instance of the ConnectionInfoModel class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionInfoModel Constructor

Initializes a new instance of the ConnectionInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionInfoModel()
Public Sub New
public:
ConnectionInfoModel()
new : unit -> ConnectionInfoModel
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel Properties

The ConnectionInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Configuration Property

ConnectionInfoModelConfiguration Property

Gets or sets the servers and settings involved in the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionConfigurationModel Configuration { get; set; }
Public Property Configuration As ConnectionConfigurationModel
    Get
    Set
public:
property ConnectionConfigurationModel^ Configuration {
    ConnectionConfigurationModel^ get ();
    void set (ConnectionConfigurationModel^ value);
}
member Configuration : ConnectionConfigurationModel with get, set

Property Value

Type: ConnectionConfigurationModel
The configuration.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Guid Property

ConnectionInfoModelGuid Property

Gets or sets the unique ID of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The GUID.
Remarks
This ID is generated by the Management Service and combines the multiple items required to uniquely identify a Double-Take engine connection into one. The two items required to uniquely identify a Double-Take engine connection are the replication set name and the target route.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.SourceAddresses Property

ConnectionInfoModelSourceAddresses Property

Gets or sets the source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] SourceAddresses { get; set; }
Public Property SourceAddresses As String()
    Get
    Set
public:
property array<String^>^ SourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SourceAddresses : string[] with get, set

Property Value

Type: String
The source addresses.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.SourceName Property

ConnectionInfoModelSourceName Property

Gets or sets the name of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
The name of the source.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Statistics Property

ConnectionInfoModelStatistics Property

Gets or sets various connection statistics collected by the Double-Take engine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatisticsModel Statistics { get; set; }
Public Property Statistics As ConnectionStatisticsModel
    Get
    Set
public:
property ConnectionStatisticsModel^ Statistics {
    ConnectionStatisticsModel^ get ();
    void set (ConnectionStatisticsModel^ value);
}
member Statistics : ConnectionStatisticsModel with get, set

Property Value

Type: ConnectionStatisticsModel
The statistics.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Status Property

ConnectionInfoModelStatus Property

Gets or sets the operational state of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatusModel Status { get; set; }
Public Property Status As ConnectionStatusModel
    Get
    Set
public:
property ConnectionStatusModel^ Status {
    ConnectionStatusModel^ get ();
    void set (ConnectionStatusModel^ value);
}
member Status : ConnectionStatusModel with get, set

Property Value

Type: ConnectionStatusModel
The status.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel Methods

The ConnectionInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionInfoModel Class


ConnectionModeEnum Enumeration

Connectio nmode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionModeEnum
Public Enumeration ConnectionModeEnum
public enum class ConnectionModeEnum
type ConnectionModeEnum
Members
Member name | Value | Description
Manual | 0 | Manual
Scheduled | 1 | Scheduled
ManualRestoreRequired | 2 | Manual restore required
ScheduledRestoreRequired | 3 | Scheduled restore required
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionParametersModel Class

Connection parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionParametersModel
Public NotInheritable Class ConnectionParametersModel
public ref class ConnectionParametersModel sealed
[<SealedAttribute>]
type ConnectionParametersModel =  class end

The ConnectionParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParametersModel | Initializes a new instance of the ConnectionParametersModel class
Top
Properties
 | Name | Description
Public property | CreateJobStatusResource | Gets or sets a value indicating whether [create job status resource].
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | EngineJobType | Gets or sets a value indicating the type of job for which this connection is to be utilized.
Public property | IsTdu | Gets or sets a value indicating whether or not connection is a TDU connection
Public property | JobId | Gets or sets the job identifier.
Public property | PathTransformations | Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.
Public property | ReplicationSetName | Gets or sets the name of the replication set to protect.
Public property | SourceClusterGroupName | Gets or sets the name of the source cluster group.
Public property | SourceIsClustered | Gets or sets a value indicating whether [source is clustered].
Public property | TargetAddress | Gets or sets the IP address on the target machine over which mirroring and replication should take place.
Public property | TargetEnginePort | Gets or sets the Double-Take engine port on the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionParametersModel Constructor

Initializes a new instance of the ConnectionParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionParametersModel()
Public Sub New
public:
ConnectionParametersModel()
new : unit -> ConnectionParametersModel
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel Properties

The ConnectionParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | CreateJobStatusResource | Gets or sets a value indicating whether [create job status resource].
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | EngineJobType | Gets or sets a value indicating the type of job for which this connection is to be utilized.
Public property | IsTdu | Gets or sets a value indicating whether or not connection is a TDU connection
Public property | JobId | Gets or sets the job identifier.
Public property | PathTransformations | Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.
Public property | ReplicationSetName | Gets or sets the name of the replication set to protect.
Public property | SourceClusterGroupName | Gets or sets the name of the source cluster group.
Public property | SourceIsClustered | Gets or sets a value indicating whether [source is clustered].
Public property | TargetAddress | Gets or sets the IP address on the target machine over which mirroring and replication should take place.
Public property | TargetEnginePort | Gets or sets the Double-Take engine port on the target.
Top
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.CreateJobStatusResource Property

ConnectionParametersModelCreateJobStatusResource Property

Gets or sets a value indicating whether [create job status resource].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool CreateJobStatusResource { get; set; }
Public Property CreateJobStatusResource As Boolean
    Get
    Set
public:
property bool CreateJobStatusResource {
    bool get ();
    void set (bool value);
}
member CreateJobStatusResource : bool with get, set

Property Value

Type: Boolean
true if [create job status resource]; otherwise, false.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.DependOnResources Property

ConnectionParametersModelDependOnResources Property

Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] DependOnResources { get; set; }
Public Property DependOnResources As String()
    Get
    Set
public:
property array<String^>^ DependOnResources {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DependOnResources : string[] with get, set

Property Value

Type: String
The list of resources to depend on.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.EngineJobType Property

ConnectionParametersModelEngineJobType Property

Gets or sets a value indicating the type of job for which this connection is to be utilized.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
One or more values from the EngineJobType enumeration.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.IsTdu Property

ConnectionParametersModelIsTdu Property

Gets or sets a value indicating whether or not connection is a TDU connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsTdu { get; set; }
Public Property IsTdu As Boolean
    Get
    Set
public:
property bool IsTdu {
    bool get ();
    void set (bool value);
}
member IsTdu : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.JobId Property

ConnectionParametersModelJobId Property

Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid JobId { get; set; }
Public Property JobId As Guid
    Get
    Set
public:
property Guid JobId {
    Guid get ();
    void set (Guid value);
}
member JobId : Guid with get, set

Property Value

Type: Guid
The job identifier.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.PathTransformations Property

ConnectionParametersModelPathTransformations Property

Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.ReplicationSetName Property

ConnectionParametersModelReplicationSetName Property

Gets or sets the name of the replication set to protect.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.SourceClusterGroupName Property

ConnectionParametersModelSourceClusterGroupName Property

Gets or sets the name of the source cluster group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceClusterGroupName { get; set; }
Public Property SourceClusterGroupName As String
    Get
    Set
public:
property String^ SourceClusterGroupName {
    String^ get ();
    void set (String^ value);
}
member SourceClusterGroupName : string with get, set

Property Value

Type: String
The name of the source cluster group.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.SourceIsClustered Property

ConnectionParametersModelSourceIsClustered Property

Gets or sets a value indicating whether [source is clustered].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool SourceIsClustered { get; set; }
Public Property SourceIsClustered As Boolean
    Get
    Set
public:
property bool SourceIsClustered {
    bool get ();
    void set (bool value);
}
member SourceIsClustered : bool with get, set

Property Value

Type: Boolean
true if [source is clustered]; otherwise, false.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.TargetAddress Property

ConnectionParametersModelTargetAddress Property

Gets or sets the IP address on the target machine over which mirroring and replication should take place.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
member TargetAddress : string with get, set

Property Value

Type: String
The target address.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.TargetEnginePort Property

ConnectionParametersModelTargetEnginePort Property

Gets or sets the Double-Take engine port on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
The target engine port.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel Methods

The ConnectionParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionParametersModel Class


ConnectionQualificationFailuresEnum Enumeration

Connection qualification failures

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionQualificationFailuresEnum
Public Enumeration ConnectionQualificationFailuresEnum
public enum class ConnectionQualificationFailuresEnum
type ConnectionQualificationFailuresEnum
Members
Member name | Value | Description
None | 0 | None
RoutableAddressDetermination | 1 | Routable address determination
CompressionAlgorithmDetermination | 2 | Compression algorithm determination
RestoreRequiredDetermination | 4 | Restore required determination
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionQualificationResultModel Class

Connection qualification result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionQualificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionQualificationResultModel
Public NotInheritable Class ConnectionQualificationResultModel
public ref class ConnectionQualificationResultModel sealed
[<SealedAttribute>]
type ConnectionQualificationResultModel =  class end

The ConnectionQualificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionQualificationResultModel | Initializes a new instance of the ConnectionQualificationResultModel class
Top
Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionQualificationResultModel Constructor

Initializes a new instance of the ConnectionQualificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionQualificationResultModel()
Public Sub New
public:
ConnectionQualificationResultModel()
new : unit -> ConnectionQualificationResultModel
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel Properties

The ConnectionQualificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.CompressionLevels Property

ConnectionQualificationResultModelCompressionLevels Property

Gets or sets the compression levels.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevelModel()
    Get
    Set
public:
property array<CompressionLevelModel^>^ CompressionLevels {
    array<CompressionLevelModel^>^ get ();
    void set (array<CompressionLevelModel^>^ value);
}
member CompressionLevels : CompressionLevelModel[] with get, set

Property Value

Type: CompressionLevelModel
The compression levels.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.ConnectionPort Property

ConnectionQualificationResultModelConnectionPort Property

Gets or sets the connection port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionPort { get; set; }
Public Property ConnectionPort As Integer
    Get
    Set
public:
property int ConnectionPort {
    int get ();
    void set (int value);
}
member ConnectionPort : int with get, set

Property Value

Type: Int32
The connection port.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.Failures Property

ConnectionQualificationResultModelFailures Property

Gets or sets the failures.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionQualificationFailuresEnum Failures { get; set; }
Public Property Failures As ConnectionQualificationFailuresEnum
    Get
    Set
public:
property ConnectionQualificationFailuresEnum Failures {
    ConnectionQualificationFailuresEnum get ();
    void set (ConnectionQualificationFailuresEnum value);
}
member Failures : ConnectionQualificationFailuresEnum with get, set

Property Value

Type: ConnectionQualificationFailuresEnum
The failures.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.IsQualified Property

ConnectionQualificationResultModelIsQualified Property

Gets or sets a value indicating whether this instance is qualified.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
member IsQualified : bool with get, set

Property Value

Type: Boolean
if this instance is qualified; otherwise, .
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.IsRestoreRequired Property

ConnectionQualificationResultModelIsRestoreRequired Property

Gets or sets a value indicating whether this instance is restore required.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
member IsRestoreRequired : bool with get, set

Property Value

Type: Boolean
if this instance is restore required; otherwise, .
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.RecommendedStartParameters Property

ConnectionQualificationResultModelRecommendedStartParameters Property

Gets or sets the recommended start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel RecommendedStartParameters { get; set; }
Public Property RecommendedStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ RecommendedStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member RecommendedStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The recommended start parameters.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.RoutableAddresses Property

ConnectionQualificationResultModelRoutableAddresses Property

Gets or sets the routable addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] RoutableAddresses { get; set; }
Public Property RoutableAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ RoutableAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member RoutableAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
The routable addresses.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.TargetMachineName Property

ConnectionQualificationResultModelTargetMachineName Property

Gets or sets the name of the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
The name of the target machine.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel Methods

The ConnectionQualificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionStatisticsModel Class

Connection statistics.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStatisticsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStatisticsModel
Public NotInheritable Class ConnectionStatisticsModel
public ref class ConnectionStatisticsModel sealed
[<SealedAttribute>]
type ConnectionStatisticsModel =  class end

The ConnectionStatisticsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatisticsModel | Initializes a new instance of the ConnectionStatisticsModel class
Top
Properties
 | Name | Description
Public property | CurrentTime | Gets or sets the CurrentTime.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the repset calc is in progress.
Public property | Rpl | Gets or sets the Rpl.
Public property | Rpt | Gets or sets the Rpt.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStatisticsModel Constructor

Initializes a new instance of the ConnectionStatisticsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatisticsModel()
Public Sub New
public:
ConnectionStatisticsModel()
new : unit -> ConnectionStatisticsModel
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel Properties

The ConnectionStatisticsModel type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTime | Gets or sets the CurrentTime.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the repset calc is in progress.
Public property | Rpl | Gets or sets the Rpl.
Public property | Rpt | Gets or sets the Rpt.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.CurrentTime Property

ConnectionStatisticsModelCurrentTime Property

Gets or sets the CurrentTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long CurrentTime { get; set; }
Public Property CurrentTime As Long
    Get
    Set
public:
property long long CurrentTime {
    long long get ();
    void set (long long value);
}
member CurrentTime : int64 with get, set

Property Value

Type: Int64
The CurrentTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.DiskQueueBytes Property

ConnectionStatisticsModelDiskQueueBytes Property

Gets or sets the number of bytes in the disk queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
member DiskQueueBytes : int64 with get, set

Property Value

Type: Int64
The disk queue bytes.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesRemaining Property

ConnectionStatisticsModelMirrorBytesRemaining Property

Gets or sets the mirror bytes remaining.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
member MirrorBytesRemaining : int64 with get, set

Property Value

Type: Int64
The mirror bytes remaining.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesSent Property

ConnectionStatisticsModelMirrorBytesSent Property

Gets or sets the mirror bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
member MirrorBytesSent : int64 with get, set

Property Value

Type: Int64
The mirror bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesSkipped Property

ConnectionStatisticsModelMirrorBytesSkipped Property

Gets or sets the mirror bytes skipped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
member MirrorBytesSkipped : int64 with get, set

Property Value

Type: Int64
The mirror bytes skipped.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesTransmitted Property

ConnectionStatisticsModelMirrorBytesTransmitted Property

Gets or sets the mirror bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
member MirrorBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The mirror bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorEndTime Property

ConnectionStatisticsModelMirrorEndTime Property

Gets or sets the MirrorEndTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorEndTime { get; set; }
Public Property MirrorEndTime As Long
    Get
    Set
public:
property long long MirrorEndTime {
    long long get ();
    void set (long long value);
}
member MirrorEndTime : int64 with get, set

Property Value

Type: Int64
The MirrorEndTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorOpsQueued Property

ConnectionStatisticsModelMirrorOpsQueued Property

Gets or sets the mirror ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
member MirrorOpsQueued : int64 with get, set

Property Value

Type: Int64
The mirror ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorPermillage Property

ConnectionStatisticsModelMirrorPermillage Property

Gets or sets the mirror permillage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
member MirrorPermillage : int16 with get, set

Property Value

Type: Int16
The mirror permillage.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorStartTime Property

ConnectionStatisticsModelMirrorStartTime Property

Gets or sets the MirrorStartTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorStartTime { get; set; }
Public Property MirrorStartTime As Long
    Get
    Set
public:
property long long MirrorStartTime {
    long long get ();
    void set (long long value);
}
member MirrorStartTime : int64 with get, set

Property Value

Type: Int64
The MirrorStartTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesQueued Property

ConnectionStatisticsModelReplicationBytesQueued Property

Gets or sets the replication bytes queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
member ReplicationBytesQueued : int64 with get, set

Property Value

Type: Int64
The replication bytes queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesSent Property

ConnectionStatisticsModelReplicationBytesSent Property

Gets or sets the replication bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
member ReplicationBytesSent : int64 with get, set

Property Value

Type: Int64
The replication bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesTransmitted Property

ConnectionStatisticsModelReplicationBytesTransmitted Property

Gets or sets the replication bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
member ReplicationBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The replication bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationOpsQueued Property

ConnectionStatisticsModelReplicationOpsQueued Property

Gets or sets the replication ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
member ReplicationOpsQueued : int64 with get, set

Property Value

Type: Int64
The replication ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationSetCalcInProgress Property

ConnectionStatisticsModelReplicationSetCalcInProgress Property

Gets or sets a value indicating whether the repset calc is in progress.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
member ReplicationSetCalcInProgress : bool with get, set

Property Value

Type: Boolean
if the repset calculation is in progress; otherwise, .
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.Rpl Property

ConnectionStatisticsModelRpl Property

Gets or sets the Rpl.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long Rpl { get; set; }
Public Property Rpl As Long
    Get
    Set
public:
property long long Rpl {
    long long get ();
    void set (long long value);
}
member Rpl : int64 with get, set

Property Value

Type: Int64
The Rpl.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.Rpt Property

ConnectionStatisticsModelRpt Property

Gets or sets the Rpt.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long Rpt { get; set; }
Public Property Rpt As Long
    Get
    Set
public:
property long long Rpt {
    long long get ();
    void set (long long value);
}
member Rpt : int64 with get, set

Property Value

Type: Int64
The Rpt.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalBytesSent Property

ConnectionStatisticsModelTotalBytesSent Property

Gets or sets the total bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
member TotalBytesSent : int64 with get, set

Property Value

Type: Int64
The total bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalBytesTransmitted Property

ConnectionStatisticsModelTotalBytesTransmitted Property

Gets or sets the total bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
member TotalBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The total bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalOpsQueued Property

ConnectionStatisticsModelTotalOpsQueued Property

Gets or sets the total ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
member TotalOpsQueued : int64 with get, set

Property Value

Type: Int64
The total ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel Methods

The ConnectionStatisticsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatusModel Class

The connection status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStatusModel
Public NotInheritable Class ConnectionStatusModel
public ref class ConnectionStatusModel sealed
[<SealedAttribute>]
type ConnectionStatusModel =  class end

The ConnectionStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatusModel | Initializes a new instance of the ConnectionStatusModel class
Top
Properties
 | Name | Description
Public property | Alive | Gets or sets a value indicating whether the connection is active.
Public property | CmdRspQueueState | Gets or sets the QueueStateEnum of the command/response queue.
Public property | ConnectionMode | Gets or sets the connection mode.
Public property | Error | Gets or sets a value indicating whether the connection experienced a network error.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | Gets or sets the QueueStateEnum of the mirror queue.
Public property | MirrorSize | Gets or sets the size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | PeerMemoryLow | Gets or sets a value indicating whether there's low memory on the target.
Public property | PendingAckQueueFull | Gets or sets a value indicating whether the pending ACK queue is full.
Public property | ReplicationQueueState | Gets or sets the QueueStateEnum of the replication queue.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.
Public property | RetransmitQueueState | Gets or sets the QueueStateEnum of the retransmit queue.
Public property | StartTime | Gets or sets the start time.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirror.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStatusModel Constructor

Initializes a new instance of the ConnectionStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatusModel()
Public Sub New
public:
ConnectionStatusModel()
new : unit -> ConnectionStatusModel
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel Properties

The ConnectionStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Alive | Gets or sets a value indicating whether the connection is active.
Public property | CmdRspQueueState | Gets or sets the QueueStateEnum of the command/response queue.
Public property | ConnectionMode | Gets or sets the connection mode.
Public property | Error | Gets or sets a value indicating whether the connection experienced a network error.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | Gets or sets the QueueStateEnum of the mirror queue.
Public property | MirrorSize | Gets or sets the size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | PeerMemoryLow | Gets or sets a value indicating whether there's low memory on the target.
Public property | PendingAckQueueFull | Gets or sets a value indicating whether the pending ACK queue is full.
Public property | ReplicationQueueState | Gets or sets the QueueStateEnum of the replication queue.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.
Public property | RetransmitQueueState | Gets or sets the QueueStateEnum of the retransmit queue.
Public property | StartTime | Gets or sets the start time.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirror.
Top
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Alive Property

ConnectionStatusModelAlive Property

Gets or sets a value indicating whether the connection is active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
member Alive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.CmdRspQueueState Property

ConnectionStatusModelCmdRspQueueState Property

Gets or sets the QueueStateEnum of the command/response queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum CmdRspQueueState { get; set; }
Public Property CmdRspQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum CmdRspQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member CmdRspQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ConnectionMode Property

ConnectionStatusModelConnectionMode Property

Gets or sets the connection mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionModeEnum ConnectionMode { get; set; }
Public Property ConnectionMode As ConnectionModeEnum
    Get
    Set
public:
property ConnectionModeEnum ConnectionMode {
    ConnectionModeEnum get ();
    void set (ConnectionModeEnum value);
}
member ConnectionMode : ConnectionModeEnum with get, set

Property Value

Type: ConnectionModeEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Error Property

ConnectionStatusModelError Property

Gets or sets a value indicating whether the connection experienced a network error.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Error { get; set; }
Public Property Error As Boolean
    Get
    Set
public:
property bool Error {
    bool get ();
    void set (bool value);
}
member Error : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.InitialMirrorComplete Property

ConnectionStatusModelInitialMirrorComplete Property

Gets or sets a value indicating whether an initial mirror has completed for the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
if an initial mirror has completed; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.IsRestoreRequired Property

ConnectionStatusModelIsRestoreRequired Property

Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
member IsRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.IsScheduled Property

ConnectionStatusModelIsScheduled Property

Gets or sets a value indicating whether the transmission is in a scheduled state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsScheduled { get; set; }
Public Property IsScheduled As Boolean
    Get
    Set
public:
property bool IsScheduled {
    bool get ();
    void set (bool value);
}
member IsScheduled : bool with get, set

Property Value

Type: Boolean
if transmission for this instance is scheduled; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorQueueState Property

ConnectionStatusModelMirrorQueueState Property

Gets or sets the QueueStateEnum of the mirror queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum MirrorQueueState { get; set; }
Public Property MirrorQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum MirrorQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member MirrorQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorSize Property

ConnectionStatusModelMirrorSize Property

Gets or sets the size of the replication set in bytes, if it has been calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long MirrorSize { get; set; }
Public Property MirrorSize As Long
    Get
    Set
public:
property long long MirrorSize {
    long long get ();
    void set (long long value);
}
member MirrorSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorState Property

ConnectionStatusModelMirrorState Property

Gets or sets the operational state of the mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
member MirrorState : MirrorState with get, set

Property Value

Type: MirrorState
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.PeerMemoryLow Property

ConnectionStatusModelPeerMemoryLow Property

Gets or sets a value indicating whether there's low memory on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
member PeerMemoryLow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.PendingAckQueueFull Property

ConnectionStatusModelPendingAckQueueFull Property

Gets or sets a value indicating whether the pending ACK queue is full.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool PendingAckQueueFull { get; set; }
Public Property PendingAckQueueFull As Boolean
    Get
    Set
public:
property bool PendingAckQueueFull {
    bool get ();
    void set (bool value);
}
member PendingAckQueueFull : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ReplicationQueueState Property

ConnectionStatusModelReplicationQueueState Property

Gets or sets the QueueStateEnum of the replication queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum ReplicationQueueState { get; set; }
Public Property ReplicationQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum ReplicationQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member ReplicationQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ReplicationState Property

ConnectionStatusModelReplicationState Property

Gets or sets the operational state of replication.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
member ReplicationState : ReplicationState with get, set

Property Value

Type: ReplicationState
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Restoring Property

ConnectionStatusModelRestoring Property

Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
member Restoring : bool with get, set

Property Value

Type: Boolean
if the connection is restoring; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.RetransmitQueueState Property

ConnectionStatusModelRetransmitQueueState Property

Gets or sets the QueueStateEnum of the retransmit queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum RetransmitQueueState { get; set; }
Public Property RetransmitQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum RetransmitQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member RetransmitQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.StartTime Property

ConnectionStatusModelStartTime Property

Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.TargetState Property

ConnectionStatusModelTargetState Property

Gets or sets the known operational states of the connection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
member TargetState : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.TransmissionMode Property

ConnectionStatusModelTransmissionMode Property

Gets or sets the operational state of replication and mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
member TransmissionMode : TransmissionMode with get, set

Property Value

Type: TransmissionMode
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel Methods

The ConnectionStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStatusModel Class


ControlledServerInfoModel Class

Represents information about a server managed by Controller Service
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsControlledServerInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ControlledServerInfoModel
Public Class ControlledServerInfoModel
public ref class ControlledServerInfoModel
type ControlledServerInfoModel =  class end

The ControlledServerInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ControlledServerInfoModel | Initializes a new instance of the ControlledServerInfoModel class
Top
Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information.
Public property | ServerInfo | Gets or sets the server information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ControlledServerInfoModel Constructor

Initializes a new instance of the ControlledServerInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ControlledServerInfoModel()
Public Sub New
public:
ControlledServerInfoModel()
new : unit -> ControlledServerInfoModel
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel Properties

The ControlledServerInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information.
Public property | ServerInfo | Gets or sets the server information.
Top
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel.ProductInfo Property

ControlledServerInfoModelProductInfo Property

Gets or sets the product information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel ProductInfo { get; set; }
Public Property ProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ ProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member ProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
The product information.
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel.ServerInfo Property

ControlledServerInfoModelServerInfo Property

Gets or sets the server information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoModel ServerInfo { get; set; }
Public Property ServerInfo As ServerInfoModel
    Get
    Set
public:
property ServerInfoModel^ ServerInfo {
    ServerInfoModel^ get ();
    void set (ServerInfoModel^ value);
}
member ServerInfo : ServerInfoModel with get, set

Property Value

Type: ServerInfoModel
The server information.
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel Methods

The ControlledServerInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoSimpleModel Class

Represents information about a server managed by Controller Service
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsControlledServerInfoSimpleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ControlledServerInfoSimpleModel
Public Class ControlledServerInfoSimpleModel
public ref class ControlledServerInfoSimpleModel
type ControlledServerInfoSimpleModel =  class end

The ControlledServerInfoSimpleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ControlledServerInfoSimpleModel | Initializes a new instance of the ControlledServerInfoSimpleModel class
Top
Properties
 | Name | Description
Public property | ServerName | Gets or sets the name of the server.
Public property | UniqueId | Gets or sets the unique identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ControlledServerInfoSimpleModel Constructor

Initializes a new instance of the ControlledServerInfoSimpleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ControlledServerInfoSimpleModel()
Public Sub New
public:
ControlledServerInfoSimpleModel()
new : unit -> ControlledServerInfoSimpleModel
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel Properties

The ControlledServerInfoSimpleModel type exposes the following members.

Properties
 | Name | Description
Public property | ServerName | Gets or sets the name of the server.
Public property | UniqueId | Gets or sets the unique identifier.
Top
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel.ServerName Property

ControlledServerInfoSimpleModelServerName Property

Gets or sets the name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
The name of the server.
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel.UniqueId Property

ControlledServerInfoSimpleModelUniqueId Property

Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique identifier.
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel Methods

The ControlledServerInfoSimpleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlOperationEnum Enumeration

Control operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ControlOperationEnum
Public Enumeration ControlOperationEnum
public enum class ControlOperationEnum
type ControlOperationEnum
Members
Member name | Value | Description
Start | 0 | Start the operation.
Stop | 1 | Stop the operation.
Pause | 2 | Pause the operation.
Resume | 3 | Resume the operation.
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusteredResourceStateEnum Enumeration

Core clustered resource state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum CoreClusteredResourceStateEnum
Public Enumeration CoreClusteredResourceStateEnum
public enum class CoreClusteredResourceStateEnum
type CoreClusteredResourceStateEnum
Members
Member name | Value | Description
Unknown | -1 | The unknown
Inherited | 0 | The inherited
Initializing | 1 | The initializing
Online | 2 | The online
Offline | 3 | The offline
Failed | 4 | The failed
Pending | 128 | The pending
OnlinePending | 129 | The online pending
OfflinePending | 130 | The offline pending
Added | 200 | The added
Deleted | 201 | The deleted
ResourceDoesNotExist | 1000 | The resource does not exist
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusterInfoModel Class

Data specific to the cluster. This is data that stays with the cluster during roll-over.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreClusterInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class CoreClusterInfoModel
Public Class CoreClusterInfoModel
public ref class CoreClusterInfoModel
type CoreClusterInfoModel =  class end

The CoreClusterInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreClusterInfoModel | Initializes a new instance of the CoreClusterInfoModel class
Top
Properties
 | Name | Description
Public property | ClusterUniqueId | Gets or sets the unique id assigned to the cluster.
Public property | CoreClusterIPAddresses | Gets or sets the IP Addresses specific to the cluster.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusterInfoModel Constructor

Initializes a new instance of the CoreClusterInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreClusterInfoModel()
Public Sub New
public:
CoreClusterInfoModel()
new : unit -> CoreClusterInfoModel
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel Properties

The CoreClusterInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterUniqueId | Gets or sets the unique id assigned to the cluster.
Public property | CoreClusterIPAddresses | Gets or sets the IP Addresses specific to the cluster.
Top
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel.ClusterUniqueId Property

CoreClusterInfoModelClusterUniqueId Property

Gets or sets the unique id assigned to the cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ClusterUniqueId { get; set; }
Public Property ClusterUniqueId As String
    Get
    Set
public:
property String^ ClusterUniqueId {
    String^ get ();
    void set (String^ value);
}
member ClusterUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel.CoreClusterIPAddresses Property

CoreClusterInfoModelCoreClusterIPAddresses Property

Gets or sets the IP Addresses specific to the cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IPAddressModel[] CoreClusterIPAddresses { get; set; }
Public Property CoreClusterIPAddresses As IPAddressModel()
    Get
    Set
public:
property array<IPAddressModel^>^ CoreClusterIPAddresses {
    array<IPAddressModel^>^ get ();
    void set (array<IPAddressModel^>^ value);
}
member CoreClusterIPAddresses : IPAddressModel[] with get, set

Property Value

Type: IPAddressModel
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel Methods

The CoreClusterInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreClusterInfoModel Class


CoreConnectionPersistedStateModel Class

The core connection persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionPersistedStateModel
Public NotInheritable Class CoreConnectionPersistedStateModel
public ref class CoreConnectionPersistedStateModel sealed
[<SealedAttribute>]
type CoreConnectionPersistedStateModel =  class end

The CoreConnectionPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionPersistedStateModel | Initializes a new instance of the CoreConnectionPersistedStateModel class
Top
Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the engine connection id.
Public property | Id | Gets or sets the core connection guid
Public property | InitialMirrorComplete | Gets or sets a value indicating whether the initial mirror is complete
Public property | SourceAddress | Gets or sets the source address.
Public property | SourceEnginePort | Gets or sets the source engine port.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionPersistedStateModel Constructor

Initializes a new instance of the CoreConnectionPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel()
Public Sub New
public:
CoreConnectionPersistedStateModel()
new : unit -> CoreConnectionPersistedStateModel
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel Properties

The CoreConnectionPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the engine connection id.
Public property | Id | Gets or sets the core connection guid
Public property | InitialMirrorComplete | Gets or sets a value indicating whether the initial mirror is complete
Public property | SourceAddress | Gets or sets the source address.
Public property | SourceEnginePort | Gets or sets the source engine port.
Top
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.EngineConnectionId Property

CoreConnectionPersistedStateModelEngineConnectionId Property

Gets or sets the engine connection id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
member EngineConnectionId : int with get, set

Property Value

Type: Int32
The engine connection id.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.Id Property

CoreConnectionPersistedStateModelId Property

Gets or sets the core connection guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.InitialMirrorComplete Property

CoreConnectionPersistedStateModelInitialMirrorComplete Property

Gets or sets a value indicating whether the initial mirror is complete

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.SourceAddress Property

CoreConnectionPersistedStateModelSourceAddress Property

Gets or sets the source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
member SourceAddress : string with get, set

Property Value

Type: String
The source address.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.SourceEnginePort Property

CoreConnectionPersistedStateModelSourceEnginePort Property

Gets or sets the source engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
member SourceEnginePort : int with get, set

Property Value

Type: Int32
The source engine port.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel Methods

The CoreConnectionPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionPersistedStateModel Class


CreateConnectionModel Class

This class represents the parameters passed into the api/connections/create call
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateConnectionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateConnectionModel
Public NotInheritable Class CreateConnectionModel
public ref class CreateConnectionModel sealed
[<SealedAttribute>]
type CreateConnectionModel =  class end

The CreateConnectionModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateConnectionModel | Initializes a new instance of the CreateConnectionModel class
Top
Properties
 | Name | Description
Public property | ConnectionParameters | Gets or sets the connection parameters.
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | Rules | Gets or sets the rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateConnectionModel Constructor

Initializes a new instance of the CreateConnectionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CreateConnectionModel()
Public Sub New
public:
CreateConnectionModel()
new : unit -> CreateConnectionModel
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel Properties

The CreateConnectionModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionParameters | Gets or sets the connection parameters.
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | Rules | Gets or sets the rules.
Top
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.ConnectionParameters Property

CreateConnectionModelConnectionParameters Property

Gets or sets the connection parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionParametersModel ConnectionParameters { get; set; }
Public Property ConnectionParameters As ConnectionParametersModel
    Get
    Set
public:
property ConnectionParametersModel^ ConnectionParameters {
    ConnectionParametersModel^ get ();
    void set (ConnectionParametersModel^ value);
}
member ConnectionParameters : ConnectionParametersModel with get, set

Property Value

Type: ConnectionParametersModel
The connection parameters.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.ConnectionStartParameters Property

CreateConnectionModelConnectionStartParameters Property

Gets or sets the connection start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The connection start parameters.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.Rules Property

CreateConnectionModelRules Property

Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] Rules { get; set; }
Public Property Rules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ Rules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member Rules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The rules.
Remarks
This field is only used for creating connections on clustered servers.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel Methods

The CreateConnectionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateConnectionModel Class


CreateFromExistingJobModel Class

Contains the information needed to create a new job from and existing job.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateFromExistingJobModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateFromExistingJobModel
Public NotInheritable Class CreateFromExistingJobModel
public ref class CreateFromExistingJobModel sealed
[<SealedAttribute>]
type CreateFromExistingJobModel =  class end

The CreateFromExistingJobModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateFromExistingJobModel | Initializes a new instance of the CreateFromExistingJobModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials.
Public property | JobInfo | Gets or sets the job information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateFromExistingJobModel Constructor

Initializes a new instance of the CreateFromExistingJobModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CreateFromExistingJobModel()
Public Sub New
public:
CreateFromExistingJobModel()
new : unit -> CreateFromExistingJobModel
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel Properties

The CreateFromExistingJobModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials.
Public property | JobInfo | Gets or sets the job information.
Top
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel.Credentials Property

CreateFromExistingJobModelCredentials Property

Gets or sets the credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel Credentials { get; set; }
Public Property Credentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ Credentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member Credentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The credentials.
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel.JobInfo Property

CreateFromExistingJobModelJobInfo Property

Gets or sets the job information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobInfoPrivateModel JobInfo { get; set; }
Public Property JobInfo As JobInfoPrivateModel
    Get
    Set
public:
property JobInfoPrivateModel^ JobInfo {
    JobInfoPrivateModel^ get ();
    void set (JobInfoPrivateModel^ value);
}
member JobInfo : JobInfoPrivateModel with get, set

Property Value

Type: JobInfoPrivateModel
The job information.
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel Methods

The CreateFromExistingJobModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateFromExistingJobModel Class


CreateRepsetRequestModel Class

Create repset request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateRepsetRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateRepsetRequestModel
Public NotInheritable Class CreateRepsetRequestModel
public ref class CreateRepsetRequestModel sealed
[<SealedAttribute>]
type CreateRepsetRequestModel =  class end

The CreateRepsetRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateRepsetRequestModel | Initializes a new instance of the CreateRepsetRequestModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | PhysicalRules | Gets or sets the physical rules.
Public property | UsageType | Gets or sets the type of the usage.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateRepsetRequestModel Constructor

Initializes a new instance of the CreateRepsetRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CreateRepsetRequestModel()
Public Sub New
public:
CreateRepsetRequestModel()
new : unit -> CreateRepsetRequestModel
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel Properties

The CreateRepsetRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | PhysicalRules | Gets or sets the physical rules.
Public property | UsageType | Gets or sets the type of the usage.
Top
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.Name Property

CreateRepsetRequestModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.PhysicalRules Property

CreateRepsetRequestModelPhysicalRules Property

Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.UsageType Property

CreateRepsetRequestModelUsageType Property

Gets or sets the type of the usage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetUsageType UsageType { get; set; }
Public Property UsageType As ReplicationSetUsageType
    Get
    Set
public:
property ReplicationSetUsageType UsageType {
    ReplicationSetUsageType get ();
    void set (ReplicationSetUsageType value);
}
member UsageType : ReplicationSetUsageType with get, set

Property Value

Type: ReplicationSetUsageType
The type of the usage.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel Methods

The CreateRepsetRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateRepsetRequestModel Class


DeleteOptionsModel Class

Delete options.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDeleteOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DeleteOptionsModel
Public NotInheritable Class DeleteOptionsModel
public ref class DeleteOptionsModel sealed
[<SealedAttribute>]
type DeleteOptionsModel =  class end

The DeleteOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteOptionsModel | Initializes a new instance of the DeleteOptionsModel class
Top
Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.
Public property | DeleteReplica | Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DeleteOptionsModel Constructor

Initializes a new instance of the DeleteOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DeleteOptionsModel()
Public Sub New
public:
DeleteOptionsModel()
new : unit -> DeleteOptionsModel
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel Properties

The DeleteOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.
Public property | DeleteReplica | Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DeleteOnClusterResourceOffline Property

DeleteOptionsModelDeleteOnClusterResourceOffline Property

Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteOnClusterResourceOffline { get; set; }
Public Property DeleteOnClusterResourceOffline As Boolean
    Get
    Set
public:
property bool DeleteOnClusterResourceOffline {
    bool get ();
    void set (bool value);
}
member DeleteOnClusterResourceOffline : bool with get, set

Property Value

Type: Boolean
true if delete is caused by target cluster resource going offline; otherwise, false.
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DeleteReplica Property

DeleteOptionsModelDeleteReplica Property

Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
member DeleteReplica : bool with get, set

Property Value

Type: Boolean
if the replica virtual machine should be deleted; otherwise, .
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DiscardTargetQueue Property

DeleteOptionsModelDiscardTargetQueue Property

Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
member DiscardTargetQueue : bool with get, set

Property Value

Type: Boolean
to discard the target queue; otherwise, .
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.ImageOptions Property

DeleteOptionsModelImageOptions Property

Gets or sets the option for what to do with the image when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfoModel
    Get
    Set
public:
property ImageDeleteInfoModel^ ImageOptions {
    ImageDeleteInfoModel^ get ();
    void set (ImageDeleteInfoModel^ value);
}
member ImageOptions : ImageDeleteInfoModel with get, set

Property Value

Type: ImageDeleteInfoModel
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel Methods

The DeleteOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteOptionsModel Class


DiagnosticsPersistedStateModel Class

Diagnostics persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiagnosticsPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiagnosticsPersistedStateModel
Public NotInheritable Class DiagnosticsPersistedStateModel
public ref class DiagnosticsPersistedStateModel sealed
[<SealedAttribute>]
type DiagnosticsPersistedStateModel =  class end

The DiagnosticsPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiagnosticsPersistedStateModel | Initializes a new instance of the DiagnosticsPersistedStateModel class
Top
Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiagnosticsPersistedStateModel Constructor

Initializes a new instance of the DiagnosticsPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiagnosticsPersistedStateModel()
Public Sub New
public:
DiagnosticsPersistedStateModel()
new : unit -> DiagnosticsPersistedStateModel
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel Properties

The DiagnosticsPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel.DiagnosticsConnectionPersistedState Property

DiagnosticsPersistedStateModelDiagnosticsConnectionPersistedState Property

Gets or sets the state of the diagnostics connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel DiagnosticsConnectionPersistedState { get; set; }
Public Property DiagnosticsConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ DiagnosticsConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member DiagnosticsConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the diagnostics connection.
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel.State Property

DiagnosticsPersistedStateModelState Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel Methods

The DiagnosticsPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiagnosticsPersistedStateModel Class


DiskLayoutInitializeModel Class

Disk layout initialize.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutInitializeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutInitializeModel
Public NotInheritable Class DiskLayoutInitializeModel
public ref class DiskLayoutInitializeModel sealed
[<SealedAttribute>]
type DiskLayoutInitializeModel =  class end

The DiskLayoutInitializeModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutInitializeModel | Initializes a new instance of the DiskLayoutInitializeModel class
Top
Properties
 | Name | Description
Public property | BaseMountPoint | Gets or sets the base location to mount the volumes to.
Public property | DiskLayout | Gets or sets the disk layout to create and mount underneath the base mount point.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutInitializeModel Constructor

Initializes a new instance of the DiskLayoutInitializeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutInitializeModel()
Public Sub New
public:
DiskLayoutInitializeModel()
new : unit -> DiskLayoutInitializeModel
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel Properties

The DiskLayoutInitializeModel type exposes the following members.

Properties
 | Name | Description
Public property | BaseMountPoint | Gets or sets the base location to mount the volumes to.
Public property | DiskLayout | Gets or sets the disk layout to create and mount underneath the base mount point.
Top
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel.BaseMountPoint Property

DiskLayoutInitializeModelBaseMountPoint Property

Gets or sets the base location to mount the volumes to.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string BaseMountPoint { get; set; }
Public Property BaseMountPoint As String
    Get
    Set
public:
property String^ BaseMountPoint {
    String^ get ();
    void set (String^ value);
}
member BaseMountPoint : string with get, set

Property Value

Type: String
Remarks
Windows volumes will be converted to valid path by replacing the ':' with '_'.
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel.DiskLayout Property

DiskLayoutInitializeModelDiskLayout Property

Gets or sets the disk layout to create and mount underneath the base mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] DiskLayout { get; set; }
Public Property DiskLayout As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ DiskLayout {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member DiskLayout : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel Methods

The DiskLayoutInitializeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutModel Class

Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutModel
Public NotInheritable Class DiskLayoutModel
public ref class DiskLayoutModel sealed
[<SealedAttribute>]
type DiskLayoutModel =  class end

The DiskLayoutModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutModel | Initializes a new instance of the DiskLayoutModel class
Top
Properties
 | Name | Description
Public property | DiskIdentifier | Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | PartitioningScheme | Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Gets or sets a value indicating whether we should partition the disk or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutModel Constructor

Initializes a new instance of the DiskLayoutModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel()
Public Sub New
public:
DiskLayoutModel()
new : unit -> DiskLayoutModel
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel Properties

The DiskLayoutModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskIdentifier | Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | PartitioningScheme | Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Gets or sets a value indicating whether we should partition the disk or not.
Top
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.DiskIdentifier Property

DiskLayoutModelDiskIdentifier Property

Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DiskIdentifier { get; set; }
Public Property DiskIdentifier As String
    Get
    Set
public:
property String^ DiskIdentifier {
    String^ get ();
    void set (String^ value);
}
member DiskIdentifier : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.PartitioningScheme Property

DiskLayoutModelPartitioningScheme Property

Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string PartitioningScheme { get; set; }
Public Property PartitioningScheme As String
    Get
    Set
public:
property String^ PartitioningScheme {
    String^ get ();
    void set (String^ value);
}
member PartitioningScheme : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.PartitionInitializationInfos Property

DiskLayoutModelPartitionInitializationInfos Property

Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskPartitionLayoutModel[] PartitionInitializationInfos { get; set; }
Public Property PartitionInitializationInfos As DiskPartitionLayoutModel()
    Get
    Set
public:
property array<DiskPartitionLayoutModel^>^ PartitionInitializationInfos {
    array<DiskPartitionLayoutModel^>^ get ();
    void set (array<DiskPartitionLayoutModel^>^ value);
}
member PartitionInitializationInfos : DiskPartitionLayoutModel[] with get, set

Property Value

Type: DiskPartitionLayoutModel
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.ShouldPartitionDisk Property

DiskLayoutModelShouldPartitionDisk Property

Gets or sets a value indicating whether we should partition the disk or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldPartitionDisk { get; set; }
Public Property ShouldPartitionDisk As Boolean
    Get
    Set
public:
property bool ShouldPartitionDisk {
    bool get ();
    void set (bool value);
}
member ShouldPartitionDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel Methods

The DiskLayoutModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutModel Class


DiskLayoutResultModel Class

Disk layout extraction result from a source system state scrape.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutResultModel
Public NotInheritable Class DiskLayoutResultModel
public ref class DiskLayoutResultModel sealed
[<SealedAttribute>]
type DiskLayoutResultModel =  class end

The DiskLayoutResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutResultModel | Initializes a new instance of the DiskLayoutResultModel class.
Public method | DiskLayoutResultModel(DiskLayoutModel, Boolean, String) | Initializes a new instance of the DiskLayoutResultModel class.
Top
Properties
 | Name | Description
Public property | DiskLayout | Gets or sets the disk layout.
Public property | Messages | Gets or sets any messages for the extraction.
Public property | Success | Gets or sets a value indicating whether the extraction was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutResultModel Constructor

Overload List
 | Name | Description
Public method | DiskLayoutResultModel | Initializes a new instance of the DiskLayoutResultModel class.
Public method | DiskLayoutResultModel(DiskLayoutModel, Boolean, String) | Initializes a new instance of the DiskLayoutResultModel class.
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel Constructor

Initializes a new instance of the DiskLayoutResultModel class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutResultModel()
Public Sub New
public:
DiskLayoutResultModel()
new : unit -> DiskLayoutResultModel
See Also

Reference

DiskLayoutResultModel Class
DiskLayoutResultModel Overload


DiskLayoutResultModel Constructor (DiskLayoutModel[], Boolean, String)

DiskLayoutResultModel Constructor (DiskLayoutModel, Boolean, String)

Initializes a new instance of the DiskLayoutResultModel class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutResultModel(
    DiskLayoutModel[] diskLayout,
    bool success,
    string messages
)
Public Sub New (
    diskLayout As DiskLayoutModel(),
    success As Boolean,
    messages As String
)
public:
DiskLayoutResultModel(
    array<DiskLayoutModel^>^ diskLayout,
    bool success,
    String^ messages
)
new :
        diskLayout : DiskLayoutModel[] *
        success : bool *
        messages : string -> DiskLayoutResultModel

Parameters

diskLayout
Type: DoubleTake.Web.ModelsDiskLayoutModel
The disk layout.
success
Type: SystemBoolean
if set to [success].
messages
Type: SystemString
The messages.
See Also

Reference

DiskLayoutResultModel Class
DiskLayoutResultModel Overload


DiskLayoutResultModel Properties

The DiskLayoutResultModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskLayout | Gets or sets the disk layout.
Public property | Messages | Gets or sets any messages for the extraction.
Public property | Success | Gets or sets a value indicating whether the extraction was successful.
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.DiskLayout Property

DiskLayoutResultModelDiskLayout Property

Gets or sets the disk layout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] DiskLayout { get; set; }
Public Property DiskLayout As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ DiskLayout {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member DiskLayout : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.Messages Property

DiskLayoutResultModelMessages Property

Gets or sets any messages for the extraction.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.Success Property

DiskLayoutResultModelSuccess Property

Gets or sets a value indicating whether the extraction was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
member Success : bool with get, set

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel Methods

The DiskLayoutResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutStatusResultModel Class

Disk layout status result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutStatusResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutStatusResultModel
Public NotInheritable Class DiskLayoutStatusResultModel
public ref class DiskLayoutStatusResultModel sealed
[<SealedAttribute>]
type DiskLayoutStatusResultModel =  class end

The DiskLayoutStatusResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutStatusResultModel | Initializes a new instance of the DiskLayoutStatusResultModel class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | Messages | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutStatusResultModel Constructor

Initializes a new instance of the DiskLayoutStatusResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutStatusResultModel()
Public Sub New
public:
DiskLayoutStatusResultModel()
new : unit -> DiskLayoutStatusResultModel
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel Properties

The DiskLayoutStatusResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | Messages | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Completed Property

DiskLayoutStatusResultModelCompleted Property

Gets or sets a value indicating whether this InitializeDisk() is has completed running.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
member Completed : bool with get, set

Property Value

Type: Boolean
true if completed; otherwise, false.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Messages Property

DiskLayoutStatusResultModelMessages Property

Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
The log generated by the InitializeDisk() operation.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Success Property

DiskLayoutStatusResultModelSuccess Property

Gets or sets a value indicating whether this InitializeDisk() is a success.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
member Success : bool with get, set

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel Methods

The DiskLayoutStatusResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutVerifyResultsModel Class

Results of disk layout verification.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutVerifyResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutVerifyResultsModel
Public NotInheritable Class DiskLayoutVerifyResultsModel
public ref class DiskLayoutVerifyResultsModel sealed
[<SealedAttribute>]
type DiskLayoutVerifyResultsModel =  class end

The DiskLayoutVerifyResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutVerifyResultsModel | Initializes a new instance of the DiskLayoutVerifyResultsModel class
Top
Properties
 | Name | Description
Public property | IsValid | Gets or sets a value indicating whether the layout is valid.
Public property | Messages | Gets or sets validation messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutVerifyResultsModel Constructor

Initializes a new instance of the DiskLayoutVerifyResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutVerifyResultsModel()
Public Sub New
public:
DiskLayoutVerifyResultsModel()
new : unit -> DiskLayoutVerifyResultsModel
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel Properties

The DiskLayoutVerifyResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets or sets a value indicating whether the layout is valid.
Public property | Messages | Gets or sets validation messages.
Top
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel.IsValid Property

DiskLayoutVerifyResultsModelIsValid Property

Gets or sets a value indicating whether the layout is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel.Messages Property

DiskLayoutVerifyResultsModelMessages Property

Gets or sets validation messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel Methods

The DiskLayoutVerifyResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutWithEnvironmentModel Class

Disk layout environment constraints.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutWithEnvironmentModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutWithEnvironmentModel
Public NotInheritable Class DiskLayoutWithEnvironmentModel
public ref class DiskLayoutWithEnvironmentModel sealed
[<SealedAttribute>]
type DiskLayoutWithEnvironmentModel =  class end

The DiskLayoutWithEnvironmentModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutWithEnvironmentModel | Initializes a new instance of the DiskLayoutWithEnvironmentModel class
Top
Properties
 | Name | Description
Public property | Disks | Gets or sets the disks to setup in this environment
Public property | FirstDiskMaxSize | Gets or sets the maximum size of the first disk in megabytes.
Public property | OtherDisksMaxSize | Gets or sets the maximum size of the remaining disks in megabytes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutWithEnvironmentModel Constructor

Initializes a new instance of the DiskLayoutWithEnvironmentModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutWithEnvironmentModel()
Public Sub New
public:
DiskLayoutWithEnvironmentModel()
new : unit -> DiskLayoutWithEnvironmentModel
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel Properties

The DiskLayoutWithEnvironmentModel type exposes the following members.

Properties
 | Name | Description
Public property | Disks | Gets or sets the disks to setup in this environment
Public property | FirstDiskMaxSize | Gets or sets the maximum size of the first disk in megabytes.
Public property | OtherDisksMaxSize | Gets or sets the maximum size of the remaining disks in megabytes.
Top
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.Disks Property

DiskLayoutWithEnvironmentModelDisks Property

Gets or sets the disks to setup in this environment

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] Disks { get; set; }
Public Property Disks As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ Disks {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member Disks : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.FirstDiskMaxSize Property

DiskLayoutWithEnvironmentModelFirstDiskMaxSize Property

Gets or sets the maximum size of the first disk in megabytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int FirstDiskMaxSize { get; set; }
Public Property FirstDiskMaxSize As Integer
    Get
    Set
public:
property int FirstDiskMaxSize {
    int get ();
    void set (int value);
}
member FirstDiskMaxSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.OtherDisksMaxSize Property

DiskLayoutWithEnvironmentModelOtherDisksMaxSize Property

Gets or sets the maximum size of the remaining disks in megabytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int OtherDisksMaxSize { get; set; }
Public Property OtherDisksMaxSize As Integer
    Get
    Set
public:
property int OtherDisksMaxSize {
    int get ();
    void set (int value);
}
member OtherDisksMaxSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel Methods

The DiskLayoutWithEnvironmentModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskPartitionLayoutModel Class

Disk partition layout model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskPartitionLayoutModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskPartitionLayoutModel
Public NotInheritable Class DiskPartitionLayoutModel
public ref class DiskPartitionLayoutModel sealed
[<SealedAttribute>]
type DiskPartitionLayoutModel =  class end

The DiskPartitionLayoutModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskPartitionLayoutModel | Initializes a new instance of the DiskPartitionLayoutModel class
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the partition should be made active.
Public property | Align | Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | FileSystemType | Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Gets or sets the INode size.
Public property | IsBoot | Gets or sets a value indicating whether this partition is a boot partition.
Public property | Label | Gets or sets the string to be used as the label of the volume. This is optional.
Public property | MountPoint | Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | Gets or sets one of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Gets or sets a value indicating whether the partition should be formatted.
Public property | Size | Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskPartitionLayoutModel Constructor

Initializes a new instance of the DiskPartitionLayoutModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DiskPartitionLayoutModel()
Public Sub New
public:
DiskPartitionLayoutModel()
new : unit -> DiskPartitionLayoutModel
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel Properties

The DiskPartitionLayoutModel type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the partition should be made active.
Public property | Align | Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | FileSystemType | Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Gets or sets the INode size.
Public property | IsBoot | Gets or sets a value indicating whether this partition is a boot partition.
Public property | Label | Gets or sets the string to be used as the label of the volume. This is optional.
Public property | MountPoint | Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | Gets or sets one of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Gets or sets a value indicating whether the partition should be formatted.
Public property | Size | Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Active Property

DiskPartitionLayoutModelActive Property

Gets or sets a value indicating whether the partition should be made active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
member Active : bool with get, set

Property Value

Type: Boolean
true if active; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Align Property

DiskPartitionLayoutModelAlign Property

Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int Align { get; set; }
Public Property Align As Integer
    Get
    Set
public:
property int Align {
    int get ();
    void set (int value);
}
member Align : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.FileSystemType Property

DiskPartitionLayoutModelFileSystemType Property

Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FileSystemType { get; set; }
Public Property FileSystemType As String
    Get
    Set
public:
property String^ FileSystemType {
    String^ get ();
    void set (String^ value);
}
member FileSystemType : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.INodeSize Property

DiskPartitionLayoutModelINodeSize Property

Gets or sets the INode size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int INodeSize { get; set; }
Public Property INodeSize As Integer
    Get
    Set
public:
property int INodeSize {
    int get ();
    void set (int value);
}
member INodeSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.IsBoot Property

DiskPartitionLayoutModelIsBoot Property

Gets or sets a value indicating whether this partition is a boot partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsBoot { get; set; }
Public Property IsBoot As Boolean
    Get
    Set
public:
property bool IsBoot {
    bool get ();
    void set (bool value);
}
member IsBoot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Label Property

DiskPartitionLayoutModelLabel Property

Gets or sets the string to be used as the label of the volume. This is optional.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.MountPoint Property

DiskPartitionLayoutModelMountPoint Property

Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Offset Property

DiskPartitionLayoutModelOffset Property

Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set
public:
property int Offset {
    int get ();
    void set (int value);
}
member Offset : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.PartitionType Property

DiskPartitionLayoutModelPartitionType Property

Gets or sets one of the partition types from the PartitionTypes class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string PartitionType { get; set; }
Public Property PartitionType As String
    Get
    Set
public:
property String^ PartitionType {
    String^ get ();
    void set (String^ value);
}
member PartitionType : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.QuickFormat Property

DiskPartitionLayoutModelQuickFormat Property

Gets or sets a value indicating whether we should use a "quick" format.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool QuickFormat { get; set; }
Public Property QuickFormat As Boolean
    Get
    Set
public:
property bool QuickFormat {
    bool get ();
    void set (bool value);
}
member QuickFormat : bool with get, set

Property Value

Type: Boolean
true if Quick format is desired; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.ShouldCreateMountPointDirectory Property

DiskPartitionLayoutModelShouldCreateMountPointDirectory Property

Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldCreateMountPointDirectory { get; set; }
Public Property ShouldCreateMountPointDirectory As Boolean
    Get
    Set
public:
property bool ShouldCreateMountPointDirectory {
    bool get ();
    void set (bool value);
}
member ShouldCreateMountPointDirectory : bool with get, set

Property Value

Type: Boolean
true if InitializeDisk should create mount point directory; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.ShouldFormatPartition Property

DiskPartitionLayoutModelShouldFormatPartition Property

Gets or sets a value indicating whether the partition should be formatted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldFormatPartition { get; set; }
Public Property ShouldFormatPartition As Boolean
    Get
    Set
public:
property bool ShouldFormatPartition {
    bool get ();
    void set (bool value);
}
member ShouldFormatPartition : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Size Property

DiskPartitionLayoutModelSize Property

Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
public:
property int Size {
    int get ();
    void set (int value);
}
member Size : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel Methods

The DiskPartitionLayoutModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskPartitionLayoutModel Class


DnsDomainDetailsPrototypeModel Class

DNS domain details prototype model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsDomainDetailsPrototypeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsDomainDetailsPrototypeModel
Public NotInheritable Class DnsDomainDetailsPrototypeModel
public ref class DnsDomainDetailsPrototypeModel sealed
[<SealedAttribute>]
type DnsDomainDetailsPrototypeModel =  class end

The DnsDomainDetailsPrototypeModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetailsPrototypeModel | Initializes a new instance of the DnsDomainDetailsPrototypeModel class
Top
Properties
 | Name | Description
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Domain | Gets or sets the domain.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsDomainDetailsPrototypeModel Constructor

Initializes a new instance of the DnsDomainDetailsPrototypeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsPrototypeModel()
Public Sub New
public:
DnsDomainDetailsPrototypeModel()
new : unit -> DnsDomainDetailsPrototypeModel
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel Properties

The DnsDomainDetailsPrototypeModel type exposes the following members.

Properties
 | Name | Description
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Domain | Gets or sets the domain.
Top
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel.DnsServers Property

DnsDomainDetailsPrototypeModelDnsServers Property

Gets or sets the DNS servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel.Domain Property

DnsDomainDetailsPrototypeModelDomain Property

Gets or sets the domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel Methods

The DnsDomainDetailsPrototypeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DriveTypeEnum Enumeration

Drive type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum DriveTypeEnum
Public Enumeration DriveTypeEnum
public enum class DriveTypeEnum
type DriveTypeEnum
Members
Member name | Value | Description
Unknown | 0 | The unknown
NoRootDirectory | 1 | The no root directory
Removable | 2 | The removable
Fixed | 3 | The fixed
Network | 4 | The network
CdRom | 5 | The cd rom
Ram | 6 | The ram
See Also

Reference

DoubleTake.Web.Models Namespace


DTAVPersistedStateModel Class

DTAV persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDTAVPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DTAVPersistedStateModel
Public NotInheritable Class DTAVPersistedStateModel
public ref class DTAVPersistedStateModel sealed
[<SealedAttribute>]
type DTAVPersistedStateModel =  class end

The DTAVPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTAVPersistedStateModel | Initializes a new instance of the DTAVPersistedStateModel class
Top
Properties
 | Name | Description
Public property | JobCreationDate | Gets or sets the job creation date.
Public property | JobState | Gets or sets the state of the job.
Public property | JobVersion | Gets or sets the job version.
Public property | Licensed | Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.
Public property | LicenseData | Gets or sets the license data.
Public property | SavedSnapshots | Gets or sets the saved snapshots.
Public property | SnapshotName | Gets or sets the name of the snapshot.
Public property | TargetVmGuid | Gets or sets the target vm unique identifier.
Public property | VmdkdInfoList | Gets or sets the VMDKD information list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DTAVPersistedStateModel Constructor

Initializes a new instance of the DTAVPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DTAVPersistedStateModel()
Public Sub New
public:
DTAVPersistedStateModel()
new : unit -> DTAVPersistedStateModel
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel Properties

The DTAVPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCreationDate | Gets or sets the job creation date.
Public property | JobState | Gets or sets the state of the job.
Public property | JobVersion | Gets or sets the job version.
Public property | Licensed | Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.
Public property | LicenseData | Gets or sets the license data.
Public property | SavedSnapshots | Gets or sets the saved snapshots.
Public property | SnapshotName | Gets or sets the name of the snapshot.
Public property | TargetVmGuid | Gets or sets the target vm unique identifier.
Public property | VmdkdInfoList | Gets or sets the VMDKD information list.
Top
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobCreationDate Property

DTAVPersistedStateModelJobCreationDate Property

Gets or sets the job creation date.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset JobCreationDate { get; set; }
Public Property JobCreationDate As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset JobCreationDate {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member JobCreationDate : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The job creation date.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobState Property

DTAVPersistedStateModelJobState Property

Gets or sets the state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel JobState { get; set; }
Public Property JobState As JobStateModel
    Get
    Set
public:
property JobStateModel^ JobState {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member JobState : JobStateModel with get, set

Property Value

Type: JobStateModel
The state of the job.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobVersion Property

DTAVPersistedStateModelJobVersion Property

Gets or sets the job version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel JobVersion { get; set; }
Public Property JobVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ JobVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member JobVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
The job version.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.Licensed Property

DTAVPersistedStateModelLicensed Property

Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Licensed { get; set; }
Public Property Licensed As Boolean
    Get
    Set
public:
property bool Licensed {
    bool get ();
    void set (bool value);
}
member Licensed : bool with get, set

Property Value

Type: Boolean
true if licensed; otherwise, false.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.LicenseData Property

DTAVPersistedStateModelLicenseData Property

Gets or sets the license data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string LicenseData { get; set; }
Public Property LicenseData As String
    Get
    Set
public:
property String^ LicenseData {
    String^ get ();
    void set (String^ value);
}
member LicenseData : string with get, set

Property Value

Type: String
The license data.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.SavedSnapshots Property

DTAVPersistedStateModelSavedSnapshots Property

Gets or sets the saved snapshots.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public List<PITSnapshotRecordModel> SavedSnapshots { get; set; }
Public Property SavedSnapshots As List(Of PITSnapshotRecordModel)
    Get
    Set
public:
property List<PITSnapshotRecordModel^>^ SavedSnapshots {
    List<PITSnapshotRecordModel^>^ get ();
    void set (List<PITSnapshotRecordModel^>^ value);
}
member SavedSnapshots : List<PITSnapshotRecordModel> with get, set

Property Value

Type: List PITSnapshotRecordModel
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.SnapshotName Property

DTAVPersistedStateModelSnapshotName Property

Gets or sets the name of the snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotName { get; set; }
Public Property SnapshotName As String
    Get
    Set
public:
property String^ SnapshotName {
    String^ get ();
    void set (String^ value);
}
member SnapshotName : string with get, set

Property Value

Type: String
The name of the snapshot.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.TargetVmGuid Property

DTAVPersistedStateModelTargetVmGuid Property

Gets or sets the target vm unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmGuid { get; set; }
Public Property TargetVmGuid As String
    Get
    Set
public:
property String^ TargetVmGuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmGuid : string with get, set

Property Value

Type: String
The target vm unique identifier.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.VmdkdInfoList Property

DTAVPersistedStateModelVmdkdInfoList Property

Gets or sets the VMDKD information list.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public List<VmdkInfoModel> VmdkdInfoList { get; set; }
Public Property VmdkdInfoList As List(Of VmdkInfoModel)
    Get
    Set
public:
property List<VmdkInfoModel^>^ VmdkdInfoList {
    List<VmdkInfoModel^>^ get ();
    void set (List<VmdkInfoModel^>^ value);
}
member VmdkdInfoList : List<VmdkInfoModel> with get, set

Property Value

Type: List VmdkInfoModel
The VMDKD information list.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel Methods

The DTAVPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTAVPersistedStateModel Class


DTHVPersistedStateModel Class

DTHV persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDTHVPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class DTHVPersistedStateModel
Public NotInheritable Class DTHVPersistedStateModel
public ref class DTHVPersistedStateModel sealed
[<SealedAttribute>]
type DTHVPersistedStateModel =  class end

The DTHVPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTHVPersistedStateModel | Initializes a new instance of the DTHVPersistedStateModel class
Top
Properties
 | Name | Description
Public property | DeleteOptions | Gets or sets the delete options.
Public property | FailoverMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | PowerSourceVm | Gets or sets a value indicating whether the source Vm was on before failover.
Public property | ProtectionConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RevertConnectionPersistedState | Gets or sets the state of the replica vm revert persisted.
Public property | SourceEndpoint | Gets or sets the source endpoint.
Public property | State | Gets or sets the state of the protection connection persisted.
Public property | TargetRoute | Gets or sets a value representing target route
Public property | TargetVmCfgResourceName | Gets or sets the name of the target vm CFG resource.
Public property | TargetVMGuid | Gets or sets the target vm unique identifier.
Public property | TargetVmResourceName | Gets or sets the name of the target vm resource.
Public property | VhdMapping | Gets or sets a value representing source and target VHD mappings
Public property | VirtualSwitchMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | VMConfigMonitorPersistedState | Gets or sets the state of the monitor persisted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DTHVPersistedStateModel Constructor

Initializes a new instance of the DTHVPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DTHVPersistedStateModel()
Public Sub New
public:
DTHVPersistedStateModel()
new : unit -> DTHVPersistedStateModel
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel Properties

The DTHVPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOptions | Gets or sets the delete options.
Public property | FailoverMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | PowerSourceVm | Gets or sets a value indicating whether the source Vm was on before failover.
Public property | ProtectionConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RevertConnectionPersistedState | Gets or sets the state of the replica vm revert persisted.
Public property | SourceEndpoint | Gets or sets the source endpoint.
Public property | State | Gets or sets the state of the protection connection persisted.
Public property | TargetRoute | Gets or sets a value representing target route
Public property | TargetVmCfgResourceName | Gets or sets the name of the target vm CFG resource.
Public property | TargetVMGuid | Gets or sets the target vm unique identifier.
Public property | TargetVmResourceName | Gets or sets the name of the target vm resource.
Public property | VhdMapping | Gets or sets a value representing source and target VHD mappings
Public property | VirtualSwitchMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | VMConfigMonitorPersistedState | Gets or sets the state of the monitor persisted.
Top
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.DeleteOptions Property

DTHVPersistedStateModelDeleteOptions Property

Gets or sets the delete options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DeleteOptionsModel DeleteOptions { get; set; }
Public Property DeleteOptions As DeleteOptionsModel
    Get
    Set
public:
property DeleteOptionsModel^ DeleteOptions {
    DeleteOptionsModel^ get ();
    void set (DeleteOptionsModel^ value);
}
member DeleteOptions : DeleteOptionsModel with get, set

Property Value

Type: DeleteOptionsModel
The delete options.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.FailoverMonitorPersistedState Property

DTHVPersistedStateModelFailoverMonitorPersistedState Property

Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel FailoverMonitorPersistedState { get; set; }
Public Property FailoverMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ FailoverMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member FailoverMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.FailoverOptions Property

DTHVPersistedStateModelFailoverOptions Property

Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.PowerSourceVm Property

DTHVPersistedStateModelPowerSourceVm Property

Gets or sets a value indicating whether the source Vm was on before failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool PowerSourceVm { get; set; }
Public Property PowerSourceVm As Boolean
    Get
    Set
public:
property bool PowerSourceVm {
    bool get ();
    void set (bool value);
}
member PowerSourceVm : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.ProtectionConnectionPersistedState Property

DTHVPersistedStateModelProtectionConnectionPersistedState Property

Gets or sets the main connection's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The main connection's persisted state.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.ProtectionTargetState Property

DTHVPersistedStateModelProtectionTargetState Property

Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.RevertConnectionPersistedState Property

DTHVPersistedStateModelRevertConnectionPersistedState Property

Gets or sets the state of the replica vm revert persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RevertConnectionPersistedState { get; set; }
Public Property RevertConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RevertConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RevertConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the Replica vm revert persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.SourceEndpoint Property

DTHVPersistedStateModelSourceEndpoint Property

Gets or sets the source endpoint.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
The source endpoint.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.State Property

DTHVPersistedStateModelState Property

Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel State { get; set; }
Public Property State As JobStateModel
    Get
    Set
public:
property JobStateModel^ State {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member State : JobStateModel with get, set

Property Value

Type: JobStateModel
The state of the protection connection persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetRoute Property

DTHVPersistedStateModelTargetRoute Property

Gets or sets a value representing target route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVmCfgResourceName Property

DTHVPersistedStateModelTargetVmCfgResourceName Property

Gets or sets the name of the target vm CFG resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmCfgResourceName { get; set; }
Public Property TargetVmCfgResourceName As String
    Get
    Set
public:
property String^ TargetVmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member TargetVmCfgResourceName : string with get, set

Property Value

Type: String
The name of the target vm CFG resource.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVMGuid Property

DTHVPersistedStateModelTargetVMGuid Property

Gets or sets the target vm unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVMGuid { get; set; }
Public Property TargetVMGuid As String
    Get
    Set
public:
property String^ TargetVMGuid {
    String^ get ();
    void set (String^ value);
}
member TargetVMGuid : string with get, set

Property Value

Type: String
The target vm unique identifier.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVmResourceName Property

DTHVPersistedStateModelTargetVmResourceName Property

Gets or sets the name of the target vm resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmResourceName { get; set; }
Public Property TargetVmResourceName As String
    Get
    Set
public:
property String^ TargetVmResourceName {
    String^ get ();
    void set (String^ value);
}
member TargetVmResourceName : string with get, set

Property Value

Type: String
The name of the target vm resource.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VhdMapping Property

DTHVPersistedStateModelVhdMapping Property

Gets or sets a value representing source and target VHD mappings

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VHDMappingModel[] VhdMapping { get; set; }
Public Property VhdMapping As VHDMappingModel()
    Get
    Set
public:
property array<VHDMappingModel^>^ VhdMapping {
    array<VHDMappingModel^>^ get ();
    void set (array<VHDMappingModel^>^ value);
}
member VhdMapping : VHDMappingModel[] with get, set

Property Value

Type: VHDMappingModel
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VirtualSwitchMonitorPersistedState Property

DTHVPersistedStateModelVirtualSwitchMonitorPersistedState Property

Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel VirtualSwitchMonitorPersistedState { get; set; }
Public Property VirtualSwitchMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ VirtualSwitchMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member VirtualSwitchMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VMConfigMonitorPersistedState Property

DTHVPersistedStateModelVMConfigMonitorPersistedState Property

Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel VMConfigMonitorPersistedState { get; set; }
Public Property VMConfigMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ VMConfigMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member VMConfigMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the vm config monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel Methods

The DTHVPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTHVPersistedStateModel Class


DtInfoCollectionProgressEnum Enumeration

Double-Take information collection progress

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum DtInfoCollectionProgressEnum
Public Enumeration DtInfoCollectionProgressEnum
public enum class DtInfoCollectionProgressEnum
type DtInfoCollectionProgressEnum
Members
Member name | Value | Description
Generating | 0 | The generating
Buffering | 1 | The buffering
DataAvailable | 2 | The data available
Complete | 3 | The complete
Error | 4 | The error
Canceled | 5 | The canceled
See Also

Reference

DoubleTake.Web.Models Namespace


DtInfoCollectionStatusModel Class

DTInfo collection status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtInfoCollectionStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class DtInfoCollectionStatusModel
Public Class DtInfoCollectionStatusModel
public ref class DtInfoCollectionStatusModel
type DtInfoCollectionStatusModel =  class end

The DtInfoCollectionStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtInfoCollectionStatusModel | Initializes a new instance of the DtInfoCollectionStatusModel class
Top
Properties
 | Name | Description
Public property | ArchiveName | Gets or sets the name of the archive.
Public property | Data | Gets or sets the data.
Public property | ErrorMessage | Gets or sets the error message.
Public property | Progress | Gets or sets the progress.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtInfoCollectionStatusModel Constructor

Initializes a new instance of the DtInfoCollectionStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtInfoCollectionStatusModel()
Public Sub New
public:
DtInfoCollectionStatusModel()
new : unit -> DtInfoCollectionStatusModel
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel Properties

The DtInfoCollectionStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveName | Gets or sets the name of the archive.
Public property | Data | Gets or sets the data.
Public property | ErrorMessage | Gets or sets the error message.
Public property | Progress | Gets or sets the progress.
Top
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.ArchiveName Property

DtInfoCollectionStatusModelArchiveName Property

Gets or sets the name of the archive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveName { get; set; }
Public Property ArchiveName As String
    Get
    Set
public:
property String^ ArchiveName {
    String^ get ();
    void set (String^ value);
}
member ArchiveName : string with get, set

Property Value

Type: String
The name of the archive.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.Data Property

DtInfoCollectionStatusModelData Property

Gets or sets the data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public byte[][] Data { get; set; }
Public Property Data As Byte()()
    Get
    Set
public:
property array<array<unsigned char>^>^ Data {
    array<array<unsigned char>^>^ get ();
    void set (array<array<unsigned char>^>^ value);
}
member Data : byte[][] with get, set

Property Value

Type: Byte
The data.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.ErrorMessage Property

DtInfoCollectionStatusModelErrorMessage Property

Gets or sets the error message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
The error message.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.Progress Property

DtInfoCollectionStatusModelProgress Property

Gets or sets the progress.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtInfoCollectionProgressEnum Progress { get; set; }
Public Property Progress As DtInfoCollectionProgressEnum
    Get
    Set
public:
property DtInfoCollectionProgressEnum Progress {
    DtInfoCollectionProgressEnum get ();
    void set (DtInfoCollectionProgressEnum value);
}
member Progress : DtInfoCollectionProgressEnum with get, set

Property Value

Type: DtInfoCollectionProgressEnum
The progress.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel Methods

The DtInfoCollectionStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtInfoCollectionStatusModel Class


DtmuActivationStatusModel Class

DTMU activation status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtmuActivationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class DtmuActivationStatusModel
Public Class DtmuActivationStatusModel
public ref class DtmuActivationStatusModel
type DtmuActivationStatusModel =  class end

The DtmuActivationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtmuActivationStatusModel | Initializes a new instance of the DtmuActivationStatusModel class
Top
Properties
 | Name | Description
Public property | Code | Gets or sets the code.
Public property | IsValid | Gets or sets a value indicating whether the status is valid.
Public property | MajorVersion | Gets or sets the major version.
Public property | MinorVersion | Gets or sets the minor version.
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtmuActivationStatusModel Constructor

Initializes a new instance of the DtmuActivationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtmuActivationStatusModel()
Public Sub New
public:
DtmuActivationStatusModel()
new : unit -> DtmuActivationStatusModel
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel Properties

The DtmuActivationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets or sets the code.
Public property | IsValid | Gets or sets a value indicating whether the status is valid.
Public property | MajorVersion | Gets or sets the major version.
Public property | MinorVersion | Gets or sets the minor version.
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.Code Property

DtmuActivationStatusModelCode Property

Gets or sets the code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
The code.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.IsValid Property

DtmuActivationStatusModelIsValid Property

Gets or sets a value indicating whether the status is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
if this instance is valid; otherwise, .
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.MajorVersion Property

DtmuActivationStatusModelMajorVersion Property

Gets or sets the major version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
member MajorVersion : int with get, set

Property Value

Type: Int32
The major version.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.MinorVersion Property

DtmuActivationStatusModelMinorVersion Property

Gets or sets the minor version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
member MinorVersion : int with get, set

Property Value

Type: Int32
The minor version.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.ProductCode Property

DtmuActivationStatusModelProductCode Property

Gets or sets the product code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
The product code.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.ProductName Property

DtmuActivationStatusModelProductName Property

Gets or sets the name of the product.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
member ProductName : string with get, set

Property Value

Type: String
The name of the product.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel Methods

The DtmuActivationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtmuActivationStatusModel Class


DtmuJobStatusEnum Enumeration

DTMU job status

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum DtmuJobStatusEnum
Public Enumeration DtmuJobStatusEnum
public enum class DtmuJobStatusEnum
type DtmuJobStatusEnum
Members
Member name | Value | Description
Unknown | 0 | The unknown
Ok | 1 | The ok
SourceConnectivityError | 2 | The source connectivity error
Error | 3 | The error
See Also

Reference

DoubleTake.Web.Models Namespace


DtscStatusQueryInputModel Class

Inputs for a DtscStatus monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsDtscStatusQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class DtscStatusQueryInputModel : QueryInputModel
Public Class DtscStatusQueryInputModel
    Inherits QueryInputModel
public ref class DtscStatusQueryInputModel : public QueryInputModel
type DtscStatusQueryInputModel =
    class
        inherit QueryInputModel
    end

The DtscStatusQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryInputModel | Initializes a new instance of the DtscStatusQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


DtscStatusQueryInputModel Constructor

Initializes a new instance of the DtscStatusQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtscStatusQueryInputModel()
Public Sub New
public:
DtscStatusQueryInputModel()
new : unit -> DtscStatusQueryInputModel
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel Properties

The DtscStatusQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Top
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel.ReplicationSetName Property

DtscStatusQueryInputModelReplicationSetName Property

Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel Methods

The DtscStatusQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryResultModel Class

Represents the results of a Dtsc status query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsDtscStatusQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class DtscStatusQueryResultModel : QueryResultModel
Public Class DtscStatusQueryResultModel
    Inherits QueryResultModel
public ref class DtscStatusQueryResultModel : public QueryResultModel
type DtscStatusQueryResultModel =
    class
        inherit QueryResultModel
    end

The DtscStatusQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryResultModel | Initializes a new instance of the DtscStatusQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | OwningNode | Gets or sets the owning node.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


DtscStatusQueryResultModel Constructor

Initializes a new instance of the DtscStatusQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtscStatusQueryResultModel()
Public Sub New
public:
DtscStatusQueryResultModel()
new : unit -> DtscStatusQueryResultModel
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel Properties

The DtscStatusQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | OwningNode | Gets or sets the owning node.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel.OwningNode Property

DtscStatusQueryResultModelOwningNode Property

Gets or sets the owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel.ResourceState Property

DtscStatusQueryResultModelResourceState Property

Gets or sets the state of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ResourceState { get; set; }
Public Property ResourceState As Integer
    Get
    Set
public:
property int ResourceState {
    int get ();
    void set (int value);
}
member ResourceState : int with get, set

Property Value

Type: Int32
The state of the resource.
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel Methods

The DtscStatusQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtscStatusQueryResultModel Class


DTTargetResourceQueryInputModel Class

The Input parameters to monitor a resource on a Target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsDTTargetResourceQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class DTTargetResourceQueryInputModel : QueryInputModel
Public Class DTTargetResourceQueryInputModel
    Inherits QueryInputModel
public ref class DTTargetResourceQueryInputModel : public QueryInputModel
type DTTargetResourceQueryInputModel =
    class
        inherit QueryInputModel
    end

The DTTargetResourceQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTTargetResourceQueryInputModel | Initializes a new instance of the DTTargetResourceQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | JobId | Gets or sets the job identifier.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | TargetHostName | Gets or sets the name of the target host.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


DTTargetResourceQueryInputModel Constructor

Initializes a new instance of the DTTargetResourceQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DTTargetResourceQueryInputModel()
Public Sub New
public:
DTTargetResourceQueryInputModel()
new : unit -> DTTargetResourceQueryInputModel
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel Properties

The DTTargetResourceQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | JobId | Gets or sets the job identifier.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | TargetHostName | Gets or sets the name of the target host.
Top
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.JobId Property

DTTargetResourceQueryInputModelJobId Property

Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobId { get; set; }
Public Property JobId As String
    Get
    Set
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
member JobId : string with get, set

Property Value

Type: String
The job identifier.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.ResourceName Property

DTTargetResourceQueryInputModelResourceName Property

Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; set; }
Public Property ResourceName As String
    Get
    Set
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}
member ResourceName : string with get, set

Property Value

Type: String
The name of the resource.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.TargetHostName Property

DTTargetResourceQueryInputModelTargetHostName Property

Gets or sets the name of the target host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetHostName { get; set; }
Public Property TargetHostName As String
    Get
    Set
public:
property String^ TargetHostName {
    String^ get ();
    void set (String^ value);
}
member TargetHostName : string with get, set

Property Value

Type: String
The name of the target host.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel Methods

The DTTargetResourceQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTTargetResourceQueryInputModel Class


EmailNotificationCategoriesEnum Enumeration

Email notification categories

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum EmailNotificationCategoriesEnum
Public Enumeration EmailNotificationCategoriesEnum
public enum class EmailNotificationCategoriesEnum
type EmailNotificationCategoriesEnum
Members
Member name | Value | Description
None | 0 | None
Information | 1 | Information
Warning | 2 | Warning
Error | 4 | Error
All | 255 | All
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationSettingsModel Class

Email notification settings model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailNotificationSettingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class EmailNotificationSettingsModel
Public NotInheritable Class EmailNotificationSettingsModel
public ref class EmailNotificationSettingsModel sealed
[<SealedAttribute>]
type EmailNotificationSettingsModel =  class end

The EmailNotificationSettingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationSettingsModel | Initializes a new instance of the EmailNotificationSettingsModel class
Top
Properties
 | Name | Description
Public property | Categories | Gets or sets the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Gets or sets the Double-Take "EmailExcludeIds" registry setting.
Public property | FromAddress | Gets or sets the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.
Public property | IsEventDescriptionInSubject | Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.
Public property | IsSmtpLogOnEnabled | Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.
Public property | Password | Gets or sets the Double-Take "EmailPassword" registry setting.
Public property | Port | Gets or sets the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Gets or sets the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Gets or sets the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Gets or sets the Double-Take "EmailUsername" registry setting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationSettingsModel Constructor

Initializes a new instance of the EmailNotificationSettingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationSettingsModel()
Public Sub New
public:
EmailNotificationSettingsModel()
new : unit -> EmailNotificationSettingsModel
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel Properties

The EmailNotificationSettingsModel type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Gets or sets the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Gets or sets the Double-Take "EmailExcludeIds" registry setting.
Public property | FromAddress | Gets or sets the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.
Public property | IsEventDescriptionInSubject | Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.
Public property | IsSmtpLogOnEnabled | Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.
Public property | Password | Gets or sets the Double-Take "EmailPassword" registry setting.
Public property | Port | Gets or sets the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Gets or sets the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Gets or sets the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Gets or sets the Double-Take "EmailUsername" registry setting.
Top
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Categories Property

EmailNotificationSettingsModelCategories Property

Gets or sets the Double-Take "EmailIncludeCategories" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationCategoriesEnum Categories { get; set; }
Public Property Categories As EmailNotificationCategoriesEnum
    Get
    Set
public:
property EmailNotificationCategoriesEnum Categories {
    EmailNotificationCategoriesEnum get ();
    void set (EmailNotificationCategoriesEnum value);
}
member Categories : EmailNotificationCategoriesEnum with get, set

Property Value

Type: EmailNotificationCategoriesEnum
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.ExcludeIds Property

EmailNotificationSettingsModelExcludeIds Property

Gets or sets the Double-Take "EmailExcludeIds" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] ExcludeIds { get; set; }
Public Property ExcludeIds As String()
    Get
    Set
public:
property array<String^>^ ExcludeIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ExcludeIds : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.FromAddress Property

EmailNotificationSettingsModelFromAddress Property

Gets or sets the Double-Take "EmailFromAddress" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FromAddress { get; set; }
Public Property FromAddress As String
    Get
    Set
public:
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
member FromAddress : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsEnabled Property

EmailNotificationSettingsModelIsEnabled Property

Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
member IsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsEventDescriptionInSubject Property

EmailNotificationSettingsModelIsEventDescriptionInSubject Property

Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsEventDescriptionInSubject { get; set; }
Public Property IsEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IsEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
member IsEventDescriptionInSubject : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsSmtpLogOnEnabled Property

EmailNotificationSettingsModelIsSmtpLogOnEnabled Property

Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsSmtpLogOnEnabled { get; set; }
Public Property IsSmtpLogOnEnabled As Boolean
    Get
    Set
public:
property bool IsSmtpLogOnEnabled {
    bool get ();
    void set (bool value);
}
member IsSmtpLogOnEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Password Property

EmailNotificationSettingsModelPassword Property

Gets or sets the Double-Take "EmailPassword" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Port Property

EmailNotificationSettingsModelPort Property

Gets or sets the Double-Take "EmailServerPort" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Recipients Property

EmailNotificationSettingsModelRecipients Property

Gets or sets the Double-Take "EmailNotificationList" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Recipients : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Server Property

EmailNotificationSettingsModelServer Property

Gets or sets the Double-Take "EmailServer" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.SubjectPrefix Property

EmailNotificationSettingsModelSubjectPrefix Property

Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
member SubjectPrefix : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.UserName Property

EmailNotificationSettingsModelUserName Property

Gets or sets the Double-Take "EmailUsername" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel Methods

The EmailNotificationSettingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationTestParametersModel Class

Email notification test parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailNotificationTestParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class EmailNotificationTestParametersModel
Public Class EmailNotificationTestParametersModel
public ref class EmailNotificationTestParametersModel
type EmailNotificationTestParametersModel =  class end

The EmailNotificationTestParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationTestParametersModel | Initializes a new instance of the EmailNotificationTestParametersModel class
Top
Properties
 | Name | Description
Public property | BodyText | Gets or sets the body text.
Public property | Recipients | Gets or sets the recipients.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationTestParametersModel Constructor

Initializes a new instance of the EmailNotificationTestParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationTestParametersModel()
Public Sub New
public:
EmailNotificationTestParametersModel()
new : unit -> EmailNotificationTestParametersModel
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel Properties

The EmailNotificationTestParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | BodyText | Gets or sets the body text.
Public property | Recipients | Gets or sets the recipients.
Top
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel.BodyText Property

EmailNotificationTestParametersModelBodyText Property

Gets or sets the body text.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string BodyText { get; set; }
Public Property BodyText As String
    Get
    Set
public:
property String^ BodyText {
    String^ get ();
    void set (String^ value);
}
member BodyText : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel.Recipients Property

EmailNotificationTestParametersModelRecipients Property

Gets or sets the recipients.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Recipients : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel Methods

The EmailNotificationTestParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailNotificationTestParametersModel Class


ErrorInfoModel Class

Represents job error properties.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsErrorInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ErrorInfoModel
Public NotInheritable Class ErrorInfoModel
public ref class ErrorInfoModel sealed
[<SealedAttribute>]
type ErrorInfoModel =  class end

The ErrorInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfoModel | Initializes a new instance of the ErrorInfoModel class
Top
Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ErrorInfoModel Constructor

Initializes a new instance of the ErrorInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ErrorInfoModel()
Public Sub New
public:
ErrorInfoModel()
new : unit -> ErrorInfoModel
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel Properties

The ErrorInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Details Property

ErrorInfoModelDetails Property

Gets or sets a value of error details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Details { get; set; }
Public Property Details As String
    Get
    Set
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}
member Details : string with get, set

Property Value

Type: String
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Health Property

ErrorInfoModelHealth Property

Gets or sets the health.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
member Health : Health with get, set

Property Value

Type: Health
The health.
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Id Property

ErrorInfoModelId Property

Gets or sets a value of error Id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Message Property

ErrorInfoModelMessage Property

Gets or sets a value of error message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Timestamp Property

ErrorInfoModelTimestamp Property

Gets or sets a value of error time stamp

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel Methods

The ErrorInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorInfoModel Class


ESXInfoModel Class

This class represents the general information about an ESX server.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsESXInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ESXInfoModel
Public Class ESXInfoModel
public ref class ESXInfoModel
type ESXInfoModel =  class end

The ESXInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ESXInfoModel | Initializes a new instance of the ESXInfoModel class
Top
Properties
 | Name | Description
Public property | FullName | Gets or sets the full name including the build number of the ESX server.
Public property | HasUserPermissions | Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.
Public property | UserRoleID | Gets or sets the logged on user's role id.
Public property | Version | Gets or sets the version of the ESX server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ESXInfoModel Constructor

Initializes a new instance of the ESXInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ESXInfoModel()
Public Sub New
public:
ESXInfoModel()
new : unit -> ESXInfoModel
See Also

Reference

ESXInfoModel Class


ESXInfoModel Properties

The ESXInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets or sets the full name including the build number of the ESX server.
Public property | HasUserPermissions | Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.
Public property | UserRoleID | Gets or sets the logged on user's role id.
Public property | Version | Gets or sets the version of the ESX server.
Top
See Also

Reference

ESXInfoModel Class


ESXInfoModel.FullName Property

ESXInfoModelFullName Property

Gets or sets the full name including the build number of the ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Property Value

Type: String
See Also

Reference

ESXInfoModel Class


ESXInfoModel.HasUserPermissions Property

ESXInfoModelHasUserPermissions Property

Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool HasUserPermissions { get; set; }
Public Property HasUserPermissions As Boolean
    Get
    Set
public:
property bool HasUserPermissions {
    bool get ();
    void set (bool value);
}
member HasUserPermissions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ESXInfoModel Class


ESXInfoModel.UserRoleID Property

ESXInfoModelUserRoleID Property

Gets or sets the logged on user's role id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int UserRoleID { get; set; }
Public Property UserRoleID As Integer
    Get
    Set
public:
property int UserRoleID {
    int get ();
    void set (int value);
}
member UserRoleID : int with get, set

Property Value

Type: Int32
See Also

Reference

ESXInfoModel Class


ESXInfoModel.Version Property

ESXInfoModelVersion Property

Gets or sets the version of the ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

ESXInfoModel Class


ESXInfoModel Methods

The ESXInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ESXInfoModel Class


FailoverPersistedStateModel Class

Failover persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverPersistedStateModel
Public NotInheritable Class FailoverPersistedStateModel
public ref class FailoverPersistedStateModel sealed
[<SealedAttribute>]
type FailoverPersistedStateModel =  class end

The FailoverPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverPersistedStateModel | Initializes a new instance of the FailoverPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailedOverAddresses | Gets or sets the failed over addresses.
Public property | FailedOverShares | Gets or sets the failed over shares.
Public property | LastKnownSourceShares | Gets or sets the last known source shares.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverPersistedStateModel Constructor

Initializes a new instance of the FailoverPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverPersistedStateModel()
Public Sub New
public:
FailoverPersistedStateModel()
new : unit -> FailoverPersistedStateModel
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel Properties

The FailoverPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailedOverAddresses | Gets or sets the failed over addresses.
Public property | FailedOverShares | Gets or sets the failed over shares.
Public property | LastKnownSourceShares | Gets or sets the last known source shares.
Top
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.FailedOverAddresses Property

FailoverPersistedStateModelFailedOverAddresses Property

Gets or sets the failed over addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<AddressPersistedStateModel> FailedOverAddresses { get; set; }
Public Property FailedOverAddresses As IEnumerable(Of AddressPersistedStateModel)
    Get
    Set
public:
property IEnumerable<AddressPersistedStateModel^>^ FailedOverAddresses {
    IEnumerable<AddressPersistedStateModel^>^ get ();
    void set (IEnumerable<AddressPersistedStateModel^>^ value);
}
member FailedOverAddresses : IEnumerable<AddressPersistedStateModel> with get, set

Property Value

Type: IEnumerable AddressPersistedStateModel
The failed over addresses.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.FailedOverShares Property

FailoverPersistedStateModelFailedOverShares Property

Gets or sets the failed over shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> FailedOverShares { get; set; }
Public Property FailedOverShares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ FailedOverShares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member FailedOverShares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
The failed over shares.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.LastKnownSourceShares Property

FailoverPersistedStateModelLastKnownSourceShares Property

Gets or sets the last known source shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> LastKnownSourceShares { get; set; }
Public Property LastKnownSourceShares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ LastKnownSourceShares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member LastKnownSourceShares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
The last known source shares.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel Methods

The FailoverPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverPersistedStateModel Class


FailoverReportingModel Class

Failover reporting data model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportingModel
Public NotInheritable Class FailoverReportingModel
public ref class FailoverReportingModel sealed
[<SealedAttribute>]
type FailoverReportingModel =  class end

The FailoverReportingModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportingModel | Initializes a new instance of the FailoverReportingModel class
Top
Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Public property | targetedMachineInfo | Information about the target machine.
Public property | times | Times for this failover
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportingModel Constructor

Initializes a new instance of the FailoverReportingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportingModel()
Public Sub New
public:
FailoverReportingModel()
new : unit -> FailoverReportingModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel Properties

The FailoverReportingModel type exposes the following members.

Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Public property | targetedMachineInfo | Information about the target machine.
Public property | times | Times for this failover
Top
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.failoverSuccess Property

FailoverReportingModelfailoverSuccess Property

Whether the failover was a success

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool failoverSuccess { get; set; }
Public Property failoverSuccess As Boolean
    Get
    Set
public:
property bool failoverSuccess {
    bool get ();
    void set (bool value);
}
member failoverSuccess : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.failoverType Property

FailoverReportingModelfailoverType Property

Type of failover being done.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTypeEnum failoverType { get; set; }
Public Property failoverType As FailoverReportTypeEnum
    Get
    Set
public:
property FailoverReportTypeEnum failoverType {
    FailoverReportTypeEnum get ();
    void set (FailoverReportTypeEnum value);
}
member failoverType : FailoverReportTypeEnum with get, set

Property Value

Type: FailoverReportTypeEnum
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.isReverse Property

FailoverReportingModelisReverse Property

Whether this is the reverse of the source in an FFO job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool isReverse { get; set; }
Public Property isReverse As Boolean
    Get
    Set
public:
property bool isReverse {
    bool get ();
    void set (bool value);
}
member isReverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobId Property

FailoverReportingModeljobId Property

Job id being reported

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string jobId { get; set; }
Public Property jobId As String
    Get
    Set
public:
property String^ jobId {
    String^ get ();
    void set (String^ value);
}
member jobId : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobName Property

FailoverReportingModeljobName Property

Name of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string jobName { get; set; }
Public Property jobName As String
    Get
    Set
public:
property String^ jobName {
    String^ get ();
    void set (String^ value);
}
member jobName : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobType Property

FailoverReportingModeljobType Property

This is the job type as described within JobInfo.cs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string jobType { get; set; }
Public Property jobType As String
    Get
    Set
public:
property String^ jobType {
    String^ get ();
    void set (String^ value);
}
member jobType : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.snapshotLabel Property

FailoverReportingModelsnapshotLabel Property

Label for the snapshot used. (Empty string for live data.)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string snapshotLabel { get; set; }
Public Property snapshotLabel As String
    Get
    Set
public:
property String^ snapshotLabel {
    String^ get ();
    void set (String^ value);
}
member snapshotLabel : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.targetedMachineInfo Property

FailoverReportingModeltargetedMachineInfo Property

Information about the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportMachineInfoModel targetedMachineInfo { get; set; }
Public Property targetedMachineInfo As FailoverReportMachineInfoModel
    Get
    Set
public:
property FailoverReportMachineInfoModel^ targetedMachineInfo {
    FailoverReportMachineInfoModel^ get ();
    void set (FailoverReportMachineInfoModel^ value);
}
member targetedMachineInfo : FailoverReportMachineInfoModel with get, set

Property Value

Type: FailoverReportMachineInfoModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.times Property

FailoverReportingModeltimes Property

Times for this failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTimesModel times { get; set; }
Public Property times As FailoverReportTimesModel
    Get
    Set
public:
property FailoverReportTimesModel^ times {
    FailoverReportTimesModel^ get ();
    void set (FailoverReportTimesModel^ value);
}
member times : FailoverReportTimesModel with get, set

Property Value

Type: FailoverReportTimesModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel Methods

The FailoverReportingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportingModel Class


FailoverReportMachineInfoModel Class

Data about the target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportMachineInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportMachineInfoModel
Public NotInheritable Class FailoverReportMachineInfoModel
public ref class FailoverReportMachineInfoModel sealed
[<SealedAttribute>]
type FailoverReportMachineInfoModel =  class end

The FailoverReportMachineInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportMachineInfoModel | Initializes a new instance of the FailoverReportMachineInfoModel class
Top
Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportMachineInfoModel Constructor

Initializes a new instance of the FailoverReportMachineInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportMachineInfoModel()
Public Sub New
public:
FailoverReportMachineInfoModel()
new : unit -> FailoverReportMachineInfoModel
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel Properties

The FailoverReportMachineInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel.os Property

FailoverReportMachineInfoModelos Property

OS on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string os { get; set; }
Public Property os As String
    Get
    Set
public:
property String^ os {
    String^ get ();
    void set (String^ value);
}
member os : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel.osVersion Property

FailoverReportMachineInfoModelosVersion Property

OS version on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string osVersion { get; set; }
Public Property osVersion As String
    Get
    Set
public:
property String^ osVersion {
    String^ get ();
    void set (String^ value);
}
member osVersion : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel Methods

The FailoverReportMachineInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportTimesModel Class

Time at various points of the failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportTimesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportTimesModel
Public NotInheritable Class FailoverReportTimesModel
public ref class FailoverReportTimesModel sealed
[<SealedAttribute>]
type FailoverReportTimesModel =  class end

The FailoverReportTimesModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportTimesModel | Initializes a new instance of the FailoverReportTimesModel class
Top
Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportTimesModel Constructor

Initializes a new instance of the FailoverReportTimesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTimesModel()
Public Sub New
public:
FailoverReportTimesModel()
new : unit -> FailoverReportTimesModel
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel Properties

The FailoverReportTimesModel type exposes the following members.

Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.completed Property

FailoverReportTimesModelcompleted Property

Time that the failover is considered complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> completed { get; set; }
Public Property completed As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> completed {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member completed : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.startProcessing Property

FailoverReportTimesModelstartProcessing Property

Time the failover processing started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTime startProcessing { get; set; }
Public Property startProcessing As DateTime
    Get
    Set
public:
property DateTime startProcessing {
    DateTime get ();
    void set (DateTime value);
}
member startProcessing : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.startReboot Property

FailoverReportTimesModelstartReboot Property

Time when the reboot started. NOTE: For data only jobs, this time will be null.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> startReboot { get; set; }
Public Property startReboot As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> startReboot {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member startReboot : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel Methods

The FailoverReportTimesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTypeEnum Enumeration

Type of failover being used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverReportTypeEnum
Public Enumeration FailoverReportTypeEnum
public enum class FailoverReportTypeEnum
type FailoverReportTypeEnum
Members
Member name | Value | Description
Live | 0 | Live failover is being done.
Test | 1 | Test failover is being done.
See Also

Reference

DoubleTake.Web.Models Namespace


FilesAndFoldersPersistedStateModel Class

Files and Folders persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFilesAndFoldersPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FilesAndFoldersPersistedStateModel
Public NotInheritable Class FilesAndFoldersPersistedStateModel
public ref class FilesAndFoldersPersistedStateModel sealed
[<SealedAttribute>]
type FilesAndFoldersPersistedStateModel =  class end

The FilesAndFoldersPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FilesAndFoldersPersistedStateModel | Initializes a new instance of the FilesAndFoldersPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailedSubState | Gets or sets a value indicating the sub-state when the State property is Failed.
Public property | MainConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | MonitorId | Gets or sets the id of the Monitoring Framework monitor used by this job.
Public property | MonitorPersistedState | Gets or sets the monitor's persisted state.
Public property | OriginalSourceAddress | Gets or sets the original source address.
Public property | OriginalSourceHostUri | Gets or sets the original source URI.
Public property | OriginalSourceMachineName | Gets or sets the name of the original source machine.
Public property | OriginalSourceUniqueId | Gets or sets the original source's unique id.
Public property | RestoreTargetHostUri | Gets or sets the restore target URI.
Public property | RestoreTargetUniqueId | Gets or sets the restore target's unique id.
Public property | State | Gets or sets the persisted state of the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FilesAndFoldersPersistedStateModel Constructor

Initializes a new instance of the FilesAndFoldersPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FilesAndFoldersPersistedStateModel()
Public Sub New
public:
FilesAndFoldersPersistedStateModel()
new : unit -> FilesAndFoldersPersistedStateModel
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel Properties

The FilesAndFoldersPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailedSubState | Gets or sets a value indicating the sub-state when the State property is Failed.
Public property | MainConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | MonitorId | Gets or sets the id of the Monitoring Framework monitor used by this job.
Public property | MonitorPersistedState | Gets or sets the monitor's persisted state.
Public property | OriginalSourceAddress | Gets or sets the original source address.
Public property | OriginalSourceHostUri | Gets or sets the original source URI.
Public property | OriginalSourceMachineName | Gets or sets the name of the original source machine.
Public property | OriginalSourceUniqueId | Gets or sets the original source's unique id.
Public property | RestoreTargetHostUri | Gets or sets the restore target URI.
Public property | RestoreTargetUniqueId | Gets or sets the restore target's unique id.
Public property | State | Gets or sets the persisted state of the job.
Top
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.FailedSubState Property

FilesAndFoldersPersistedStateModelFailedSubState Property

Gets or sets a value indicating the sub-state when the State property is Failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FailedSubState { get; set; }
Public Property FailedSubState As String
    Get
    Set
public:
property String^ FailedSubState {
    String^ get ();
    void set (String^ value);
}
member FailedSubState : string with get, set

Property Value

Type: String
The sub-state when the State property is Failed.
Remarks
Possible values for this property:
Value | Description
FailedOver | The job is in a failed-over state which means that the target is standing in for the source.
FailedBack | The target is no longer standing in for the source
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MainConnectionPersistedState Property

FilesAndFoldersPersistedStateModelMainConnectionPersistedState Property

Gets or sets the main connection's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel MainConnectionPersistedState { get; set; }
Public Property MainConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ MainConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member MainConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The main connection's persisted state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MonitorId Property

FilesAndFoldersPersistedStateModelMonitorId Property

Gets or sets the id of the Monitoring Framework monitor used by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
The id of the Monitoring Framework monitor used by this job.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MonitorPersistedState Property

FilesAndFoldersPersistedStateModelMonitorPersistedState Property

Gets or sets the monitor's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel MonitorPersistedState { get; set; }
Public Property MonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ MonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member MonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The monitor's persisted state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceAddress Property

FilesAndFoldersPersistedStateModelOriginalSourceAddress Property

Gets or sets the original source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceAddress { get; set; }
Public Property OriginalSourceAddress As String
    Get
    Set
public:
property String^ OriginalSourceAddress {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceAddress : string with get, set

Property Value

Type: String
The original source address.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceHostUri Property

FilesAndFoldersPersistedStateModelOriginalSourceHostUri Property

Gets or sets the original source URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri OriginalSourceHostUri { get; set; }
Public Property OriginalSourceHostUri As Uri
    Get
    Set
public:
property Uri^ OriginalSourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member OriginalSourceHostUri : Uri with get, set

Property Value

Type: Uri
The original source URI.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceMachineName Property

FilesAndFoldersPersistedStateModelOriginalSourceMachineName Property

Gets or sets the name of the original source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceMachineName { get; set; }
Public Property OriginalSourceMachineName As String
    Get
    Set
public:
property String^ OriginalSourceMachineName {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceMachineName : string with get, set

Property Value

Type: String
The name of the original source machine.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceUniqueId Property

FilesAndFoldersPersistedStateModelOriginalSourceUniqueId Property

Gets or sets the original source's unique id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceUniqueId { get; set; }
Public Property OriginalSourceUniqueId As String
    Get
    Set
public:
property String^ OriginalSourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceUniqueId : string with get, set

Property Value

Type: String
The original source's unique id.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.RestoreTargetHostUri Property

FilesAndFoldersPersistedStateModelRestoreTargetHostUri Property

Gets or sets the restore target URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RestoreTargetHostUri : Uri with get, set

Property Value

Type: Uri
The restore target URI.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.RestoreTargetUniqueId Property

FilesAndFoldersPersistedStateModelRestoreTargetUniqueId Property

Gets or sets the restore target's unique id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RestoreTargetUniqueId { get; set; }
Public Property RestoreTargetUniqueId As String
    Get
    Set
public:
property String^ RestoreTargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member RestoreTargetUniqueId : string with get, set

Property Value

Type: String
The restore target's unique id.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.State Property

FilesAndFoldersPersistedStateModelState Property

Gets or sets the persisted state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The persisted state of the job.
Remarks
Possible values for this property:
Value | Description
None | No state had been determined due to failed initialization.
Stopped | The job was in a stopped state.
Protecting | The job was in a protecting state.
Restoring | The job was restoring.
Failed | The job was in a failed state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel Methods

The FilesAndFoldersPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FullServerJobTypeEnum Enumeration

This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum FullServerJobTypeEnum
Public Enumeration FullServerJobTypeEnum
public enum class FullServerJobTypeEnum
type FullServerJobTypeEnum
Members
Member name | Value | Description
FullServerProtection | 0 | The full server protection
ImageRepositoryFailover | 1 | The image repository failover
BackupRecovery | 2 | The backup recovery
MoveServerMigration | 3 | The move server migration
PreFailoverTest | 4 | The pre failover test
PreFailoverTestWithReservedIPs | 5 | The pre failover test with reserved i ps
SnapshotMirror | 6 | The snapshot mirror
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerPersistedStateModel Class

Full server persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerPersistedStateModel
Public NotInheritable Class FullServerPersistedStateModel
public ref class FullServerPersistedStateModel sealed
[<SealedAttribute>]
type FullServerPersistedStateModel =  class end

The FullServerPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerPersistedStateModel | Initializes a new instance of the FullServerPersistedStateModel class
Top
Properties
 | Name | Description
Public property | BackupConnectionPersistedState | Gets or sets the state of the backup connection persisted.
Public property | BackupTargetState | Gets or sets the state of the backup target.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Public property | SystemVolumeRevertPersistedState | Gets or sets the state of the system volume revert persisted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerPersistedStateModel Constructor

Initializes a new instance of the FullServerPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FullServerPersistedStateModel()
Public Sub New
public:
FullServerPersistedStateModel()
new : unit -> FullServerPersistedStateModel
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel Properties

The FullServerPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionPersistedState | Gets or sets the state of the backup connection persisted.
Public property | BackupTargetState | Gets or sets the state of the backup target.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Public property | SystemVolumeRevertPersistedState | Gets or sets the state of the system volume revert persisted.
Top
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.BackupConnectionPersistedState Property

FullServerPersistedStateModelBackupConnectionPersistedState Property

Gets or sets the state of the backup connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel BackupConnectionPersistedState { get; set; }
Public Property BackupConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ BackupConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member BackupConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the backup connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.BackupTargetState Property

FullServerPersistedStateModelBackupTargetState Property

Gets or sets the state of the backup target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> BackupTargetState { get; set; }
Public Property BackupTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> BackupTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member BackupTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the backup target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.FailoverOptions Property

FullServerPersistedStateModelFailoverOptions Property

Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.ProtectionConnectionPersistedState Property

FullServerPersistedStateModelProtectionConnectionPersistedState Property

Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.ProtectionTargetState Property

FullServerPersistedStateModelProtectionTargetState Property

Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.RecoveryConnectionPersistedState Property

FullServerPersistedStateModelRecoveryConnectionPersistedState Property

Gets or sets the state of the recovery connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RecoveryConnectionPersistedState { get; set; }
Public Property RecoveryConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RecoveryConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RecoveryConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.RecoveryTargetState Property

FullServerPersistedStateModelRecoveryTargetState Property

Gets or sets the state of the recovery target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> RecoveryTargetState { get; set; }
Public Property RecoveryTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> RecoveryTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member RecoveryTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the recovery target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.State Property

FullServerPersistedStateModelState Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.SystemVolumeRevertPersistedState Property

FullServerPersistedStateModelSystemVolumeRevertPersistedState Property

Gets or sets the state of the system volume revert persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel SystemVolumeRevertPersistedState { get; set; }
Public Property SystemVolumeRevertPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ SystemVolumeRevertPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member SystemVolumeRevertPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the system volume revert persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel Methods

The FullServerPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerPersistedStateModel Class


HeartbeatPingQueryInputModel Class

Represents the input to a Double-Take heartbeat ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsHeartbeatPingQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class HeartbeatPingQueryInputModel : QueryInputModel
Public Class HeartbeatPingQueryInputModel
    Inherits QueryInputModel
public ref class HeartbeatPingQueryInputModel : public QueryInputModel
type HeartbeatPingQueryInputModel =
    class
        inherit QueryInputModel
    end

The HeartbeatPingQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryInputModel | Initializes a new instance of the HeartbeatPingQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | EnginePort | Gets or sets the engine port.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


HeartbeatPingQueryInputModel Constructor

Initializes a new instance of the HeartbeatPingQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public HeartbeatPingQueryInputModel()
Public Sub New
public:
HeartbeatPingQueryInputModel()
new : unit -> HeartbeatPingQueryInputModel
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel Properties

The HeartbeatPingQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | EnginePort | Gets or sets the engine port.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel.EnginePort Property

HeartbeatPingQueryInputModelEnginePort Property

Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel.IPAddress Property

HeartbeatPingQueryInputModelIPAddress Property

Gets or sets the IP address to ping for a heartbeat.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address to ping for a heartbeat.
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel Methods

The HeartbeatPingQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryResultModel Class

Represents the results of a heartbeat ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsHeartbeatPingQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class HeartbeatPingQueryResultModel : QueryResultModel
Public Class HeartbeatPingQueryResultModel
    Inherits QueryResultModel
public ref class HeartbeatPingQueryResultModel : public QueryResultModel
type HeartbeatPingQueryResultModel =
    class
        inherit QueryResultModel
    end

The HeartbeatPingQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryResultModel | Initializes a new instance of the HeartbeatPingQueryResultModel class
Top
Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


HeartbeatPingQueryResultModel Constructor

Initializes a new instance of the HeartbeatPingQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public HeartbeatPingQueryResultModel()
Public Sub New
public:
HeartbeatPingQueryResultModel()
new : unit -> HeartbeatPingQueryResultModel
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel Properties

The HeartbeatPingQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel.EnginePort Property

HeartbeatPingQueryResultModelEnginePort Property

Gets or sets the engine port that was used to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
The engine port that was used to ping.
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel.IPAddress Property

HeartbeatPingQueryResultModelIPAddress Property

Gets or sets the IP address that was pinged during this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address that was pinged during this query.
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel Methods

The HeartbeatPingQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeartbeatPingQueryResultModel Class


IcmpPingQueryInputModel Class

Represents the input to an ICMP ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsIcmpPingQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class IcmpPingQueryInputModel : QueryInputModel
Public Class IcmpPingQueryInputModel
    Inherits QueryInputModel
public ref class IcmpPingQueryInputModel : public QueryInputModel
type IcmpPingQueryInputModel =
    class
        inherit QueryInputModel
    end

The IcmpPingQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryInputModel | Initializes a new instance of the IcmpPingQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IcmpPingQueryInputModel Constructor

Initializes a new instance of the IcmpPingQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IcmpPingQueryInputModel()
Public Sub New
public:
IcmpPingQueryInputModel()
new : unit -> IcmpPingQueryInputModel
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel Properties

The IcmpPingQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel.NetworkId Property

IcmpPingQueryInputModelNetworkId Property

Gets or sets the server name or IP address to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The server name or IP address to ping.
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel Methods

The IcmpPingQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryResultModel Class

Represents the results of an ICMP ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsIcmpPingQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class IcmpPingQueryResultModel : QueryResultModel
Public Class IcmpPingQueryResultModel
    Inherits QueryResultModel
public ref class IcmpPingQueryResultModel : public QueryResultModel
type IcmpPingQueryResultModel =
    class
        inherit QueryResultModel
    end

The IcmpPingQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryResultModel | Initializes a new instance of the IcmpPingQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IcmpPingQueryResultModel Constructor

Initializes a new instance of the IcmpPingQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IcmpPingQueryResultModel()
Public Sub New
public:
IcmpPingQueryResultModel()
new : unit -> IcmpPingQueryResultModel
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel Properties

The IcmpPingQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.ExceptionDetail Property

IcmpPingQueryResultModelExceptionDetail Property

Gets or sets the exception detail.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ ExceptionDetail {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member ExceptionDetail : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The exception detail.
Remarks
This property will only be non- if an exception was thrown by the ICMP ping operation.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.NetworkId Property

IcmpPingQueryResultModelNetworkId Property

Gets or sets the network id that was pinged.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id that was pinged.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.ReplyAddress Property

IcmpPingQueryResultModelReplyAddress Property

Gets or sets the IP address from which the reply was sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplyAddress { get; set; }
Public Property ReplyAddress As String
    Get
    Set
public:
property String^ ReplyAddress {
    String^ get ();
    void set (String^ value);
}
member ReplyAddress : string with get, set

Property Value

Type: String
The IP address from which the reply was sent.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.Roundtrip Property

IcmpPingQueryResultModelRoundtrip Property

Gets or sets the duration of the ICMP ping round-trip.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Roundtrip { get; set; }
Public Property Roundtrip As TimeSpan
    Get
    Set
public:
property TimeSpan Roundtrip {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Roundtrip : TimeSpan with get, set

Property Value

Type: TimeSpan
The duration of the ICMP ping round-trip.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.Status Property

IcmpPingQueryResultModelStatus Property

Gets or sets the IPStatus from the ping reply as a string.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
The IPStatus from the ping reply as a string.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel Methods

The IcmpPingQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IcmpPingQueryResultModel Class


ImageProtectionPersistedStateModel Class

Image protection persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionPersistedStateModel
Public NotInheritable Class ImageProtectionPersistedStateModel
public ref class ImageProtectionPersistedStateModel sealed
[<SealedAttribute>]
type ImageProtectionPersistedStateModel =  class end

The ImageProtectionPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionPersistedStateModel | Initializes a new instance of the ImageProtectionPersistedStateModel class
Top
Properties
 | Name | Description
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionPersistedStateModel Constructor

Initializes a new instance of the ImageProtectionPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionPersistedStateModel()
Public Sub New
public:
ImageProtectionPersistedStateModel()
new : unit -> ImageProtectionPersistedStateModel
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel Properties

The ImageProtectionPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | State | Gets or sets the state.
Top
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.ProtectionConnectionPersistedState Property

ImageProtectionPersistedStateModelProtectionConnectionPersistedState Property

Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.ProtectionTargetState Property

ImageProtectionPersistedStateModelProtectionTargetState Property

Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.State Property

ImageProtectionPersistedStateModelState Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel Methods

The ImageProtectionPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageRecoveryPersistedStateModel Class

Image recovery persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryPersistedStateModel
Public NotInheritable Class ImageRecoveryPersistedStateModel
public ref class ImageRecoveryPersistedStateModel sealed
[<SealedAttribute>]
type ImageRecoveryPersistedStateModel =  class end

The ImageRecoveryPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryPersistedStateModel | Initializes a new instance of the ImageRecoveryPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the failover options.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryPersistedStateModel Constructor

Initializes a new instance of the ImageRecoveryPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryPersistedStateModel()
Public Sub New
public:
ImageRecoveryPersistedStateModel()
new : unit -> ImageRecoveryPersistedStateModel
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel Properties

The ImageRecoveryPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the failover options.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Top
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.FailoverOptions Property

ImageRecoveryPersistedStateModelFailoverOptions Property

Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.RecoveryConnectionPersistedState Property

ImageRecoveryPersistedStateModelRecoveryConnectionPersistedState Property

Gets or sets the state of the recovery connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RecoveryConnectionPersistedState { get; set; }
Public Property RecoveryConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RecoveryConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RecoveryConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.RecoveryTargetState Property

ImageRecoveryPersistedStateModelRecoveryTargetState Property

Gets or sets the state of the recovery target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> RecoveryTargetState { get; set; }
Public Property RecoveryTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> RecoveryTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member RecoveryTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the recovery target.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.State Property

ImageRecoveryPersistedStateModelState Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel Methods

The ImageRecoveryPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryPersistedStateModel Class


IntegerSettingModel Class

Integer setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsIntegerSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class IntegerSettingModel : NamedSettingModel
Public Class IntegerSettingModel
    Inherits NamedSettingModel
public ref class IntegerSettingModel : public NamedSettingModel
type IntegerSettingModel =
    class
        inherit NamedSettingModel
    end

The IntegerSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerSettingModel | Initializes a new instance of the IntegerSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IntegerSettingModel Constructor

Initializes a new instance of the IntegerSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IntegerSettingModel()
Public Sub New
public:
IntegerSettingModel()
new : unit -> IntegerSettingModel
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel Properties

The IntegerSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel.Value Property

IntegerSettingModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel Methods

The IntegerSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntegerSettingModel Class


IPAddressModel Class

IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsIPAddressModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class IPAddressModel
Public Class IPAddressModel
public ref class IPAddressModel
type IPAddressModel =  class end

The IPAddressModel type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressModel | Initializes a new instance of the IPAddressModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IPAddressModel Constructor

Initializes a new instance of the IPAddressModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IPAddressModel()
Public Sub New
public:
IPAddressModel()
new : unit -> IPAddressModel
See Also

Reference

IPAddressModel Class


IPAddressModel Properties

The IPAddressModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
See Also

Reference

IPAddressModel Class


IPAddressModel.Address Property

IPAddressModelAddress Property

Gets or sets the address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public byte[] Address { get; set; }
Public Property Address As Byte()
    Get
    Set
public:
property array<unsigned char>^ Address {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Address : byte[] with get, set

Property Value

Type: Byte
The address.
See Also

Reference

IPAddressModel Class


IPAddressModel Methods

The IPAddressModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IPAddressModel Class


JobInfoPrivateModel Class

Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobInfoPrivateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobInfoPrivateModel
Public NotInheritable Class JobInfoPrivateModel
public ref class JobInfoPrivateModel sealed
[<SealedAttribute>]
type JobInfoPrivateModel =  class end

The JobInfoPrivateModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfoPrivateModel | Initializes a new instance of the JobInfoPrivateModel class
Top
Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created the job.
Public property | Features | Gets or sets a service endpoint that provides additional features for a job.
Public property | Id | Gets or sets the unique identifier.
Public property | JobType | Gets or sets the type of job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether the job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether the job is managed.
Public property | Options | Gets or sets the current options for the job.
Public property | OtherHostUris | Gets or sets the URIs for other servers involved in the job.
Public property | SourceHostUri | Gets or sets the source URI.
Public property | SourceUniqueId | Gets or sets the unique ID of the source server.
Public property | Statistics | Gets or sets the current statistics of the job
Public property | Status | Gets or sets the current state of the job.
Public property | TargetHostUri | Gets or sets the target URI.
Public property | TargetUniqueId | Gets or sets the unique ID of the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobInfoPrivateModel Constructor

Initializes a new instance of the JobInfoPrivateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobInfoPrivateModel()
Public Sub New
public:
JobInfoPrivateModel()
new : unit -> JobInfoPrivateModel
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel Properties

The JobInfoPrivateModel type exposes the following members.

Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created the job.
Public property | Features | Gets or sets a service endpoint that provides additional features for a job.
Public property | Id | Gets or sets the unique identifier.
Public property | JobType | Gets or sets the type of job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether the job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether the job is managed.
Public property | Options | Gets or sets the current options for the job.
Public property | OtherHostUris | Gets or sets the URIs for other servers involved in the job.
Public property | SourceHostUri | Gets or sets the source URI.
Public property | SourceUniqueId | Gets or sets the unique ID of the source server.
Public property | Statistics | Gets or sets the current statistics of the job
Public property | Status | Gets or sets the current state of the job.
Public property | TargetHostUri | Gets or sets the target URI.
Public property | TargetUniqueId | Gets or sets the unique ID of the target server.
Top
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.CreatorUserName Property

JobInfoPrivateModelCreatorUserName Property

Gets or sets the name of the user who created the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
member CreatorUserName : string with get, set

Property Value

Type: String
The name of the user who created this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Features Property

JobInfoPrivateModelFeatures Property

Gets or sets a service endpoint that provides additional features for a job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel[] Features { get; set; }
Public Property Features As FeatureModel()
    Get
    Set
public:
property array<FeatureModel^>^ Features {
    array<FeatureModel^>^ get ();
    void set (array<FeatureModel^>^ value);
}
member Features : FeatureModel[] with get, set

Property Value

Type: FeatureModel
An array of Feature that includes the additional features supported by this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Id Property

JobInfoPrivateModelId Property

Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
The unique identifier.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.JobType Property

JobInfoPrivateModelJobType Property

Gets or sets the type of job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The type of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.LoadedFromDisk Property

JobInfoPrivateModelLoadedFromDisk Property

Gets or sets a value indicating whether the job was loaded from persistence.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
member LoadedFromDisk : bool with get, set

Property Value

Type: Boolean
if this job was loaded from persistence; otherwise, .
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Managed Property

JobInfoPrivateModelManaged Property

Gets or sets a value indicating whether the job is managed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
member Managed : bool with get, set

Property Value

Type: Boolean
if this job is managed; otherwise, .
Remarks
This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime. Typically, jobs who have this property set to will be added to the job manager using the [M:Add] method.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Options Property

JobInfoPrivateModelOptions Property

Gets or sets the current options for the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel Options { get; set; }
Public Property Options As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ Options {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member Options : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
A JobOptions that represents the current options for this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.OtherHostUris Property

JobInfoPrivateModelOtherHostUris Property

Gets or sets the URIs for other servers involved in the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, Uri> OtherHostUris { get; set; }
Public Property OtherHostUris As IDictionary(Of String, Uri)
    Get
    Set
public:
property IDictionary<String^, Uri^>^ OtherHostUris {
    IDictionary<String^, Uri^>^ get ();
    void set (IDictionary<String^, Uri^>^ value);
}
member OtherHostUris : IDictionary<string, Uri> with get, set

Property Value

Type: IDictionary String, Uri
The other server URIs.
Remarks
This property serves as a replacement for the OtherNetworkIds property. Please refrain from using the OtherNetworkIds property.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.SourceHostUri Property

JobInfoPrivateModelSourceHostUri Property

Gets or sets the source URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member SourceHostUri : Uri with get, set

Property Value

Type: Uri
The source URI.
Remarks
This property serves as a replacement for the SourceNetworkId and SourceManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.SourceUniqueId Property

JobInfoPrivateModelSourceUniqueId Property

Gets or sets the unique ID of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Statistics Property

JobInfoPrivateModelStatistics Property

Gets or sets the current statistics of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel Statistics { get; set; }
Public Property Statistics As JobStatisticsModel
    Get
    Set
public:
property JobStatisticsModel^ Statistics {
    JobStatisticsModel^ get ();
    void set (JobStatisticsModel^ value);
}
member Statistics : JobStatisticsModel with get, set

Property Value

Type: JobStatisticsModel
A JobStatistics that represents the current statistics of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Status Property

JobInfoPrivateModelStatus Property

Gets or sets the current state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel Status { get; set; }
Public Property Status As JobStatusModel
    Get
    Set
public:
property JobStatusModel^ Status {
    JobStatusModel^ get ();
    void set (JobStatusModel^ value);
}
member Status : JobStatusModel with get, set

Property Value

Type: JobStatusModel
A JobStatus that represents the current status of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.TargetHostUri Property

JobInfoPrivateModelTargetHostUri Property

Gets or sets the target URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri TargetHostUri { get; set; }
Public Property TargetHostUri As Uri
    Get
    Set
public:
property Uri^ TargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member TargetHostUri : Uri with get, set

Property Value

Type: Uri
The target URI.
Remarks
This property serves as a replacement for the TargetNetworkId and TargetManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.TargetUniqueId Property

JobInfoPrivateModelTargetUniqueId Property

Gets or sets the unique ID of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel Methods

The JobInfoPrivateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobInfoPrivateModel Class


JobParametersModel Class

Job parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobParametersModel
Public NotInheritable Class JobParametersModel
public ref class JobParametersModel sealed
[<SealedAttribute>]
type JobParametersModel =  class end

The JobParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobParametersModel | Initializes a new instance of the JobParametersModel class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.
Public property | Properties | Gets or sets the properties.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | Gets or sets the type of workload to create. See Create
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobParametersModel Constructor

Initializes a new instance of the JobParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobParametersModel()
Public Sub New
public:
JobParametersModel()
new : unit -> JobParametersModel
See Also

Reference

JobParametersModel Class


JobParametersModel Properties

The JobParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.
Public property | Properties | Gets or sets the properties.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | Gets or sets the type of workload to create. See Create
Top
See Also

Reference

JobParametersModel Class


JobParametersModel.ConnectionStartParameters Property

JobParametersModelConnectionStartParameters Property

Gets or sets the connection start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The connection start parameters.
See Also

Reference

JobParametersModel Class


JobParametersModel.EngineJobType Property

JobParametersModelEngineJobType Property

Gets or sets the engine job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
The engine job type.
See Also

Reference

JobParametersModel Class


JobParametersModel.JobType Property

JobParametersModelJobType Property

Gets or sets the the job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The the job type.
See Also

Reference

JobParametersModel Class


JobParametersModel.Monitor Property

JobParametersModelMonitor Property

Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel Monitor { get; set; }
Public Property Monitor As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ Monitor {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member Monitor : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

JobParametersModel Class


JobParametersModel.PathTransformations Property

JobParametersModelPathTransformations Property

Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

JobParametersModel Class


JobParametersModel.Properties Property

JobParametersModelProperties Property

Gets or sets the properties.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PropertyModel[] Properties { get; set; }
Public Property Properties As PropertyModel()
    Get
    Set
public:
property array<PropertyModel^>^ Properties {
    array<PropertyModel^>^ get ();
    void set (array<PropertyModel^>^ value);
}
member Properties : PropertyModel[] with get, set

Property Value

Type: PropertyModel
See Also

Reference

JobParametersModel Class


JobParametersModel.SourceAddresses Property

JobParametersModelSourceAddresses Property

Gets or sets the source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] SourceAddresses { get; set; }
Public Property SourceAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ SourceAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member SourceAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
The source addresses.
Remarks
These addresses are used by the Management Service on the job host to communicate with the source. If there is a NAT firewall in between the source and the target
See Also

Reference

JobParametersModel Class


JobParametersModel.TargetAddress Property

JobParametersModelTargetAddress Property

Gets or sets the target address over which the data will be mirrored and replicated from the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel TargetAddress { get; set; }
Public Property TargetAddress As UnicastIPAddressModel
    Get
    Set
public:
property UnicastIPAddressModel^ TargetAddress {
    UnicastIPAddressModel^ get ();
    void set (UnicastIPAddressModel^ value);
}
member TargetAddress : UnicastIPAddressModel with get, set

Property Value

Type: UnicastIPAddressModel
The target address.
See Also

Reference

JobParametersModel Class


JobParametersModel.WorkloadRules Property

JobParametersModelWorkloadRules Property

Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] WorkloadRules { get; set; }
Public Property WorkloadRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ WorkloadRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member WorkloadRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The workload rules.
See Also

Reference

JobParametersModel Class


JobParametersModel.WorkloadType Property

JobParametersModelWorkloadType Property

Gets or sets the type of workload to create. See Create

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string WorkloadType { get; set; }
Public Property WorkloadType As String
    Get
    Set
public:
property String^ WorkloadType {
    String^ get ();
    void set (String^ value);
}
member WorkloadType : string with get, set

Property Value

Type: String
See Also

Reference

JobParametersModel Class
DoubleTake.Web.Models Namespace
ICoreWorkload.Create


JobParametersModel Methods

The JobParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobParametersModel Class


JobStateModel Class

Represents job state information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStateModel
Public NotInheritable Class JobStateModel
public ref class JobStateModel sealed
[<SealedAttribute>]
type JobStateModel =  class end

The JobStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStateModel | Initializes a new instance of the JobStateModel class
Top
Properties
 | Name | Description
Public property | HasError | Gets or sets a value indicating whether the job has an error.
Public property | HighLevel | Gets or sets the high level state.
Public property | IsInSync | Gets or sets a value indicating whether the job is already in sync
Public property | LowLevel | Gets or sets a value of low level state
Public property | RecentErrors | Gets or sets a value of list of recent errors
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStateModel Constructor

Initializes a new instance of the JobStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel()
Public Sub New
public:
JobStateModel()
new : unit -> JobStateModel
See Also

Reference

JobStateModel Class


JobStateModel Properties

The JobStateModel type exposes the following members.

Properties
 | Name | Description
Public property | HasError | Gets or sets a value indicating whether the job has an error.
Public property | HighLevel | Gets or sets the high level state.
Public property | IsInSync | Gets or sets a value indicating whether the job is already in sync
Public property | LowLevel | Gets or sets a value of low level state
Public property | RecentErrors | Gets or sets a value of list of recent errors
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
See Also

Reference

JobStateModel Class


JobStateModel.HasError Property

JobStateModelHasError Property

Gets or sets a value indicating whether the job has an error.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool HasError { get; set; }
Public Property HasError As Boolean
    Get
    Set
public:
property bool HasError {
    bool get ();
    void set (bool value);
}
member HasError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStateModel Class


JobStateModel.HighLevel Property

JobStateModelHighLevel Property

Gets or sets the high level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string HighLevel { get; set; }
Public Property HighLevel As String
    Get
    Set
public:
property String^ HighLevel {
    String^ get ();
    void set (String^ value);
}
member HighLevel : string with get, set

Property Value

Type: String
The high level state.
See Also

Reference

JobStateModel Class


JobStateModel.IsInSync Property

JobStateModelIsInSync Property

Gets or sets a value indicating whether the job is already in sync

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsInSync { get; set; }
Public Property IsInSync As Boolean
    Get
    Set
public:
property bool IsInSync {
    bool get ();
    void set (bool value);
}
member IsInSync : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStateModel Class


JobStateModel.LowLevel Property

JobStateModelLowLevel Property

Gets or sets a value of low level state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string LowLevel { get; set; }
Public Property LowLevel As String
    Get
    Set
public:
property String^ LowLevel {
    String^ get ();
    void set (String^ value);
}
member LowLevel : string with get, set

Property Value

Type: String
See Also

Reference

JobStateModel Class


JobStateModel.RecentErrors Property

JobStateModelRecentErrors Property

Gets or sets a value of list of recent errors

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public List<ErrorInfoModel> RecentErrors { get; set; }
Public Property RecentErrors As List(Of ErrorInfoModel)
    Get
    Set
public:
property List<ErrorInfoModel^>^ RecentErrors {
    List<ErrorInfoModel^>^ get ();
    void set (List<ErrorInfoModel^>^ value);
}
member RecentErrors : List<ErrorInfoModel> with get, set

Property Value

Type: List ErrorInfoModel
See Also

Reference

JobStateModel Class


JobStateModel.SourceActivationCodeMessages Property

JobStateModelSourceActivationCodeMessages Property

Gets or sets the activation code messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] SourceActivationCodeMessages { get; set; }
Public Property SourceActivationCodeMessages As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ SourceActivationCodeMessages {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member SourceActivationCodeMessages : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
The activation code messages.
See Also

Reference

JobStateModel Class


JobStateModel.TargetActivationCodeMessages Property

JobStateModelTargetActivationCodeMessages Property

Gets or sets the activation code messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] TargetActivationCodeMessages { get; set; }
Public Property TargetActivationCodeMessages As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ TargetActivationCodeMessages {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member TargetActivationCodeMessages : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
The activation code messages.
See Also

Reference

JobStateModel Class


JobStateModel Methods

The JobStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStateModel Class


JobUsageDataModel Class

Job usage data.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobUsageDataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobUsageDataModel
Public NotInheritable Class JobUsageDataModel
public ref class JobUsageDataModel sealed
[<SealedAttribute>]
type JobUsageDataModel =  class end

The JobUsageDataModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobUsageDataModel | Initializes a new instance of the JobUsageDataModel class
Top
Properties
 | Name | Description
Public property | IsInitialData | Gets or sets a value indicating whether the initial data was recorded when the job was created.
Public property | JobOrConnectionId | Gets or sets the job or connection ID.
Public property | JobOrConnectionName | Gets or sets the job or connection name.
Public property | JobOrConnectionType | Gets or sets the job or connection type.
Public property | JobStatus | Gets or sets the job status.
Public property | PersistencePath | Gets or sets the job persistence path.
Public property | SourceActivationStatus | Gets or sets the source activation status.
Public property | SourceNetworkId | Gets or sets the source network ID (usually host name).
Public property | SourceUniqueId | Gets or sets the source unique ID (aka hardware ID).
Public property | TargetNetworkId | Gets or sets the target network ID (usually host name).
Public property | TargetUniqueId | Gets or sets the target unique ID (aka hardware ID).
Public property | Timestamp | Gets or sets the time when the data was collected.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobUsageDataModel Constructor

Initializes a new instance of the JobUsageDataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobUsageDataModel()
Public Sub New
public:
JobUsageDataModel()
new : unit -> JobUsageDataModel
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel Properties

The JobUsageDataModel type exposes the following members.

Properties
 | Name | Description
Public property | IsInitialData | Gets or sets a value indicating whether the initial data was recorded when the job was created.
Public property | JobOrConnectionId | Gets or sets the job or connection ID.
Public property | JobOrConnectionName | Gets or sets the job or connection name.
Public property | JobOrConnectionType | Gets or sets the job or connection type.
Public property | JobStatus | Gets or sets the job status.
Public property | PersistencePath | Gets or sets the job persistence path.
Public property | SourceActivationStatus | Gets or sets the source activation status.
Public property | SourceNetworkId | Gets or sets the source network ID (usually host name).
Public property | SourceUniqueId | Gets or sets the source unique ID (aka hardware ID).
Public property | TargetNetworkId | Gets or sets the target network ID (usually host name).
Public property | TargetUniqueId | Gets or sets the target unique ID (aka hardware ID).
Public property | Timestamp | Gets or sets the time when the data was collected.
Top
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.IsInitialData Property

JobUsageDataModelIsInitialData Property

Gets or sets a value indicating whether the initial data was recorded when the job was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsInitialData { get; set; }
Public Property IsInitialData As Boolean
    Get
    Set
public:
property bool IsInitialData {
    bool get ();
    void set (bool value);
}
member IsInitialData : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionId Property

JobUsageDataModelJobOrConnectionId Property

Gets or sets the job or connection ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid JobOrConnectionId { get; set; }
Public Property JobOrConnectionId As Guid
    Get
    Set
public:
property Guid JobOrConnectionId {
    Guid get ();
    void set (Guid value);
}
member JobOrConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionName Property

JobUsageDataModelJobOrConnectionName Property

Gets or sets the job or connection name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobOrConnectionName { get; set; }
Public Property JobOrConnectionName As String
    Get
    Set
public:
property String^ JobOrConnectionName {
    String^ get ();
    void set (String^ value);
}
member JobOrConnectionName : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionType Property

JobUsageDataModelJobOrConnectionType Property

Gets or sets the job or connection type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobOrConnectionType { get; set; }
Public Property JobOrConnectionType As String
    Get
    Set
public:
property String^ JobOrConnectionType {
    String^ get ();
    void set (String^ value);
}
member JobOrConnectionType : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobStatus Property

JobUsageDataModelJobStatus Property

Gets or sets the job status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtmuJobStatusEnum JobStatus { get; set; }
Public Property JobStatus As DtmuJobStatusEnum
    Get
    Set
public:
property DtmuJobStatusEnum JobStatus {
    DtmuJobStatusEnum get ();
    void set (DtmuJobStatusEnum value);
}
member JobStatus : DtmuJobStatusEnum with get, set

Property Value

Type: DtmuJobStatusEnum
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.PersistencePath Property

JobUsageDataModelPersistencePath Property

Gets or sets the job persistence path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string PersistencePath { get; set; }
Public Property PersistencePath As String
    Get
    Set
public:
property String^ PersistencePath {
    String^ get ();
    void set (String^ value);
}
member PersistencePath : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceActivationStatus Property

JobUsageDataModelSourceActivationStatus Property

Gets or sets the source activation status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DtmuActivationStatusModel SourceActivationStatus { get; set; }
Public Property SourceActivationStatus As DtmuActivationStatusModel
    Get
    Set
public:
property DtmuActivationStatusModel^ SourceActivationStatus {
    DtmuActivationStatusModel^ get ();
    void set (DtmuActivationStatusModel^ value);
}
member SourceActivationStatus : DtmuActivationStatusModel with get, set

Property Value

Type: DtmuActivationStatusModel
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceNetworkId Property

JobUsageDataModelSourceNetworkId Property

Gets or sets the source network ID (usually host name).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
member SourceNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceUniqueId Property

JobUsageDataModelSourceUniqueId Property

Gets or sets the source unique ID (aka hardware ID).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid SourceUniqueId { get; set; }
Public Property SourceUniqueId As Guid
    Get
    Set
public:
property Guid SourceUniqueId {
    Guid get ();
    void set (Guid value);
}
member SourceUniqueId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.TargetNetworkId Property

JobUsageDataModelTargetNetworkId Property

Gets or sets the target network ID (usually host name).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetNetworkId { get; set; }
Public Property TargetNetworkId As String
    Get
    Set
public:
property String^ TargetNetworkId {
    String^ get ();
    void set (String^ value);
}
member TargetNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.TargetUniqueId Property

JobUsageDataModelTargetUniqueId Property

Gets or sets the target unique ID (aka hardware ID).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid TargetUniqueId { get; set; }
Public Property TargetUniqueId As Guid
    Get
    Set
public:
property Guid TargetUniqueId {
    Guid get ();
    void set (Guid value);
}
member TargetUniqueId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.Timestamp Property

JobUsageDataModelTimestamp Property

Gets or sets the time when the data was collected.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel Methods

The JobUsageDataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobUsageDataModel Class


LinuxJobPersistedStateModel Class

Linux job persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobPersistedStateModel
Public NotInheritable Class LinuxJobPersistedStateModel
public ref class LinuxJobPersistedStateModel sealed
[<SealedAttribute>]
type LinuxJobPersistedStateModel =  class end

The LinuxJobPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobPersistedStateModel | Initializes a new instance of the LinuxJobPersistedStateModel class
Top
Properties
 | Name | Description
Public property | CurrentJobStateFlagStack | Gets or sets the current job state flag stack.
Public property | DeserializedJobStateFlagStack | Gets or sets the deserialized job state flag stack.
Public property | PreviousJobStateFlagStack | Gets or sets the previous job state flag stack.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobPersistedStateModel Constructor

Initializes a new instance of the LinuxJobPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobPersistedStateModel()
Public Sub New
public:
LinuxJobPersistedStateModel()
new : unit -> LinuxJobPersistedStateModel
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel Properties

The LinuxJobPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | CurrentJobStateFlagStack | Gets or sets the current job state flag stack.
Public property | DeserializedJobStateFlagStack | Gets or sets the deserialized job state flag stack.
Public property | PreviousJobStateFlagStack | Gets or sets the previous job state flag stack.
Top
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.CurrentJobStateFlagStack Property

LinuxJobPersistedStateModelCurrentJobStateFlagStack Property

Gets or sets the current job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel CurrentJobStateFlagStack { get; set; }
Public Property CurrentJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ CurrentJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member CurrentJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The current job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.DeserializedJobStateFlagStack Property

LinuxJobPersistedStateModelDeserializedJobStateFlagStack Property

Gets or sets the deserialized job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel DeserializedJobStateFlagStack { get; set; }
Public Property DeserializedJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ DeserializedJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member DeserializedJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The deserialized job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.PreviousJobStateFlagStack Property

LinuxJobPersistedStateModelPreviousJobStateFlagStack Property

Gets or sets the previous job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel PreviousJobStateFlagStack { get; set; }
Public Property PreviousJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ PreviousJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member PreviousJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The previous job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel Methods

The LinuxJobPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobStateFlagModel Class

String representation of a JobStateFlag, defined privately by the Linux job implementation
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagModel
Public NotInheritable Class LinuxJobStateFlagModel
public ref class LinuxJobStateFlagModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagModel =  class end

The LinuxJobStateFlagModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagModel | Initializes a new instance of the LinuxJobStateFlagModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagModel Constructor

Initializes a new instance of the LinuxJobStateFlagModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagModel()
Public Sub New
public:
LinuxJobStateFlagModel()
new : unit -> LinuxJobStateFlagModel
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel Properties

The LinuxJobStateFlagModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel.Name Property

LinuxJobStateFlagModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel Methods

The LinuxJobStateFlagModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagStackLevelModel Class

Linux job state flag stack level.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagStackLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagStackLevelModel
Public NotInheritable Class LinuxJobStateFlagStackLevelModel
public ref class LinuxJobStateFlagStackLevelModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagStackLevelModel =  class end

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStackLevelModel | Initializes a new instance of the LinuxJobStateFlagStackLevelModel class
Top
Properties
 | Name | Description
Public property | JobStateFlags | Gets or sets the job state flags.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagStackLevelModel Constructor

Initializes a new instance of the LinuxJobStateFlagStackLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackLevelModel()
Public Sub New
public:
LinuxJobStateFlagStackLevelModel()
new : unit -> LinuxJobStateFlagStackLevelModel
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel Properties

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlags | Gets or sets the job state flags.
Top
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel.JobStateFlags Property

LinuxJobStateFlagStackLevelModelJobStateFlags Property

Gets or sets the job state flags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagModel[] JobStateFlags { get; set; }
Public Property JobStateFlags As LinuxJobStateFlagModel()
    Get
    Set
public:
property array<LinuxJobStateFlagModel^>^ JobStateFlags {
    array<LinuxJobStateFlagModel^>^ get ();
    void set (array<LinuxJobStateFlagModel^>^ value);
}
member JobStateFlags : LinuxJobStateFlagModel[] with get, set

Property Value

Type: LinuxJobStateFlagModel
The job state flags.
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel Methods

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackModel Class

A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagStackModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagStackModel
Public NotInheritable Class LinuxJobStateFlagStackModel
public ref class LinuxJobStateFlagStackModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagStackModel =  class end

The LinuxJobStateFlagStackModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStackModel | Initializes a new instance of the LinuxJobStateFlagStackModel class
Top
Properties
 | Name | Description
Public property | JobStateFlagStackLevels | Gets or sets the job state flag stack levels.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagStackModel Constructor

Initializes a new instance of the LinuxJobStateFlagStackModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel()
Public Sub New
public:
LinuxJobStateFlagStackModel()
new : unit -> LinuxJobStateFlagStackModel
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel Properties

The LinuxJobStateFlagStackModel type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlagStackLevels | Gets or sets the job state flag stack levels.
Top
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel.JobStateFlagStackLevels Property

LinuxJobStateFlagStackModelJobStateFlagStackLevels Property

Gets or sets the job state flag stack levels.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackLevelModel[] JobStateFlagStackLevels { get; set; }
Public Property JobStateFlagStackLevels As LinuxJobStateFlagStackLevelModel()
    Get
    Set
public:
property array<LinuxJobStateFlagStackLevelModel^>^ JobStateFlagStackLevels {
    array<LinuxJobStateFlagStackLevelModel^>^ get ();
    void set (array<LinuxJobStateFlagStackLevelModel^>^ value);
}
member JobStateFlagStackLevels : LinuxJobStateFlagStackLevelModel[] with get, set

Property Value

Type: LinuxJobStateFlagStackLevelModel
The job state flag stack levels.
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel Methods

The LinuxJobStateFlagStackModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagStackModel Class


LogActionInputModel Class

Represents the input to a log action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsLogActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class LogActionInputModel : ActionInputModel
Public Class LogActionInputModel
    Inherits ActionInputModel
public ref class LogActionInputModel : public ActionInputModel
type LogActionInputModel =
    class
        inherit ActionInputModel
    end

The LogActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogActionInputModel | Initializes a new instance of the LogActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | EventType | Gets or sets the type of the event.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogActionInputModel Constructor

Initializes a new instance of the LogActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public LogActionInputModel()
Public Sub New
public:
LogActionInputModel()
new : unit -> LogActionInputModel
See Also

Reference

LogActionInputModel Class


LogActionInputModel Properties

The LogActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | EventType | Gets or sets the type of the event.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
See Also

Reference

LogActionInputModel Class


LogActionInputModel.EventType Property

LogActionInputModelEventType Property

Gets or sets the type of the event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TraceEventType EventType { get; set; }
Public Property EventType As TraceEventType
    Get
    Set
public:
property TraceEventType EventType {
    TraceEventType get ();
    void set (TraceEventType value);
}
member EventType : TraceEventType with get, set

Property Value

Type: TraceEventType
The type of the event.
See Also

Reference

LogActionInputModel Class


LogActionInputModel.Message Property

LogActionInputModelMessage Property

Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

LogActionInputModel Class


LogActionInputModel.MessageFormatParameters Property

LogActionInputModelMessageFormatParameters Property

Gets or sets the message format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
The message format parameters.
See Also

Reference

LogActionInputModel Class


LogActionInputModel Methods

The LogActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogActionInputModel Class


ModifyReplicationSetRulesRequestModel Class

Modify replication set rules request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsModifyReplicationSetRulesRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ModifyReplicationSetRulesRequestModel
Public NotInheritable Class ModifyReplicationSetRulesRequestModel
public ref class ModifyReplicationSetRulesRequestModel sealed
[<SealedAttribute>]
type ModifyReplicationSetRulesRequestModel =  class end

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | ModifyReplicationSetRulesRequestModel | Initializes a new instance of the ModifyReplicationSetRulesRequestModel class
Top
Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ModifyReplicationSetRulesRequestModel Constructor

Initializes a new instance of the ModifyReplicationSetRulesRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ModifyReplicationSetRulesRequestModel()
Public Sub New
public:
ModifyReplicationSetRulesRequestModel()
new : unit -> ModifyReplicationSetRulesRequestModel
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel Properties

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel.PhysicalRules Property

ModifyReplicationSetRulesRequestModelPhysicalRules Property

Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel Methods

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


MonitorableAddressInfoModel Class

Used to specify a monitorable IP address that can be used to configure a failover monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorableAddressInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorableAddressInfoModel
Public Class MonitorableAddressInfoModel
public ref class MonitorableAddressInfoModel
type MonitorableAddressInfoModel =  class end

The MonitorableAddressInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorableAddressInfoModel | Initializes a new instance of the MonitorableAddressInfoModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | InterfaceMacAddress | Gets or sets the MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | Gets or sets a list of GUIDs specifying target NICs that can monitor this address.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorableAddressInfoModel Constructor

Initializes a new instance of the MonitorableAddressInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorableAddressInfoModel()
Public Sub New
public:
MonitorableAddressInfoModel()
new : unit -> MonitorableAddressInfoModel
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel Properties

The MonitorableAddressInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | InterfaceMacAddress | Gets or sets the MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | Gets or sets a list of GUIDs specifying target NICs that can monitor this address.
Top
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.Address Property

MonitorableAddressInfoModelAddress Property

Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel Address { get; set; }
Public Property Address As UnicastIPAddressModel
    Get
    Set
public:
property UnicastIPAddressModel^ Address {
    UnicastIPAddressModel^ get ();
    void set (UnicastIPAddressModel^ value);
}
member Address : UnicastIPAddressModel with get, set

Property Value

Type: UnicastIPAddressModel
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.InterfaceMacAddress Property

MonitorableAddressInfoModelInterfaceMacAddress Property

Gets or sets the MAC address of the NIC on which this address resides.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string InterfaceMacAddress { get; set; }
Public Property InterfaceMacAddress As String
    Get
    Set
public:
property String^ InterfaceMacAddress {
    String^ get ();
    void set (String^ value);
}
member InterfaceMacAddress : string with get, set

Property Value

Type: String
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.TargetInterfaceGuids Property

MonitorableAddressInfoModelTargetInterfaceGuids Property

Gets or sets a list of GUIDs specifying target NICs that can monitor this address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] TargetInterfaceGuids { get; set; }
Public Property TargetInterfaceGuids As String()
    Get
    Set
public:
property array<String^>^ TargetInterfaceGuids {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TargetInterfaceGuids : string[] with get, set

Property Value

Type: String
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel Methods

The MonitorableAddressInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorableAddressInfoModel Class


MonitorActionFlatModel Class

Represents an action that is run in the context of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorActionFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorActionFlatModel
Public Class MonitorActionFlatModel
public ref class MonitorActionFlatModel
type MonitorActionFlatModel =  class end

The MonitorActionFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorActionFlatModel | Initializes a new instance of the MonitorActionFlatModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorActionFlatModel Constructor

Initializes a new instance of the MonitorActionFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorActionFlatModel()
Public Sub New
public:
MonitorActionFlatModel()
new : unit -> MonitorActionFlatModel
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel Properties

The MonitorActionFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Input Property

MonitorActionFlatModelInput Property

Gets or sets the input arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionInputFlatModel Input { get; set; }
Public Property Input As ActionInputFlatModel
    Get
    Set
public:
property ActionInputFlatModel^ Input {
    ActionInputFlatModel^ get ();
    void set (ActionInputFlatModel^ value);
}
member Input : ActionInputFlatModel with get, set

Property Value

Type: ActionInputFlatModel
The input arguments.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Name Property

MonitorActionFlatModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.RemoteServerCredentials Property

MonitorActionFlatModelRemoteServerCredentials Property

Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.RemoteServerUri Property

MonitorActionFlatModelRemoteServerUri Property

Gets or sets the remote server on which to run this action. Set this to to run the action locally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Timeout Property

MonitorActionFlatModelTimeout Property

Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.UniqueId Property

MonitorActionFlatModelUniqueId Property

Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel Methods

The MonitorActionFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorActionFlatModel Class


MonitorActionModel Class

Represents an action that is run in the context of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorActionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorActionModel
Public Class MonitorActionModel
public ref class MonitorActionModel
type MonitorActionModel =  class end

The MonitorActionModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorActionModel | Initializes a new instance of the MonitorActionModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorActionModel Constructor

Initializes a new instance of the MonitorActionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorActionModel()
Public Sub New
public:
MonitorActionModel()
new : unit -> MonitorActionModel
See Also

Reference

MonitorActionModel Class


MonitorActionModel Properties

The MonitorActionModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Input Property

MonitorActionModelInput Property

Gets or sets the input arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ActionInputModel Input { get; set; }
Public Property Input As ActionInputModel
    Get
    Set
public:
property ActionInputModel^ Input {
    ActionInputModel^ get ();
    void set (ActionInputModel^ value);
}
member Input : ActionInputModel with get, set

Property Value

Type: ActionInputModel
The input arguments.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Name Property

MonitorActionModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.RemoteServerCredentials Property

MonitorActionModelRemoteServerCredentials Property

Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.RemoteServerUri Property

MonitorActionModelRemoteServerUri Property

Gets or sets the remote server on which to run this action. Set this to to run the action locally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Timeout Property

MonitorActionModelTimeout Property

Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.UniqueId Property

MonitorActionModelUniqueId Property

Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorActionModel Class


MonitorActionModel Methods

The MonitorActionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorActionModel Class


MonitorInfoModel Class

Monitor information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorInfoModel
Public Class MonitorInfoModel
public ref class MonitorInfoModel
type MonitorInfoModel =  class end

The MonitorInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorInfoModel | Initializes a new instance of the MonitorInfoModel class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorInfoModel Constructor

Initializes a new instance of the MonitorInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorInfoModel()
Public Sub New
public:
MonitorInfoModel()
new : unit -> MonitorInfoModel
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel Properties

The MonitorInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Configuration Property

MonitorInfoModelConfiguration Property

Gets or sets the MonitorConfiguration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel Configuration { get; set; }
Public Property Configuration As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ Configuration {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member Configuration : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
The MonitorConfiguration.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Guid Property

MonitorInfoModelGuid Property

Gets or sets the unique id of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The unique id of the monitor.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Name Property

MonitorInfoModelName Property

Gets or sets the name of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of the monitor.
Remarks
This is typically the host name or IP address of the source machine.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Status Property

MonitorInfoModelStatus Property

Gets or sets the MonitorStatus.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorStatusModel Status { get; set; }
Public Property Status As MonitorStatusModel
    Get
    Set
public:
property MonitorStatusModel^ Status {
    MonitorStatusModel^ get ();
    void set (MonitorStatusModel^ value);
}
member Status : MonitorStatusModel with get, set

Property Value

Type: MonitorStatusModel
The MonitorStatus.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel Methods

The MonitorInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorInfoModel Class


MonitorQualificationResultModel Class

An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQualificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitorQualificationResultModel
Public NotInheritable Class MonitorQualificationResultModel
public ref class MonitorQualificationResultModel sealed
[<SealedAttribute>]
type MonitorQualificationResultModel =  class end

The MonitorQualificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQualificationResultModel | Initializes a new instance of the MonitorQualificationResultModel class
Top
Properties
 | Name | Description
Public property | DefaultMonitor | Gets or sets a pre-populated monitor with default values for the configuration properties.
Public property | IsQualified | Gets or sets a value indicating whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | Gets or sets a list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Gets or sets information about all the network interfaces on the target machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQualificationResultModel Constructor

Initializes a new instance of the MonitorQualificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorQualificationResultModel()
Public Sub New
public:
MonitorQualificationResultModel()
new : unit -> MonitorQualificationResultModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel Properties

The MonitorQualificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | DefaultMonitor | Gets or sets a pre-populated monitor with default values for the configuration properties.
Public property | IsQualified | Gets or sets a value indicating whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | Gets or sets a list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Gets or sets information about all the network interfaces on the target machine.
Top
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.DefaultMonitor Property

MonitorQualificationResultModelDefaultMonitor Property

Gets or sets a pre-populated monitor with default values for the configuration properties.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel DefaultMonitor { get; set; }
Public Property DefaultMonitor As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ DefaultMonitor {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member DefaultMonitor : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.IsQualified Property

MonitorQualificationResultModelIsQualified Property

Gets or sets a value indicating whether or not the machine in question can be monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
member IsQualified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.MonitorableAddresses Property

MonitorQualificationResultModelMonitorableAddresses Property

Gets or sets a list of monitorable addresses from the target's point of view.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorableAddressInfoModel[] MonitorableAddresses { get; set; }
Public Property MonitorableAddresses As MonitorableAddressInfoModel()
    Get
    Set
public:
property array<MonitorableAddressInfoModel^>^ MonitorableAddresses {
    array<MonitorableAddressInfoModel^>^ get ();
    void set (array<MonitorableAddressInfoModel^>^ value);
}
member MonitorableAddresses : MonitorableAddressInfoModel[] with get, set

Property Value

Type: MonitorableAddressInfoModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.SourceMachineName Property

MonitorQualificationResultModelSourceMachineName Property

Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.TargetInterfaces Property

MonitorQualificationResultModelTargetInterfaces Property

Gets or sets information about all the network interfaces on the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] TargetInterfaces { get; set; }
Public Property TargetInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ TargetInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member TargetInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel Methods

The MonitorQualificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQualificationResultModel Class


MonitorQueryFlatModel Class

Monitor query flat.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQueryFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorQueryFlatModel
Public Class MonitorQueryFlatModel
public ref class MonitorQueryFlatModel
type MonitorQueryFlatModel =  class end

The MonitorQueryFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQueryFlatModel | Initializes a new instance of the MonitorQueryFlatModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQueryFlatModel Constructor

Initializes a new instance of the MonitorQueryFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryFlatModel()
Public Sub New
public:
MonitorQueryFlatModel()
new : unit -> MonitorQueryFlatModel
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel Properties

The MonitorQueryFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Input Property

MonitorQueryFlatModelInput Property

Gets or sets the input.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryInputFlatModel Input { get; set; }
Public Property Input As QueryInputFlatModel
    Get
    Set
public:
property QueryInputFlatModel^ Input {
    QueryInputFlatModel^ get ();
    void set (QueryInputFlatModel^ value);
}
member Input : QueryInputFlatModel with get, set

Property Value

Type: QueryInputFlatModel
The input.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Name Property

MonitorQueryFlatModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.RemoteServerCredentials Property

MonitorQueryFlatModelRemoteServerCredentials Property

Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.RemoteServerUri Property

MonitorQueryFlatModelRemoteServerUri Property

Gets or sets the remote server URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server URI.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Timeout Property

MonitorQueryFlatModelTimeout Property

Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.UniqueId Property

MonitorQueryFlatModelUniqueId Property

Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel Methods

The MonitorQueryFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryModel Class

This class is part of the MonitorActivity class which contains both query and action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQueryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorQueryModel
Public Class MonitorQueryModel
public ref class MonitorQueryModel
type MonitorQueryModel =  class end

The MonitorQueryModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQueryModel | Initializes a new instance of the MonitorQueryModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQueryModel Constructor

Initializes a new instance of the MonitorQueryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryModel()
Public Sub New
public:
MonitorQueryModel()
new : unit -> MonitorQueryModel
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel Properties

The MonitorQueryModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Input Property

MonitorQueryModelInput Property

Gets or sets the input.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryInputModel Input { get; set; }
Public Property Input As QueryInputModel
    Get
    Set
public:
property QueryInputModel^ Input {
    QueryInputModel^ get ();
    void set (QueryInputModel^ value);
}
member Input : QueryInputModel with get, set

Property Value

Type: QueryInputModel
The input.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Name Property

MonitorQueryModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.RemoteServerCredentials Property

MonitorQueryModelRemoteServerCredentials Property

Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.RemoteServerUri Property

MonitorQueryModelRemoteServerUri Property

Gets or sets the remote server URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server URI.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Timeout Property

MonitorQueryModelTimeout Property

Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.UniqueId Property

MonitorQueryModelUniqueId Property

Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel Methods

The MonitorQueryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQueryModel Class


MonitorResultEnum Enumeration

Monitor result

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum MonitorResultEnum
Public Enumeration MonitorResultEnum
public enum class MonitorResultEnum
type MonitorResultEnum
Members
Member name | Value | Description
Success | 0 | The success
Failure | 1 | The failure
Indeterminate | 2 | The indeterminate
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorStatusModel Class

Monitor status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MonitorStatusModel
Public Class MonitorStatusModel
public ref class MonitorStatusModel
type MonitorStatusModel =  class end

The MonitorStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorStatusModel | Initializes a new instance of the MonitorStatusModel class
Top
Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorStatusModel Constructor

Initializes a new instance of the MonitorStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorStatusModel()
Public Sub New
public:
MonitorStatusModel()
new : unit -> MonitorStatusModel
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel Properties

The MonitorStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Addresses Property

MonitorStatusModelAddresses Property

Gets or sets the addresses that are being monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressStatusModel()
    Get
    Set
public:
property array<MonitoredAddressStatusModel^>^ Addresses {
    array<MonitoredAddressStatusModel^>^ get ();
    void set (array<MonitoredAddressStatusModel^>^ value);
}
member Addresses : MonitoredAddressStatusModel[] with get, set

Property Value

Type: MonitoredAddressStatusModel
The addresses.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Name Property

MonitorStatusModelName Property

Gets or sets the name of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of the monitor.
Remarks
The name of the monitor is usually the
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.RestoreStates Property

MonitorStatusModelRestoreStates Property

Gets or sets the RestoreStates.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
member RestoreStates : RestoreStates with get, set

Property Value

Type: RestoreStates
The RestoreStates.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Status Property

MonitorStatusModelStatus Property

Gets or sets the HighAvailabilityState.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public HighAvailabilityState Status { get; set; }
Public Property Status As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState Status {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
member Status : HighAvailabilityState with get, set

Property Value

Type: HighAvailabilityState
The HighAvailabilityState.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel Methods

The MonitorStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorStatusModel Class


MultiStringSettingModel Class

Multi-string setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsMultiStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class MultiStringSettingModel : NamedSettingModel
Public Class MultiStringSettingModel
    Inherits NamedSettingModel
public ref class MultiStringSettingModel : public NamedSettingModel
type MultiStringSettingModel =
    class
        inherit NamedSettingModel
    end

The MultiStringSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | MultiStringSettingModel | Initializes a new instance of the MultiStringSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MultiStringSettingModel Constructor

Initializes a new instance of the MultiStringSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MultiStringSettingModel()
Public Sub New
public:
MultiStringSettingModel()
new : unit -> MultiStringSettingModel
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel Properties

The MultiStringSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel.Value Property

MultiStringSettingModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] Value { get; set; }
Public Property Value As String()
    Get
    Set
public:
property array<String^>^ Value {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Value : string[] with get, set

Property Value

Type: String
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel Methods

The MultiStringSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultiStringSettingModel Class


NamedSettingModel Class

Named setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsBooleanSettingModel
DoubleTake.Web.ModelsIntegerSettingModel
DoubleTake.Web.ModelsMultiStringSettingModel
DoubleTake.Web.ModelsStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class NamedSettingModel
Public Class NamedSettingModel
public ref class NamedSettingModel
type NamedSettingModel =  class end

The NamedSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | NamedSettingModel | Initializes a new instance of the NamedSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeName | Gets or sets the type name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NamedSettingModel Constructor

Initializes a new instance of the NamedSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public NamedSettingModel()
Public Sub New
public:
NamedSettingModel()
new : unit -> NamedSettingModel
See Also

Reference

NamedSettingModel Class


NamedSettingModel Properties

The NamedSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeName | Gets or sets the type name.
Top
See Also

Reference

NamedSettingModel Class


NamedSettingModel.Name Property

NamedSettingModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NamedSettingModel Class


NamedSettingModel.TypeName Property

NamedSettingModelTypeName Property

Gets or sets the type name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
member TypeName : string with get, set

Property Value

Type: String
See Also

Reference

NamedSettingModel Class


NamedSettingModel Methods

The NamedSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NamedSettingModel Class


NicMappingsModel Class

NIC mapping.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNicMappingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class NicMappingsModel
Public Class NicMappingsModel
public ref class NicMappingsModel
type NicMappingsModel =  class end

The NicMappingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | NicMappingsModel | Initializes a new instance of the NicMappingsModel class
Top
Properties
 | Name | Description
Public property | FullServerNicMappings | Gets or sets the full server nic mappings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NicMappingsModel Constructor

Initializes a new instance of the NicMappingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public NicMappingsModel()
Public Sub New
public:
NicMappingsModel()
new : unit -> NicMappingsModel
See Also

Reference

NicMappingsModel Class


NicMappingsModel Properties

The NicMappingsModel type exposes the following members.

Properties
 | Name | Description
Public property | FullServerNicMappings | Gets or sets the full server nic mappings.
Top
See Also

Reference

NicMappingsModel Class


NicMappingsModel.FullServerNicMappings Property

NicMappingsModelFullServerNicMappings Property

Gets or sets the full server nic mappings.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel[] FullServerNicMappings { get; set; }
Public Property FullServerNicMappings As FullServerNicMappingsModel()
    Get
    Set
public:
property array<FullServerNicMappingsModel^>^ FullServerNicMappings {
    array<FullServerNicMappingsModel^>^ get ();
    void set (array<FullServerNicMappingsModel^>^ value);
}
member FullServerNicMappings : FullServerNicMappingsModel[] with get, set

Property Value

Type: FullServerNicMappingsModel
The full server nic mappings.
See Also

Reference

NicMappingsModel Class


NicMappingsModel Methods

The NicMappingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NicMappingsModel Class


OptionRequestModel Class

Options request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionRequestModel
Public NotInheritable Class OptionRequestModel
public ref class OptionRequestModel sealed
[<SealedAttribute>]
type OptionRequestModel =  class end

The OptionRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionRequestModel | Initializes a new instance of the OptionRequestModel class
Top
Properties
 | Name | Description
Public property | Options | Gets or sets the options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionRequestModel Constructor

Initializes a new instance of the OptionRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public OptionRequestModel()
Public Sub New
public:
OptionRequestModel()
new : unit -> OptionRequestModel
See Also

Reference

OptionRequestModel Class


OptionRequestModel Properties

The OptionRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets or sets the options.
Top
See Also

Reference

OptionRequestModel Class


OptionRequestModel.Options Property

OptionRequestModelOptions Property

Gets or sets the options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public OptionModel[] Options { get; set; }
Public Property Options As OptionModel()
    Get
    Set
public:
property array<OptionModel^>^ Options {
    array<OptionModel^>^ get ();
    void set (array<OptionModel^>^ value);
}
member Options : OptionModel[] with get, set

Property Value

Type: OptionModel
The options.
See Also

Reference

OptionRequestModel Class


OptionRequestModel Methods

The OptionRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionRequestModel Class


OptionValueModel Class

Options value.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionValueModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionValueModel
Public NotInheritable Class OptionValueModel
public ref class OptionValueModel sealed
[<SealedAttribute>]
type OptionValueModel =  class end

The OptionValueModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionValueModel | Initializes a new instance of the OptionValueModel class
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionValueModel Constructor

Initializes a new instance of the OptionValueModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public OptionValueModel()
Public Sub New
public:
OptionValueModel()
new : unit -> OptionValueModel
See Also

Reference

OptionValueModel Class


OptionValueModel Properties

The OptionValueModel type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
See Also

Reference

OptionValueModel Class


OptionValueModel.Value Property

OptionValueModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
The value.
See Also

Reference

OptionValueModel Class


OptionValueModel Methods

The OptionValueModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionValueModel Class


PathBlockingEntryModel Class

A path blocking entry.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPathBlockingEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class PathBlockingEntryModel
Public Class PathBlockingEntryModel
public ref class PathBlockingEntryModel
type PathBlockingEntryModel =  class end

The PathBlockingEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | PathBlockingEntryModel | Initializes a new instance of the PathBlockingEntryModel class
Top
Properties
 | Name | Description
Public property | BlockingMode | Gets or sets the blocking mode.
Public property | Paths | Gets or sets the paths that are blocked.
Public property | SourceAddress | Gets or sets the source address corresponding to the connection having blocked paths.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PathBlockingEntryModel Constructor

Initializes a new instance of the PathBlockingEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathBlockingEntryModel()
Public Sub New
public:
PathBlockingEntryModel()
new : unit -> PathBlockingEntryModel
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel Properties

The PathBlockingEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | BlockingMode | Gets or sets the blocking mode.
Public property | Paths | Gets or sets the paths that are blocked.
Public property | SourceAddress | Gets or sets the source address corresponding to the connection having blocked paths.
Top
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.BlockingMode Property

PathBlockingEntryModelBlockingMode Property

Gets or sets the blocking mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathBlockingModeEnum BlockingMode { get; set; }
Public Property BlockingMode As PathBlockingModeEnum
    Get
    Set
public:
property PathBlockingModeEnum BlockingMode {
    PathBlockingModeEnum get ();
    void set (PathBlockingModeEnum value);
}
member BlockingMode : PathBlockingModeEnum with get, set

Property Value

Type: PathBlockingModeEnum
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.Paths Property

PathBlockingEntryModelPaths Property

Gets or sets the paths that are blocked.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.SourceAddress Property

PathBlockingEntryModelSourceAddress Property

Gets or sets the source address corresponding to the connection having blocked paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
member SourceAddress : string with get, set

Property Value

Type: String
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel Methods

The PathBlockingEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathBlockingEntryModel Class


PathBlockingModeEnum Enumeration

This value represents if the path is blocked.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum PathBlockingModeEnum
Public Enumeration PathBlockingModeEnum
public enum class PathBlockingModeEnum
type PathBlockingModeEnum
Members
Member name | Value | Description
Blocked | 0 | The path is blocked for writing, except by Double-Take.
Unblocked | 1 | The path is unblocked for writing.
See Also

Reference

DoubleTake.Web.Models Namespace


PerformanceCounterQueryInputModel Class

Represents the input to a performance counter query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsPerformanceCounterQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceCounterQueryInputModel : QueryInputModel
Public Class PerformanceCounterQueryInputModel
    Inherits QueryInputModel
public ref class PerformanceCounterQueryInputModel : public QueryInputModel
type PerformanceCounterQueryInputModel =
    class
        inherit QueryInputModel
    end

The PerformanceCounterQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryInputModel | Initializes a new instance of the PerformanceCounterQueryInputModel class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Criteria | Gets or sets the criteria.
Public property | Instance | Gets or sets the instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PerformanceCounterQueryInputModel Constructor

Initializes a new instance of the PerformanceCounterQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PerformanceCounterQueryInputModel()
Public Sub New
public:
PerformanceCounterQueryInputModel()
new : unit -> PerformanceCounterQueryInputModel
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel Properties

The PerformanceCounterQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Criteria | Gets or sets the criteria.
Public property | Instance | Gets or sets the instance.
Top
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Category Property

PerformanceCounterQueryInputModelCategory Property

Gets or sets the category.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
The category.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.ComparisonOperation Property

PerformanceCounterQueryInputModelComparisonOperation Property

Gets or sets the comparison operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ComparisonOperationEnum ComparisonOperation { get; set; }
Public Property ComparisonOperation As ComparisonOperationEnum
    Get
    Set
public:
property ComparisonOperationEnum ComparisonOperation {
    ComparisonOperationEnum get ();
    void set (ComparisonOperationEnum value);
}
member ComparisonOperation : ComparisonOperationEnum with get, set

Property Value

Type: ComparisonOperationEnum
The comparison operation.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Counter Property

PerformanceCounterQueryInputModelCounter Property

Gets or sets the counter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Counter { get; set; }
Public Property Counter As String
    Get
    Set
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}
member Counter : string with get, set

Property Value

Type: String
The counter.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Criteria Property

PerformanceCounterQueryInputModelCriteria Property

Gets or sets the criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public float Criteria { get; set; }
Public Property Criteria As Single
    Get
    Set
public:
property float Criteria {
    float get ();
    void set (float value);
}
member Criteria : float32 with get, set

Property Value

Type: Single
The criteria.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Instance Property

PerformanceCounterQueryInputModelInstance Property

Gets or sets the instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}
member Instance : string with get, set

Property Value

Type: String
The instance.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel Methods

The PerformanceCounterQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryResultModel Class

Represents the results of a Performance Counter Query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsPerformanceCounterQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceCounterQueryResultModel : QueryResultModel
Public Class PerformanceCounterQueryResultModel
    Inherits QueryResultModel
public ref class PerformanceCounterQueryResultModel : public QueryResultModel
type PerformanceCounterQueryResultModel =
    class
        inherit QueryResultModel
    end

The PerformanceCounterQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryResultModel | Initializes a new instance of the PerformanceCounterQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


PerformanceCounterQueryResultModel Constructor

Initializes a new instance of the PerformanceCounterQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PerformanceCounterQueryResultModel()
Public Sub New
public:
PerformanceCounterQueryResultModel()
new : unit -> PerformanceCounterQueryResultModel
See Also

Reference

PerformanceCounterQueryResultModel Class


PerformanceCounterQueryResultModel Properties

The PerformanceCounterQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

PerformanceCounterQueryResultModel Class


PerformanceCounterQueryResultModel Methods

The PerformanceCounterQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PerformanceCounterQueryResultModel Class


PhysicalRulesModel Class

Physical rules model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPhysicalRulesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class PhysicalRulesModel
Public Class PhysicalRulesModel
public ref class PhysicalRulesModel
type PhysicalRulesModel =  class end

The PhysicalRulesModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRulesModel | Initializes a new instance of the PhysicalRulesModel class
Top
Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalRulesModel Constructor

Initializes a new instance of the PhysicalRulesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRulesModel()
Public Sub New
public:
PhysicalRulesModel()
new : unit -> PhysicalRulesModel
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel Properties

The PhysicalRulesModel type exposes the following members.

Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel.PhysicalRules Property

PhysicalRulesModelPhysicalRules Property

Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel Methods

The PhysicalRulesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalRulesModel Class


PITSnapshotRecordModel Class

PIT snapshot record.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPITSnapshotRecordModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class PITSnapshotRecordModel
Public NotInheritable Class PITSnapshotRecordModel
public ref class PITSnapshotRecordModel sealed
[<SealedAttribute>]
type PITSnapshotRecordModel =  class end

The PITSnapshotRecordModel type exposes the following members.

Constructors
 | Name | Description
Public method | PITSnapshotRecordModel | Initializes a new instance of the PITSnapshotRecordModel class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PITSnapshotRecordModel Constructor

Initializes a new instance of the PITSnapshotRecordModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PITSnapshotRecordModel()
Public Sub New
public:
PITSnapshotRecordModel()
new : unit -> PITSnapshotRecordModel
See Also

Reference

PITSnapshotRecordModel Class


PITSnapshotRecordModel Methods

The PITSnapshotRecordModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PITSnapshotRecordModel Class


PropertyModel Class

Represents an association between a name and another string
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPropertyModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class PropertyModel
Public NotInheritable Class PropertyModel
public ref class PropertyModel sealed
[<SealedAttribute>]
type PropertyModel =  class end

The PropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModel | Initializes a new instance of the PropertyModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PropertyModel Constructor

Initializes a new instance of the PropertyModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PropertyModel()
Public Sub New
public:
PropertyModel()
new : unit -> PropertyModel
See Also

Reference

PropertyModel Class


PropertyModel Properties

The PropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

PropertyModel Class


PropertyModel.Name Property

PropertyModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

PropertyModel Class


PropertyModel.Value Property

PropertyModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

PropertyModel Class


PropertyModel Methods

The PropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyModel Class


QueryInputFlatModel Class

Query input flat.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class QueryInputFlatModel
Public Class QueryInputFlatModel
public ref class QueryInputFlatModel
type QueryInputFlatModel =  class end

The QueryInputFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInputFlatModel | Initializes a new instance of the QueryInputFlatModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Category | Gets or sets the category.
Public property | ClassName | Gets or sets the name of the class.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | Criteria | Gets or sets the criteria.
Public property | EnginePort | Gets or sets the engine port.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | IdJob | Gets or sets the job identifier.
Public property | Instance | Gets or sets the instance.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Public property | JobId | Gets or sets the job identifier.
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | Rules | Gets or sets the rules.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service to monitor.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Target | Gets or sets the target.
Public property | TargetHostName | Gets or sets the name of the target host.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the VM identifier.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueryInputFlatModel Constructor

Initializes a new instance of the QueryInputFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryInputFlatModel()
Public Sub New
public:
QueryInputFlatModel()
new : unit -> QueryInputFlatModel
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel Properties

The QueryInputFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Category | Gets or sets the category.
Public property | ClassName | Gets or sets the name of the class.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | Criteria | Gets or sets the criteria.
Public property | EnginePort | Gets or sets the engine port.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | IdJob | Gets or sets the job identifier.
Public property | Instance | Gets or sets the instance.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Public property | JobId | Gets or sets the job identifier.
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | Rules | Gets or sets the rules.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service to monitor.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Target | Gets or sets the target.
Public property | TargetHostName | Gets or sets the name of the target host.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the VM identifier.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Arguments Property

QueryInputFlatModelArguments Property

Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Category Property

QueryInputFlatModelCategory Property

Gets or sets the category.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
The category.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ClassName Property

QueryInputFlatModelClassName Property

Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The assembly qualified name of the class we are representing.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ComparisonOperation Property

QueryInputFlatModelComparisonOperation Property

Gets or sets the comparison operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ComparisonOperationEnum ComparisonOperation { get; set; }
Public Property ComparisonOperation As ComparisonOperationEnum
    Get
    Set
public:
property ComparisonOperationEnum ComparisonOperation {
    ComparisonOperationEnum get ();
    void set (ComparisonOperationEnum value);
}
member ComparisonOperation : ComparisonOperationEnum with get, set

Property Value

Type: ComparisonOperationEnum
The comparison operation.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Counter Property

QueryInputFlatModelCounter Property

Gets or sets the counter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Counter { get; set; }
Public Property Counter As String
    Get
    Set
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}
member Counter : string with get, set

Property Value

Type: String
The counter.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Credentials Property

QueryInputFlatModelCredentials Property

Gets or sets the credentials to be used by the query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Criteria Property

QueryInputFlatModelCriteria Property

Gets or sets the criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public float Criteria { get; set; }
Public Property Criteria As Single
    Get
    Set
public:
property float Criteria {
    float get ();
    void set (float value);
}
member Criteria : float32 with get, set

Property Value

Type: Single
The criteria.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.EnginePort Property

QueryInputFlatModelEnginePort Property

Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ExternalDataRoot Property

QueryInputFlatModelExternalDataRoot Property

Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.FileName Property

QueryInputFlatModelFileName Property

Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.IdJob Property

QueryInputFlatModelIdJob Property

Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid IdJob { get; set; }
Public Property IdJob As Guid
    Get
    Set
public:
property Guid IdJob {
    Guid get ();
    void set (Guid value);
}
member IdJob : Guid with get, set

Property Value

Type: Guid
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Instance Property

QueryInputFlatModelInstance Property

Gets or sets the instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}
member Instance : string with get, set

Property Value

Type: String
The instance.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.IPAddress Property

QueryInputFlatModelIPAddress Property

Gets or sets the IP address to ping for a heartbeat.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address to ping for a heartbeat.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.JobId Property

QueryInputFlatModelJobId Property

Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string JobId { get; set; }
Public Property JobId As String
    Get
    Set
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
member JobId : string with get, set

Property Value

Type: String
The job identifier.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.NetworkId Property

QueryInputFlatModelNetworkId Property

Gets or sets the server name or IP address to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The server name or IP address to ping.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Operation Property

QueryInputFlatModelOperation Property

Gets or sets the mode of query aggregation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryOperationEnum Operation { get; set; }
Public Property Operation As CompositeQueryOperationEnum
    Get
    Set
public:
property CompositeQueryOperationEnum Operation {
    CompositeQueryOperationEnum get ();
    void set (CompositeQueryOperationEnum value);
}
member Operation : CompositeQueryOperationEnum with get, set

Property Value

Type: CompositeQueryOperationEnum
The mode.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ParallelExecution Property

QueryInputFlatModelParallelExecution Property

Gets or sets a value indicating whether the queries are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the queries are to be executed in parallel; otherwise, .
Remarks
If this property is set to
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Queries Property

QueryInputFlatModelQueries Property

Gets or sets the enumerable collection of queries.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryFlatModel[] Queries { get; set; }
Public Property Queries As MonitorQueryFlatModel()
    Get
    Set
public:
property array<MonitorQueryFlatModel^>^ Queries {
    array<MonitorQueryFlatModel^>^ get ();
    void set (array<MonitorQueryFlatModel^>^ value);
}
member Queries : MonitorQueryFlatModel[] with get, set

Property Value

Type: MonitorQueryFlatModel
The enumerable collection of queries.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ReplicationSetName Property

QueryInputFlatModelReplicationSetName Property

Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ResourceName Property

QueryInputFlatModelResourceName Property

Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; set; }
Public Property ResourceName As String
    Get
    Set
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}
member ResourceName : string with get, set

Property Value

Type: String
The name of the resource.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Rules Property

QueryInputFlatModelRules Property

Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PhysicalRuleModel> Rules { get; set; }
Public Property Rules As IEnumerable(Of PhysicalRuleModel)
    Get
    Set
public:
property IEnumerable<PhysicalRuleModel^>^ Rules {
    IEnumerable<PhysicalRuleModel^>^ get ();
    void set (IEnumerable<PhysicalRuleModel^>^ value);
}
member Rules : IEnumerable<PhysicalRuleModel> with get, set

Property Value

Type: IEnumerable PhysicalRuleModel
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.RunAs Property

QueryInputFlatModelRunAs Property

Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ServiceName Property

QueryInputFlatModelServiceName Property

Gets or sets the name of the service to monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.SnapshotDataRoot Property

QueryInputFlatModelSnapshotDataRoot Property

Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Target Property

QueryInputFlatModelTarget Property

Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri Target { get; set; }
Public Property Target As Uri
    Get
    Set
public:
property Uri^ Target {
    Uri^ get ();
    void set (Uri^ value);
}
member Target : Uri with get, set

Property Value

Type: Uri
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.TargetHostName Property

QueryInputFlatModelTargetHostName Property

Gets or sets the name of the target host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetHostName { get; set; }
Public Property TargetHostName As String
    Get
    Set
public:
property String^ TargetHostName {
    String^ get ();
    void set (String^ value);
}
member TargetHostName : string with get, set

Property Value

Type: String
The name of the target host.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VhdPath Property

QueryInputFlatModelVhdPath Property

Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VirtualSwitchInfoColl Property

QueryInputFlatModelVirtualSwitchInfoColl Property

Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VmId Property

QueryInputFlatModelVmId Property

Gets or sets the VM identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The VM identifier.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WaitForCompletion Property

QueryInputFlatModelWaitForCompletion Property

Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WaitForCompletionTimeout Property

QueryInputFlatModelWaitForCompletionTimeout Property

Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WorkingDirectory Property

QueryInputFlatModelWorkingDirectory Property

Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel Methods

The QueryInputFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryInputFlatModel Class


QueryInputModel Class

Represents arguments to a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
More...

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class QueryInputModel
Public Class QueryInputModel
public ref class QueryInputModel
type QueryInputModel =  class end

The QueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInputModel | Initializes a new instance of the QueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsCompositeQueryInputModel
DoubleTake.Web.ModelsDtscStatusQueryInputModel
DoubleTake.Web.ModelsDTTargetResourceQueryInputModel
DoubleTake.Web.ModelsHeartbeatPingQueryInputModel
DoubleTake.Web.ModelsIcmpPingQueryInputModel
DoubleTake.Web.ModelsPerformanceCounterQueryInputModel
DoubleTake.Web.ModelsScriptQueryInputModel
DoubleTake.Web.ModelsServiceStatusQueryInputModel
DoubleTake.Web.ModelsShareQueryInputModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryInputModel
DoubleTake.Web.ModelsVmConfigQueryInputModel
DoubleTake.Web.ModelsVmHealthQueryInputModel


QueryInputModel Constructor

Initializes a new instance of the QueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryInputModel()
Public Sub New
public:
QueryInputModel()
new : unit -> QueryInputModel
See Also

Reference

QueryInputModel Class


QueryInputModel Properties

The QueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Top
See Also

Reference

QueryInputModel Class


QueryInputModel.Credentials Property

QueryInputModelCredentials Property

Gets or sets the credentials to be used by the query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

QueryInputModel Class


QueryInputModel Methods

The QueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryInputModel Class


QueryResultFlatModel Class

Represents the result of a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class QueryResultFlatModel
Public Class QueryResultFlatModel
public ref class QueryResultFlatModel
type QueryResultFlatModel =  class end

The QueryResultFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryResultFlatModel | Initializes a new instance of the QueryResultFlatModel class
Top
Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name.
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception.
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | OwningNode | Gets or sets the owning node.
Public property | QueryResults | Gets or sets the query results.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Shares | Gets or sets the shares.
Public property | StartTime | Gets or sets the start time.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Public property | VhdPath | Gets or sets the VHD paths.
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueryResultFlatModel Constructor

Initializes a new instance of the QueryResultFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel()
Public Sub New
public:
QueryResultFlatModel()
new : unit -> QueryResultFlatModel
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel Properties

The QueryResultFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name.
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception.
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | OwningNode | Gets or sets the owning node.
Public property | QueryResults | Gets or sets the query results.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Shares | Gets or sets the shares.
Public property | StartTime | Gets or sets the start time.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Public property | VhdPath | Gets or sets the VHD paths.
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ClassName Property

QueryResultFlatModelClassName Property

Gets or sets the class name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The class name.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.EnginePort Property

QueryResultFlatModelEnginePort Property

Gets or sets the engine port that was used to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
The engine port that was used to ping.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Exception Property

QueryResultFlatModelException Property

Gets or sets the query exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The query exception.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExceptionDetail Property

QueryResultFlatModelExceptionDetail Property

Gets or sets the exception detail.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ ExceptionDetail {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member ExceptionDetail : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The exception detail.
Remarks
This property will only be non- if an exception was thrown by the ICMP ping operation.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExitCode Property

QueryResultFlatModelExitCode Property

Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExitTime Property

QueryResultFlatModelExitTime Property

Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.IPAddress Property

QueryResultFlatModelIPAddress Property

Gets or sets the IP address that was pinged during this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address that was pinged during this query.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.NetworkId Property

QueryResultFlatModelNetworkId Property

Gets or sets the network id that was pinged.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id that was pinged.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.OwningNode Property

QueryResultFlatModelOwningNode Property

Gets or sets the owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.QueryResults Property

QueryResultFlatModelQueryResults Property

Gets or sets the query results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel[] QueryResults { get; set; }
Public Property QueryResults As QueryResultFlatModel()
    Get
    Set
public:
property array<QueryResultFlatModel^>^ QueryResults {
    array<QueryResultFlatModel^>^ get ();
    void set (array<QueryResultFlatModel^>^ value);
}
member QueryResults : QueryResultFlatModel[] with get, set

Property Value

Type: QueryResultFlatModel
The query results.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ReplyAddress Property

QueryResultFlatModelReplyAddress Property

Gets or sets the IP address from which the reply was sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ReplyAddress { get; set; }
Public Property ReplyAddress As String
    Get
    Set
public:
property String^ ReplyAddress {
    String^ get ();
    void set (String^ value);
}
member ReplyAddress : string with get, set

Property Value

Type: String
The IP address from which the reply was sent.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ResourceState Property

QueryResultFlatModelResourceState Property

Gets or sets the state of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ResourceState { get; set; }
Public Property ResourceState As Integer
    Get
    Set
public:
property int ResourceState {
    int get ();
    void set (int value);
}
member ResourceState : int with get, set

Property Value

Type: Int32
The state of the resource.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Result Property

QueryResultFlatModelResult Property

Gets or sets a value indicating whether or not the query was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorResultEnum Result { get; set; }
Public Property Result As MonitorResultEnum
    Get
    Set
public:
property MonitorResultEnum Result {
    MonitorResultEnum get ();
    void set (MonitorResultEnum value);
}
member Result : MonitorResultEnum with get, set

Property Value

Type: MonitorResultEnum
if query was successful; otherwise, .
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Roundtrip Property

QueryResultFlatModelRoundtrip Property

Gets or sets the duration of the ICMP ping round-trip.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Roundtrip { get; set; }
Public Property Roundtrip As TimeSpan
    Get
    Set
public:
property TimeSpan Roundtrip {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Roundtrip : TimeSpan with get, set

Property Value

Type: TimeSpan
The duration of the ICMP ping round-trip.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ServiceName Property

QueryResultFlatModelServiceName Property

Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Shares Property

QueryResultFlatModelShares Property

Gets or sets the shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> Shares { get; set; }
Public Property Shares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ Shares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member Shares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.StartTime Property

QueryResultFlatModelStartTime Property

Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Status Property

QueryResultFlatModelStatus Property

Gets or sets the IPStatus from the ping reply as a string.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
The IPStatus from the ping reply as a string.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VhdPath Property

QueryResultFlatModelVhdPath Property

Gets or sets the VHD paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VirtualSwitchInfoColl Property

QueryResultFlatModelVirtualSwitchInfoColl Property

Gets or sets the virtual switch information collection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information collection.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmId Property

QueryResultFlatModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmSnapshotDataRoot Property

QueryResultFlatModelVmSnapshotDataRoot Property

Gets or sets the vm snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmSnapshotDataRoot { get; set; }
Public Property VmSnapshotDataRoot As String
    Get
    Set
public:
property String^ VmSnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member VmSnapshotDataRoot : string with get, set

Property Value

Type: String
The vm snapshot data root.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmSnapshotFileNames Property

QueryResultFlatModelVmSnapshotFileNames Property

Gets or sets the vm snapshot file names.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VmSnapshotFileNames { get; set; }
Public Property VmSnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ VmSnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VmSnapshotFileNames : string[] with get, set

Property Value

Type: String
The vm snapshot file names.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel Methods

The QueryResultFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryResultFlatModel Class


QueryResultModel Class

Represents the result of a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
More...

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class QueryResultModel
Public Class QueryResultModel
public ref class QueryResultModel
type QueryResultModel =  class end

The QueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryResultModel | Initializes a new instance of the QueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsCompositeQueryResultModel
DoubleTake.Web.ModelsDtscStatusQueryResultModel
DoubleTake.Web.ModelsHeartbeatPingQueryResultModel
DoubleTake.Web.ModelsIcmpPingQueryResultModel
DoubleTake.Web.ModelsPerformanceCounterQueryResultModel
DoubleTake.Web.ModelsServiceStatusQueryResultModel
DoubleTake.Web.ModelsShareQueryResultModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryResultModel
DoubleTake.Web.ModelsVmConfigQueryResultModel
DoubleTake.Web.ModelsVmHealthQueryResultModel


QueryResultModel Constructor

Initializes a new instance of the QueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueryResultModel()
Public Sub New
public:
QueryResultModel()
new : unit -> QueryResultModel
See Also

Reference

QueryResultModel Class


QueryResultModel Properties

The QueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
See Also

Reference

QueryResultModel Class


QueryResultModel.Exception Property

QueryResultModelException Property

Gets or sets the query exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The query exception.
See Also

Reference

QueryResultModel Class


QueryResultModel.Result Property

QueryResultModelResult Property

Gets or sets a value indicating whether or not the query was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MonitorResultEnum Result { get; set; }
Public Property Result As MonitorResultEnum
    Get
    Set
public:
property MonitorResultEnum Result {
    MonitorResultEnum get ();
    void set (MonitorResultEnum value);
}
member Result : MonitorResultEnum with get, set

Property Value

Type: MonitorResultEnum
if query was successful; otherwise, .
See Also

Reference

QueryResultModel Class


QueryResultModel Methods

The QueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryResultModel Class


QueueStateEnum Enumeration

The operational state of a queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum QueueStateEnum
Public Enumeration QueueStateEnum
public enum class QueueStateEnum
type QueueStateEnum
Members
Member name | Value | Description
Pause | 0 | Queue processing is paused.
Active | 1 | The queue is being processed.
Scheduled | 2 | Queue processing is pending.
Remarks
Describes the current state of a queue, not necessarily the desired operation.
See Also

Reference

DoubleTake.Web.Models Namespace


QueueTaskParametersModel Class

Queue task parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueueTaskParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class QueueTaskParametersModel
Public NotInheritable Class QueueTaskParametersModel
public ref class QueueTaskParametersModel sealed
[<SealedAttribute>]
type QueueTaskParametersModel =  class end

The QueueTaskParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueueTaskParametersModel | Initializes a new instance of the QueueTaskParametersModel class
Top
Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueueTaskParametersModel Constructor

Initializes a new instance of the QueueTaskParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public QueueTaskParametersModel()
Public Sub New
public:
QueueTaskParametersModel()
new : unit -> QueueTaskParametersModel
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel Properties

The QueueTaskParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.DesktopInteractionMode Property

QueueTaskParametersModelDesktopInteractionMode Property

Gets or sets the desktop interaction mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionMode DesktopInteractionMode { get; set; }
Public Property DesktopInteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode DesktopInteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
member DesktopInteractionMode : DesktopInteractionMode with get, set

Property Value

Type: DesktopInteractionMode
The desktop interaction mode.
Remarks
Use this parameter to specify whether or not you want the script or executable to be able to interact with the desktop.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnExecute Property

QueueTaskParametersModelOnExecute Property

Gets or sets the script to execute when the command is executed on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnExecute { get; set; }
Public Property OnExecute As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnExecute {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnExecute : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute when the command is executed on the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnQueue Property

QueueTaskParametersModelOnQueue Property

Gets or sets the script to execute on the source when the command is queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnQueue { get; set; }
Public Property OnQueue As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnQueue {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnQueue : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute on the source when the command is queued.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnReceive Property

QueueTaskParametersModelOnReceive Property

Gets or sets the script to execute when the command is received on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnReceive { get; set; }
Public Property OnReceive As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnReceive {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnReceive : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute when the command is received on the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnTransmit Property

QueueTaskParametersModelOnTransmit Property

Gets or sets the script to execute on the source when the command is transmitted to the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnTransmit { get; set; }
Public Property OnTransmit As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnTransmit {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnTransmit : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute on the source when the command is transmitted to the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.TaskName Property

QueueTaskParametersModelTaskName Property

Gets or sets the name of the task.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TaskName { get; set; }
Public Property TaskName As String
    Get
    Set
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}
member TaskName : string with get, set

Property Value

Type: String
The name of the task.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.Timeout Property

QueueTaskParametersModelTimeout Property

Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel Methods

The QueueTaskParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueueTaskParametersModel Class


RebootActionEnum Enumeration

An enumeration specifying the desired reboot behavior after a cutover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum RebootActionEnum
Public Enumeration RebootActionEnum
public enum class RebootActionEnum
type RebootActionEnum
Members
Member name | Value | Description
RebootAfterCutover | 0 | The target should be rebooted after cutover.
DoNotRebootAfterCutover | 1 | The target should not be rebooted after cutover.
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedRestoreOptionsModel Class

Recommended restore options.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedRestoreOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedRestoreOptionsModel
Public NotInheritable Class RecommendedRestoreOptionsModel
public ref class RecommendedRestoreOptionsModel sealed
[<SealedAttribute>]
type RecommendedRestoreOptionsModel =  class end

The RecommendedRestoreOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedRestoreOptionsModel | Initializes a new instance of the RecommendedRestoreOptionsModel class
Top
Properties
 | Name | Description
Public property | CanClearRestoreRequired | Gets or sets a value indicating whether the restore required state can be cleared.
Public property | IsNat | Gets or sets a value indicating whether this instance is NAT.
Public property | PossibleSourceAddresses | Gets or sets the possible source addresses.
Public property | RestoreOptions | Gets or sets the restore options.
Public property | SameSourceOnly | Gets or sets a value indicating whether the job only allows restoring to the same source.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedRestoreOptionsModel Constructor

Initializes a new instance of the RecommendedRestoreOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public RecommendedRestoreOptionsModel()
Public Sub New
public:
RecommendedRestoreOptionsModel()
new : unit -> RecommendedRestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Properties

The RecommendedRestoreOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | CanClearRestoreRequired | Gets or sets a value indicating whether the restore required state can be cleared.
Public property | IsNat | Gets or sets a value indicating whether this instance is NAT.
Public property | PossibleSourceAddresses | Gets or sets the possible source addresses.
Public property | RestoreOptions | Gets or sets the restore options.
Public property | SameSourceOnly | Gets or sets a value indicating whether the job only allows restoring to the same source.
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.CanClearRestoreRequired Property

RecommendedRestoreOptionsModelCanClearRestoreRequired Property

Gets or sets a value indicating whether the restore required state can be cleared.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool CanClearRestoreRequired { get; set; }
Public Property CanClearRestoreRequired As Boolean
    Get
    Set
public:
property bool CanClearRestoreRequired {
    bool get ();
    void set (bool value);
}
member CanClearRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.IsNat Property

RecommendedRestoreOptionsModelIsNat Property

Gets or sets a value indicating whether this instance is NAT.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
member IsNat : bool with get, set

Property Value

Type: Boolean
if this instance is NAT; otherwise, .
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.PossibleSourceAddresses Property

RecommendedRestoreOptionsModelPossibleSourceAddresses Property

Gets or sets the possible source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] PossibleSourceAddresses { get; set; }
Public Property PossibleSourceAddresses As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PossibleSourceAddresses : string[] with get, set

Property Value

Type: String
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.RestoreOptions Property

RecommendedRestoreOptionsModelRestoreOptions Property

Gets or sets the restore options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsModel RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptionsModel
    Get
    Set
public:
property RestoreOptionsModel^ RestoreOptions {
    RestoreOptionsModel^ get ();
    void set (RestoreOptionsModel^ value);
}
member RestoreOptions : RestoreOptionsModel with get, set

Property Value

Type: RestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.SameSourceOnly Property

RecommendedRestoreOptionsModelSameSourceOnly Property

Gets or sets a value indicating whether the job only allows restoring to the same source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool SameSourceOnly { get; set; }
Public Property SameSourceOnly As Boolean
    Get
    Set
public:
property bool SameSourceOnly {
    bool get ();
    void set (bool value);
}
member SameSourceOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Methods

The RecommendedRestoreOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


ReMonitorActionEnum Enumeration

Used to specify the action to take after a failback has completed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ReMonitorActionEnum
Public Enumeration ReMonitorActionEnum
public enum class ReMonitorActionEnum
type ReMonitorActionEnum
Members
Member name | Value | Description
Remove | 0 | Indicates that we want to remove the monitor (stop monitoring).
Resume | 1 | Indicates that we want to resume monitoring.
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationSetInfoModel Class

Replication set information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsReplicationSetInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ReplicationSetInfoModel
Public NotInheritable Class ReplicationSetInfoModel
public ref class ReplicationSetInfoModel sealed
[<SealedAttribute>]
type ReplicationSetInfoModel =  class end

The ReplicationSetInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicationSetInfoModel | Initializes a new instance of the ReplicationSetInfoModel class
Top
Properties
 | Name | Description
Public property | ByteCount | Gets or sets the byte count.
Public property | DirectoryCount | Gets or sets the directory count.
Public property | FileCount | Gets or sets the file count.
Public property | IsCalculating | Gets or sets a value indicating whether the replication set size is currently being calculated.
Public property | IsCaseSensitive | Gets or sets a value indicating whether this instance is case sensitive.
Public property | LastCalculated | Gets or sets the last calculated.
Public property | LastSaved | Gets or sets the last saved.
Public property | Name | Gets or sets the name.
Public property | Rules | Gets or sets the rules.
Public property | UsageType | Gets or sets the type of the usage.
Public property | VolumeCount | Gets or sets the volume count.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationSetInfoModel Constructor

Initializes a new instance of the ReplicationSetInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetInfoModel()
Public Sub New
public:
ReplicationSetInfoModel()
new : unit -> ReplicationSetInfoModel
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel Properties

The ReplicationSetInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ByteCount | Gets or sets the byte count.
Public property | DirectoryCount | Gets or sets the directory count.
Public property | FileCount | Gets or sets the file count.
Public property | IsCalculating | Gets or sets a value indicating whether the replication set size is currently being calculated.
Public property | IsCaseSensitive | Gets or sets a value indicating whether this instance is case sensitive.
Public property | LastCalculated | Gets or sets the last calculated.
Public property | LastSaved | Gets or sets the last saved.
Public property | Name | Gets or sets the name.
Public property | Rules | Gets or sets the rules.
Public property | UsageType | Gets or sets the type of the usage.
Public property | VolumeCount | Gets or sets the volume count.
Top
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.ByteCount Property

ReplicationSetInfoModelByteCount Property

Gets or sets the byte count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long ByteCount { get; set; }
Public Property ByteCount As Long
    Get
    Set
public:
property long long ByteCount {
    long long get ();
    void set (long long value);
}
member ByteCount : int64 with get, set

Property Value

Type: Int64
The byte count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.DirectoryCount Property

ReplicationSetInfoModelDirectoryCount Property

Gets or sets the directory count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long DirectoryCount { get; set; }
Public Property DirectoryCount As Long
    Get
    Set
public:
property long long DirectoryCount {
    long long get ();
    void set (long long value);
}
member DirectoryCount : int64 with get, set

Property Value

Type: Int64
The directory count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.FileCount Property

ReplicationSetInfoModelFileCount Property

Gets or sets the file count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long FileCount { get; set; }
Public Property FileCount As Long
    Get
    Set
public:
property long long FileCount {
    long long get ();
    void set (long long value);
}
member FileCount : int64 with get, set

Property Value

Type: Int64
The file count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.IsCalculating Property

ReplicationSetInfoModelIsCalculating Property

Gets or sets a value indicating whether the replication set size is currently being calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsCalculating { get; set; }
Public Property IsCalculating As Boolean
    Get
    Set
public:
property bool IsCalculating {
    bool get ();
    void set (bool value);
}
member IsCalculating : bool with get, set

Property Value

Type: Boolean
if the size is being calculated; otherwise .
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.IsCaseSensitive Property

ReplicationSetInfoModelIsCaseSensitive Property

Gets or sets a value indicating whether this instance is case sensitive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set
public:
property bool IsCaseSensitive {
    bool get ();
    void set (bool value);
}
member IsCaseSensitive : bool with get, set

Property Value

Type: Boolean
if this instance is case sensitive; otherwise, .
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.LastCalculated Property

ReplicationSetInfoModelLastCalculated Property

Gets or sets the last calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastCalculated { get; set; }
Public Property LastCalculated As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastCalculated {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastCalculated : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The last calculated.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.LastSaved Property

ReplicationSetInfoModelLastSaved Property

Gets or sets the last saved.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastSaved { get; set; }
Public Property LastSaved As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastSaved {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastSaved : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The last saved.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.Name Property

ReplicationSetInfoModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.Rules Property

ReplicationSetInfoModelRules Property

Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] Rules { get; set; }
Public Property Rules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ Rules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member Rules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The rules.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.UsageType Property

ReplicationSetInfoModelUsageType Property

Gets or sets the type of the usage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string UsageType { get; set; }
Public Property UsageType As String
    Get
    Set
public:
property String^ UsageType {
    String^ get ();
    void set (String^ value);
}
member UsageType : string with get, set

Property Value

Type: String
The usage type.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.VolumeCount Property

ReplicationSetInfoModelVolumeCount Property

Gets or sets the volume count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int VolumeCount { get; set; }
Public Property VolumeCount As Integer
    Get
    Set
public:
property int VolumeCount {
    int get ();
    void set (int value);
}
member VolumeCount : int with get, set

Property Value

Type: Int32
The volume count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel Methods

The ReplicationSetInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReplicationSetInfoModel Class


ResourceAndPassiveNodesModel Class

Resource and passive nodes.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsResourceAndPassiveNodesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ResourceAndPassiveNodesModel
Public Class ResourceAndPassiveNodesModel
public ref class ResourceAndPassiveNodesModel
type ResourceAndPassiveNodesModel =  class end

The ResourceAndPassiveNodesModel type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceAndPassiveNodesModel | Initializes a new instance of the ResourceAndPassiveNodesModel class
Top
Properties
 | Name | Description
Public property | PassiveNodes | Gets or sets the passive nodes.
Public property | Resource | Gets or sets the resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ResourceAndPassiveNodesModel Constructor

Initializes a new instance of the ResourceAndPassiveNodesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ResourceAndPassiveNodesModel()
Public Sub New
public:
ResourceAndPassiveNodesModel()
new : unit -> ResourceAndPassiveNodesModel
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel Properties

The ResourceAndPassiveNodesModel type exposes the following members.

Properties
 | Name | Description
Public property | PassiveNodes | Gets or sets the passive nodes.
Public property | Resource | Gets or sets the resource.
Top
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel.PassiveNodes Property

ResourceAndPassiveNodesModelPassiveNodes Property

Gets or sets the passive nodes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] PassiveNodes { get; set; }
Public Property PassiveNodes As String()
    Get
    Set
public:
property array<String^>^ PassiveNodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PassiveNodes : string[] with get, set

Property Value

Type: String
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel.Resource Property

ResourceAndPassiveNodesModelResource Property

Gets or sets the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Resource { get; set; }
Public Property Resource As String
    Get
    Set
public:
property String^ Resource {
    String^ get ();
    void set (String^ value);
}
member Resource : string with get, set

Property Value

Type: String
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel Methods

The ResourceAndPassiveNodesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResourceAndPassiveNodesModel Class


ScriptActionInputModel Class

Represents the input to execute a script
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsScriptActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ScriptActionInputModel : ActionInputModel
Public Class ScriptActionInputModel
    Inherits ActionInputModel
public ref class ScriptActionInputModel : public ActionInputModel
type ScriptActionInputModel =
    class
        inherit ActionInputModel
    end

The ScriptActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionInputModel | Initializes a new instance of the ScriptActionInputModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionInputModel


ScriptActionInputModel Constructor

Initializes a new instance of the ScriptActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ScriptActionInputModel()
Public Sub New
public:
ScriptActionInputModel()
new : unit -> ScriptActionInputModel
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel Properties

The ScriptActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.Arguments Property

ScriptActionInputModelArguments Property

Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.FileName Property

ScriptActionInputModelFileName Property

Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.RunAs Property

ScriptActionInputModelRunAs Property

Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WaitForCompletion Property

ScriptActionInputModelWaitForCompletion Property

Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WaitForCompletionTimeout Property

ScriptActionInputModelWaitForCompletionTimeout Property

Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WorkingDirectory Property

ScriptActionInputModelWorkingDirectory Property

Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel Methods

The ScriptActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptActionInputModel Class


ScriptActionResultModel Class

Represents the results of a Script action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsScriptActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ScriptActionResultModel : ActionResultModel
Public Class ScriptActionResultModel
    Inherits ActionResultModel
public ref class ScriptActionResultModel : public ActionResultModel
type ScriptActionResultModel =
    class
        inherit ActionResultModel
    end

The ScriptActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionResultModel | Initializes a new instance of the ScriptActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionResultModel


ScriptActionResultModel Constructor

Initializes a new instance of the ScriptActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResultModel()
Public Sub New
public:
ScriptActionResultModel()
new : unit -> ScriptActionResultModel
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel Properties

The ScriptActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.ExitCode Property

ScriptActionResultModelExitCode Property

Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.ExitTime Property

ScriptActionResultModelExitTime Property

Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.StartTime Property

ScriptActionResultModelStartTime Property

Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel Methods

The ScriptActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptActionResultModel Class


ScriptQueryInputModel Class

Defines the input into the script query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsScriptQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ScriptQueryInputModel : QueryInputModel
Public Class ScriptQueryInputModel
    Inherits QueryInputModel
public ref class ScriptQueryInputModel : public QueryInputModel
type ScriptQueryInputModel =
    class
        inherit QueryInputModel
    end

The ScriptQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptQueryInputModel | Initializes a new instance of the ScriptQueryInputModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptQueryInputModel Constructor

Initializes a new instance of the ScriptQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ScriptQueryInputModel()
Public Sub New
public:
ScriptQueryInputModel()
new : unit -> ScriptQueryInputModel
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel Properties

The ScriptQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.Arguments Property

ScriptQueryInputModelArguments Property

Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.FileName Property

ScriptQueryInputModelFileName Property

Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.RunAs Property

ScriptQueryInputModelRunAs Property

Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WaitForCompletion Property

ScriptQueryInputModelWaitForCompletion Property

Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WaitForCompletionTimeout Property

ScriptQueryInputModelWaitForCompletionTimeout Property

Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WorkingDirectory Property

ScriptQueryInputModelWorkingDirectory Property

Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel Methods

The ScriptQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptQueryInputModel Class


ServiceInfoModel Class

Service information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceInfoModel
Public NotInheritable Class ServiceInfoModel
public ref class ServiceInfoModel sealed
[<SealedAttribute>]
type ServiceInfoModel =  class end

The ServiceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInfoModel | Initializes a new instance of the ServiceInfoModel class
Top
Properties
 | Name | Description
Public property | Account | Gets or sets the account under which the service runs.
Public property | Name | Gets or sets the service name.
Public property | NameDisplay | Gets or sets the service display name.
Public property | StartMode | Gets or sets the service start mode.
Public property | Status | Gets or sets the service status.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceInfoModel Constructor

Initializes a new instance of the ServiceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceInfoModel()
Public Sub New
public:
ServiceInfoModel()
new : unit -> ServiceInfoModel
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel Properties

The ServiceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Account | Gets or sets the account under which the service runs.
Public property | Name | Gets or sets the service name.
Public property | NameDisplay | Gets or sets the service display name.
Public property | StartMode | Gets or sets the service start mode.
Public property | Status | Gets or sets the service status.
Top
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Account Property

ServiceInfoModelAccount Property

Gets or sets the account under which the service runs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Account { get; set; }
Public Property Account As String
    Get
    Set
public:
property String^ Account {
    String^ get ();
    void set (String^ value);
}
member Account : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Name Property

ServiceInfoModelName Property

Gets or sets the service name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.NameDisplay Property

ServiceInfoModelNameDisplay Property

Gets or sets the service display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NameDisplay { get; set; }
Public Property NameDisplay As String
    Get
    Set
public:
property String^ NameDisplay {
    String^ get ();
    void set (String^ value);
}
member NameDisplay : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.StartMode Property

ServiceInfoModelStartMode Property

Gets or sets the service start mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServicesStartModeEnum StartMode { get; set; }
Public Property StartMode As ServicesStartModeEnum
    Get
    Set
public:
property ServicesStartModeEnum StartMode {
    ServicesStartModeEnum get ();
    void set (ServicesStartModeEnum value);
}
member StartMode : ServicesStartModeEnum with get, set

Property Value

Type: ServicesStartModeEnum
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Status Property

ServiceInfoModelStatus Property

Gets or sets the service status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TargetServiceStatus Status { get; set; }
Public Property Status As TargetServiceStatus
    Get
    Set
public:
property TargetServiceStatus Status {
    TargetServiceStatus get ();
    void set (TargetServiceStatus value);
}
member Status : TargetServiceStatus with get, set

Property Value

Type: TargetServiceStatus
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel Methods

The ServiceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceInfoModel Class


ServiceMetadataModel Class

Service metadata.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceMetadataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceMetadataModel
Public NotInheritable Class ServiceMetadataModel
public ref class ServiceMetadataModel sealed
[<SealedAttribute>]
type ServiceMetadataModel =  class end

The ServiceMetadataModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMetadataModel | Initializes a new instance of the ServiceMetadataModel class
Top
Properties
 | Name | Description
Public property | MachineId | Gets or sets the machine identifier.
Public property | ProductVersion | Gets or sets the product version.
Public property | ServerName | Gets or sets the name of the server.
Public property | ServiceTags | Gets or sets the service tags.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceMetadataModel Constructor

Initializes a new instance of the ServiceMetadataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceMetadataModel()
Public Sub New
public:
ServiceMetadataModel()
new : unit -> ServiceMetadataModel
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Properties

The ServiceMetadataModel type exposes the following members.

Properties
 | Name | Description
Public property | MachineId | Gets or sets the machine identifier.
Public property | ProductVersion | Gets or sets the product version.
Public property | ServerName | Gets or sets the name of the server.
Public property | ServiceTags | Gets or sets the service tags.
Top
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.MachineId Property

ServiceMetadataModelMachineId Property

Gets or sets the machine identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid MachineId { get; set; }
Public Property MachineId As Guid
    Get
    Set
public:
property Guid MachineId {
    Guid get ();
    void set (Guid value);
}
member MachineId : Guid with get, set

Property Value

Type: Guid
The machine identifier.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ProductVersion Property

ServiceMetadataModelProductVersion Property

Gets or sets the product version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}
member ProductVersion : string with get, set

Property Value

Type: String
The product version.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServerName Property

ServiceMetadataModelServerName Property

Gets or sets the name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
The name of the server.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServiceTags Property

ServiceMetadataModelServiceTags Property

Gets or sets the service tags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ServiceTags { get; set; }
Public Property ServiceTags As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ServiceTags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ServiceTags : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The service tags.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Methods

The ServiceMetadataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceMetadataModel Class


ServiceOperationActionInputModel Class

The inputs for a Service operation
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsServiceOperationActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ServiceOperationActionInputModel : ActionInputModel
Public Class ServiceOperationActionInputModel
    Inherits ActionInputModel
public ref class ServiceOperationActionInputModel : public ActionInputModel
type ServiceOperationActionInputModel =
    class
        inherit ActionInputModel
    end

The ServiceOperationActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionInputModel | Initializes a new instance of the ServiceOperationActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionInputModel


ServiceOperationActionInputModel Constructor

Initializes a new instance of the ServiceOperationActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationActionInputModel()
Public Sub New
public:
ServiceOperationActionInputModel()
new : unit -> ServiceOperationActionInputModel
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel Properties

The ServiceOperationActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.ServiceName Property

ServiceOperationActionInputModelServiceName Property

Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.ServiceOperation Property

ServiceOperationActionInputModelServiceOperation Property

Gets or sets the service operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationEnum ServiceOperation { get; set; }
Public Property ServiceOperation As ServiceOperationEnum
    Get
    Set
public:
property ServiceOperationEnum ServiceOperation {
    ServiceOperationEnum get ();
    void set (ServiceOperationEnum value);
}
member ServiceOperation : ServiceOperationEnum with get, set

Property Value

Type: ServiceOperationEnum
The service operation.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.StartArguments Property

ServiceOperationActionInputModelStartArguments Property

Gets or sets the arguments for the Start operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] StartArguments { get; set; }
Public Property StartArguments As String()
    Get
    Set
public:
property array<String^>^ StartArguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member StartArguments : string[] with get, set

Property Value

Type: String
The arguments for the Start operation.
Remarks
This property is ignored for all [F:ServiceOperation] values other than the Start operation.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.Timeout Property

ServiceOperationActionInputModelTimeout Property

Gets or sets the timeout for the wait operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Timeout { get; set; }
Public Property Timeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Timeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Timeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The timeout for the wait operation.
Remarks
If this value is , the action agent will wait indefinitely for the status to change.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.WaitForStatus Property

ServiceOperationActionInputModelWaitForStatus Property

Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForStatus { get; set; }
Public Property WaitForStatus As Boolean
    Get
    Set
public:
property bool WaitForStatus {
    bool get ();
    void set (bool value);
}
member WaitForStatus : bool with get, set

Property Value

Type: Boolean
to wait for the service status to change; otherwise, .
Remarks
There is a corresponding service status change for each operation. For instance, if you've requested the Start operation, this action will wait for the service status to change to Running.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel Methods

The ServiceOperationActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionResultModel Class

Represents the result of a service operation action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsServiceOperationActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ServiceOperationActionResultModel : ActionResultModel
Public Class ServiceOperationActionResultModel
    Inherits ActionResultModel
public ref class ServiceOperationActionResultModel : public ActionResultModel
type ServiceOperationActionResultModel =
    class
        inherit ActionResultModel
    end

The ServiceOperationActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionResultModel | Initializes a new instance of the ServiceOperationActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceOperationActionResultModel Constructor

Initializes a new instance of the ServiceOperationActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationActionResultModel()
Public Sub New
public:
ServiceOperationActionResultModel()
new : unit -> ServiceOperationActionResultModel
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel Properties

The ServiceOperationActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel.ServiceStatus Property

ServiceOperationActionResultModelServiceStatus Property

Gets or sets the service status after the operation has been executed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceStatus { get; set; }
Public Property ServiceStatus As String
    Get
    Set
public:
property String^ ServiceStatus {
    String^ get ();
    void set (String^ value);
}
member ServiceStatus : string with get, set

Property Value

Type: String
The service status after the operation has been executed.
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel Methods

The ServiceOperationActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationEnum Enumeration

Represents the different types of Windows service operations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ServiceOperationEnum
Public Enumeration ServiceOperationEnum
public enum class ServiceOperationEnum
type ServiceOperationEnum
Members
Member name | Value | Description
Start | 0 | Indicates to execute the 'Start' operation on the service.
Stop | 1 | Indicates to execute the 'Stop' operation on the service.
Pause | 2 | Indicates to execute the 'Pause' operation on the service.
Continue | 3 | Indicates to execute the 'Continue' operation on the service.
See Also

Reference

DoubleTake.Web.Models Namespace


ServicesStartModeEnum Enumeration

Represents the startup mode of a Windows service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ServicesStartModeEnum
Public Enumeration ServicesStartModeEnum
public enum class ServicesStartModeEnum
type ServicesStartModeEnum
Members
Member name | Value | Description
Boot | 0 | Indicates that the device driver is started by the operating system loader.
System | 1 | Indicates that the device driver is started by the operating system initialization process.
Auto | 2 | Indicates that the service is started automatically by the Service Control Manager during system startup.
Manual | 3 | Indicates that the service is started by the Service Control Manager upon user request.
Disabled | 4 | Indicates that the service cannot be started.
Unknown | 5 | Indicates that WMI was unable to determine the start mode of the service. This is undocumented, but we have seen cases where this caused problems.
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceStatusQueryInputModel Class

Represents the input to a service query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsServiceStatusQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ServiceStatusQueryInputModel : QueryInputModel
Public Class ServiceStatusQueryInputModel
    Inherits QueryInputModel
public ref class ServiceStatusQueryInputModel : public QueryInputModel
type ServiceStatusQueryInputModel =
    class
        inherit QueryInputModel
    end

The ServiceStatusQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryInputModel | Initializes a new instance of the ServiceStatusQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ServiceName | Gets or sets the name of the service to monitor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


ServiceStatusQueryInputModel Constructor

Initializes a new instance of the ServiceStatusQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceStatusQueryInputModel()
Public Sub New
public:
ServiceStatusQueryInputModel()
new : unit -> ServiceStatusQueryInputModel
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel Properties

The ServiceStatusQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ServiceName | Gets or sets the name of the service to monitor.
Top
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel.ServiceName Property

ServiceStatusQueryInputModelServiceName Property

Gets or sets the name of the service to monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel Methods

The ServiceStatusQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryResultModel Class

Represents the results of a Service Status Query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsServiceStatusQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ServiceStatusQueryResultModel : QueryResultModel
Public Class ServiceStatusQueryResultModel
    Inherits QueryResultModel
public ref class ServiceStatusQueryResultModel : public QueryResultModel
type ServiceStatusQueryResultModel =
    class
        inherit QueryResultModel
    end

The ServiceStatusQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryResultModel | Initializes a new instance of the ServiceStatusQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | ServiceName | Gets or sets the name of the service.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


ServiceStatusQueryResultModel Constructor

Initializes a new instance of the ServiceStatusQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServiceStatusQueryResultModel()
Public Sub New
public:
ServiceStatusQueryResultModel()
new : unit -> ServiceStatusQueryResultModel
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel Properties

The ServiceStatusQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | ServiceName | Gets or sets the name of the service.
Top
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel.ServiceName Property

ServiceStatusQueryResultModelServiceName Property

Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel Methods

The ServiceStatusQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceStatusQueryResultModel Class


ServicesToStopModel Class

Services to stop.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServicesToStopModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ServicesToStopModel
Public Class ServicesToStopModel
public ref class ServicesToStopModel
type ServicesToStopModel =  class end

The ServicesToStopModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesToStopModel | Initializes a new instance of the ServicesToStopModel class
Top
Properties
 | Name | Description
Public property | TargetServicesToStop | Gets or sets the target services to stop.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServicesToStopModel Constructor

Initializes a new instance of the ServicesToStopModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ServicesToStopModel()
Public Sub New
public:
ServicesToStopModel()
new : unit -> ServicesToStopModel
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel Properties

The ServicesToStopModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetServicesToStop | Gets or sets the target services to stop.
Top
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel.TargetServicesToStop Property

ServicesToStopModelTargetServicesToStop Property

Gets or sets the target services to stop.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel[] TargetServicesToStop { get; set; }
Public Property TargetServicesToStop As TargetServicesToStopModel()
    Get
    Set
public:
property array<TargetServicesToStopModel^>^ TargetServicesToStop {
    array<TargetServicesToStopModel^>^ get ();
    void set (array<TargetServicesToStopModel^>^ value);
}
member TargetServicesToStop : TargetServicesToStopModel[] with get, set

Property Value

Type: TargetServicesToStopModel
The target services.
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel Methods

The ServicesToStopModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServicesToStopModel Class


ShareQueryInputModel Class

The inputs required for a share monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsShareQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ShareQueryInputModel : QueryInputModel
Public Class ShareQueryInputModel
    Inherits QueryInputModel
public ref class ShareQueryInputModel : public QueryInputModel
type ShareQueryInputModel =
    class
        inherit QueryInputModel
    end

The ShareQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryInputModel | Initializes a new instance of the ShareQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | IdJob | Gets or sets the identifier job.
Public property | Rules | Gets or sets the rules.
Public property | Target | Gets or sets the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


ShareQueryInputModel Constructor

Initializes a new instance of the ShareQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ShareQueryInputModel()
Public Sub New
public:
ShareQueryInputModel()
new : unit -> ShareQueryInputModel
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel Properties

The ShareQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | IdJob | Gets or sets the identifier job.
Public property | Rules | Gets or sets the rules.
Public property | Target | Gets or sets the target.
Top
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.IdJob Property

ShareQueryInputModelIdJob Property

Gets or sets the identifier job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid IdJob { get; set; }
Public Property IdJob As Guid
    Get
    Set
public:
property Guid IdJob {
    Guid get ();
    void set (Guid value);
}
member IdJob : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.Rules Property

ShareQueryInputModelRules Property

Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PhysicalRuleModel> Rules { get; set; }
Public Property Rules As IEnumerable(Of PhysicalRuleModel)
    Get
    Set
public:
property IEnumerable<PhysicalRuleModel^>^ Rules {
    IEnumerable<PhysicalRuleModel^>^ get ();
    void set (IEnumerable<PhysicalRuleModel^>^ value);
}
member Rules : IEnumerable<PhysicalRuleModel> with get, set

Property Value

Type: IEnumerable PhysicalRuleModel
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.Target Property

ShareQueryInputModelTarget Property

Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Uri Target { get; set; }
Public Property Target As Uri
    Get
    Set
public:
property Uri^ Target {
    Uri^ get ();
    void set (Uri^ value);
}
member Target : Uri with get, set

Property Value

Type: Uri
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel Methods

The ShareQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareQueryInputModel Class


ShareQueryResultModel Class

Represents the results of a share query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsShareQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class ShareQueryResultModel : QueryResultModel
Public Class ShareQueryResultModel
    Inherits QueryResultModel
public ref class ShareQueryResultModel : public QueryResultModel
type ShareQueryResultModel =
    class
        inherit QueryResultModel
    end

The ShareQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryResultModel | Initializes a new instance of the ShareQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Shares | Gets or sets the shares.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


ShareQueryResultModel Constructor

Initializes a new instance of the ShareQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public ShareQueryResultModel()
Public Sub New
public:
ShareQueryResultModel()
new : unit -> ShareQueryResultModel
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel Properties

The ShareQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Shares | Gets or sets the shares.
Top
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel.Shares Property

ShareQueryResultModelShares Property

Gets or sets the shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> Shares { get; set; }
Public Property Shares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ Shares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member Shares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel Methods

The ShareQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareQueryResultModel Class


ShortNameBehaviorSettingEnum Enumeration

Defines values of the system short name behavior setting

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ShortNameBehaviorSettingEnum
Public Enumeration ShortNameBehaviorSettingEnum
public enum class ShortNameBehaviorSettingEnum
type ShortNameBehaviorSettingEnum
Members
Member name | Value | Description
Enabled | 0 | Enable 8dot3 name creation on all volumes on the system.
Disabled | 1 | Disable 8dot3 name creation on all volumes on the system.
PerVolume | 2 | Set 8dot3 name creation on a per volume basis.
AllButSystem | 3 | Disable 8dot3 name creation on all volumes except the system volume.
See Also

Reference

DoubleTake.Web.Models Namespace


ShutdownOptionEnum Enumeration

Shutdown option

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum ShutdownOptionEnum
Public Enumeration ShutdownOptionEnum
public enum class ShutdownOptionEnum
type ShutdownOptionEnum
Members
Member name | Value | Description
ShutdownOnly | 0 | Shutdown only
Restart | 1 | Restart
See Also

Reference

DoubleTake.Web.Models Namespace


SqlDatabasePersistedInfoModel Class

SQL database persisted information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSqlDatabasePersistedInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SqlDatabasePersistedInfoModel
Public NotInheritable Class SqlDatabasePersistedInfoModel
public ref class SqlDatabasePersistedInfoModel sealed
[<SealedAttribute>]
type SqlDatabasePersistedInfoModel =  class end

The SqlDatabasePersistedInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | SqlDatabasePersistedInfoModel | Initializes a new instance of the SqlDatabasePersistedInfoModel class
Top
Properties
 | Name | Description
Public property | Files | Gets or sets the files.
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SqlDatabasePersistedInfoModel Constructor

Initializes a new instance of the SqlDatabasePersistedInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SqlDatabasePersistedInfoModel()
Public Sub New
public:
SqlDatabasePersistedInfoModel()
new : unit -> SqlDatabasePersistedInfoModel
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel Properties

The SqlDatabasePersistedInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Files | Gets or sets the files.
Public property | Name | Gets or sets the name.
Top
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel.Files Property

SqlDatabasePersistedInfoModelFiles Property

Gets or sets the files.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Files { get; set; }
Public Property Files As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Files {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Files : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The files.
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel.Name Property

SqlDatabasePersistedInfoModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel Methods

The SqlDatabasePersistedInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlDatabasePersistedInfoModel Class


StorageInfoModel Class

Core.StorageInfo
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsStorageInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class StorageInfoModel
Public NotInheritable Class StorageInfoModel
public ref class StorageInfoModel sealed
[<SealedAttribute>]
type StorageInfoModel =  class end

The StorageInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | StorageInfoModel | Initializes a new instance of the StorageInfoModel class
Top
Properties
 | Name | Description
Public property | Disk | Gets or sets storage location.
Public property | FreeSizeInBytes | Gets or sets the free size in bytes.
Public property | Group | Gets or sets cluster group location.
Public property | IsAvailableStorageGroup | Gets or sets a value indicating whether [is available storage group].
Public property | IsQuorumResource | Gets or sets a value indicating whether this instance is quorum resource.
Public property | IsSystemVolume | Gets or sets a value indicating whether this instance is system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether this instance is volume CSV.
Public property | Name | Gets or sets the name of the resource.
Public property | OwningNode | Gets or sets the current Owning Node.
Public property | TotalSizeInBytes | Gets or sets the total size in bytes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


StorageInfoModel Constructor

Initializes a new instance of the StorageInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public StorageInfoModel()
Public Sub New
public:
StorageInfoModel()
new : unit -> StorageInfoModel
See Also

Reference

StorageInfoModel Class


StorageInfoModel Properties

The StorageInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Disk | Gets or sets storage location.
Public property | FreeSizeInBytes | Gets or sets the free size in bytes.
Public property | Group | Gets or sets cluster group location.
Public property | IsAvailableStorageGroup | Gets or sets a value indicating whether [is available storage group].
Public property | IsQuorumResource | Gets or sets a value indicating whether this instance is quorum resource.
Public property | IsSystemVolume | Gets or sets a value indicating whether this instance is system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether this instance is volume CSV.
Public property | Name | Gets or sets the name of the resource.
Public property | OwningNode | Gets or sets the current Owning Node.
Public property | TotalSizeInBytes | Gets or sets the total size in bytes.
Top
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Disk Property

StorageInfoModelDisk Property

Gets or sets storage location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Disk { get; set; }
Public Property Disk As String
    Get
    Set
public:
property String^ Disk {
    String^ get ();
    void set (String^ value);
}
member Disk : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.FreeSizeInBytes Property

StorageInfoModelFreeSizeInBytes Property

Gets or sets the free size in bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long FreeSizeInBytes { get; set; }
Public Property FreeSizeInBytes As Long
    Get
    Set
public:
property long long FreeSizeInBytes {
    long long get ();
    void set (long long value);
}
member FreeSizeInBytes : int64 with get, set

Property Value

Type: Int64
The free size in bytes.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Group Property

StorageInfoModelGroup Property

Gets or sets cluster group location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsAvailableStorageGroup Property

StorageInfoModelIsAvailableStorageGroup Property

Gets or sets a value indicating whether [is available storage group].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsAvailableStorageGroup { get; set; }
Public Property IsAvailableStorageGroup As Boolean
    Get
    Set
public:
property bool IsAvailableStorageGroup {
    bool get ();
    void set (bool value);
}
member IsAvailableStorageGroup : bool with get, set

Property Value

Type: Boolean
true if [is available storage group]; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsQuorumResource Property

StorageInfoModelIsQuorumResource Property

Gets or sets a value indicating whether this instance is quorum resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsQuorumResource { get; set; }
Public Property IsQuorumResource As Boolean
    Get
    Set
public:
property bool IsQuorumResource {
    bool get ();
    void set (bool value);
}
member IsQuorumResource : bool with get, set

Property Value

Type: Boolean
true if this instance is quorum resource; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsSystemVolume Property

StorageInfoModelIsSystemVolume Property

Gets or sets a value indicating whether this instance is system volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
member IsSystemVolume : bool with get, set

Property Value

Type: Boolean
true if this instance is system volume; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsVolumeCSV Property

StorageInfoModelIsVolumeCSV Property

Gets or sets a value indicating whether this instance is volume CSV.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
true if this instance is volume CSV; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Name Property

StorageInfoModelName Property

Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.OwningNode Property

StorageInfoModelOwningNode Property

Gets or sets the current Owning Node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.TotalSizeInBytes Property

StorageInfoModelTotalSizeInBytes Property

Gets or sets the total size in bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TotalSizeInBytes { get; set; }
Public Property TotalSizeInBytes As Long
    Get
    Set
public:
property long long TotalSizeInBytes {
    long long get ();
    void set (long long value);
}
member TotalSizeInBytes : int64 with get, set

Property Value

Type: Int64
The total size in bytes.
See Also

Reference

StorageInfoModel Class


StorageInfoModel Methods

The StorageInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StorageInfoModel Class


StringSettingModel Class

String setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class StringSettingModel : NamedSettingModel
Public Class StringSettingModel
    Inherits NamedSettingModel
public ref class StringSettingModel : public NamedSettingModel
type StringSettingModel =
    class
        inherit NamedSettingModel
    end

The StringSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | StringSettingModel | Initializes a new instance of the StringSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


StringSettingModel Constructor

Initializes a new instance of the StringSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public StringSettingModel()
Public Sub New
public:
StringSettingModel()
new : unit -> StringSettingModel
See Also

Reference

StringSettingModel Class


StringSettingModel Properties

The StringSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

StringSettingModel Class


StringSettingModel.Value Property

StringSettingModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringSettingModel Class


StringSettingModel Methods

The StringSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringSettingModel Class


SwitchPortInfoModel Class

Switch port info.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSwitchPortInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SwitchPortInfoModel
Public NotInheritable Class SwitchPortInfoModel
public ref class SwitchPortInfoModel sealed
[<SealedAttribute>]
type SwitchPortInfoModel =  class end

The SwitchPortInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchPortInfoModel | Initializes a new instance of the SwitchPortInfoModel class
Top
Properties
 | Name | Description
Public property | AccessVLanId | Gets or sets the VLan Id.
Public property | Guid | Gets or sets the switch port Guid.
Public property | Name | Gets or sets the switch port label.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SwitchPortInfoModel Constructor

Initializes a new instance of the SwitchPortInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SwitchPortInfoModel()
Public Sub New
public:
SwitchPortInfoModel()
new : unit -> SwitchPortInfoModel
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Properties

The SwitchPortInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessVLanId | Gets or sets the VLan Id.
Public property | Guid | Gets or sets the switch port Guid.
Public property | Name | Gets or sets the switch port label.
Top
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.AccessVLanId Property

SwitchPortInfoModelAccessVLanId Property

Gets or sets the VLan Id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int AccessVLanId { get; set; }
Public Property AccessVLanId As Integer
    Get
    Set
public:
property int AccessVLanId {
    int get ();
    void set (int value);
}
member AccessVLanId : int with get, set

Property Value

Type: Int32
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Guid Property

SwitchPortInfoModelGuid Property

Gets or sets the switch port Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Name Property

SwitchPortInfoModelName Property

Gets or sets the switch port label.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Methods

The SwitchPortInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SwitchPortInfoModel Class


SystemStateConfigurationModel Class

Holds the system state definitions for both the source and target
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateConfigurationModel
Public NotInheritable Class SystemStateConfigurationModel
public ref class SystemStateConfigurationModel sealed
[<SealedAttribute>]
type SystemStateConfigurationModel =  class end

The SystemStateConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateConfigurationModel | Initializes a new instance of the SystemStateConfigurationModel class
Top
Properties
 | Name | Description
Public property | SourceSystemStateDefinition | Gets or sets the source system state definition.
Public property | TargetSystemStateDefinition | Gets or sets the target system state definition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateConfigurationModel Constructor

Initializes a new instance of the SystemStateConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateConfigurationModel()
Public Sub New
public:
SystemStateConfigurationModel()
new : unit -> SystemStateConfigurationModel
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel Properties

The SystemStateConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceSystemStateDefinition | Gets or sets the source system state definition.
Public property | TargetSystemStateDefinition | Gets or sets the target system state definition.
Top
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel.SourceSystemStateDefinition Property

SystemStateConfigurationModelSourceSystemStateDefinition Property

Gets or sets the source system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceSystemStateDefinition { get; set; }
Public Property SourceSystemStateDefinition As String
    Get
    Set
public:
property String^ SourceSystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member SourceSystemStateDefinition : string with get, set

Property Value

Type: String
The source system state definition.
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel.TargetSystemStateDefinition Property

SystemStateConfigurationModelTargetSystemStateDefinition Property

Gets or sets the target system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetSystemStateDefinition { get; set; }
Public Property TargetSystemStateDefinition As String
    Get
    Set
public:
property String^ TargetSystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member TargetSystemStateDefinition : string with get, set

Property Value

Type: String
The target system state definition.
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel Methods

The SystemStateConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateConfigurationModel Class


SystemStateCutoverStatusModel Class

System state cutover status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateCutoverStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateCutoverStatusModel
Public Class SystemStateCutoverStatusModel
public ref class SystemStateCutoverStatusModel
type SystemStateCutoverStatusModel =  class end

The SystemStateCutoverStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateCutoverStatusModel | Initializes a new instance of the SystemStateCutoverStatusModel class
Top
Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateCutoverStatusModel Constructor

Initializes a new instance of the SystemStateCutoverStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateCutoverStatusModel()
Public Sub New
public:
SystemStateCutoverStatusModel()
new : unit -> SystemStateCutoverStatusModel
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel Properties

The SystemStateCutoverStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.PercentComplete Property

SystemStateCutoverStatusModelPercentComplete Property

Gets or sets the percent complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
member PercentComplete : int with get, set

Property Value

Type: Int32
The percent complete.
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.State Property

SystemStateCutoverStatusModelState Property

Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
member State : int with get, set

Property Value

Type: Int32
The state.
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.TargetRebootFailed Property

SystemStateCutoverStatusModelTargetRebootFailed Property

Gets or sets a value indicating whether or not the call to reboot the target failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool TargetRebootFailed { get; set; }
Public Property TargetRebootFailed As Boolean
    Get
    Set
public:
property bool TargetRebootFailed {
    bool get ();
    void set (bool value);
}
member TargetRebootFailed : bool with get, set

Property Value

Type: Boolean
if the target reboot failed; otherwise, .
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel Methods

The SystemStateCutoverStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateDefinitionModel Class

System state definition.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateDefinitionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateDefinitionModel
Public NotInheritable Class SystemStateDefinitionModel
public ref class SystemStateDefinitionModel sealed
[<SealedAttribute>]
type SystemStateDefinitionModel =  class end

The SystemStateDefinitionModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateDefinitionModel | Initializes a new instance of the SystemStateDefinitionModel class
Top
Properties
 | Name | Description
Public property | SystemStateDefinition | Gets or sets the system state definition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateDefinitionModel Constructor

Initializes a new instance of the SystemStateDefinitionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateDefinitionModel()
Public Sub New
public:
SystemStateDefinitionModel()
new : unit -> SystemStateDefinitionModel
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel Properties

The SystemStateDefinitionModel type exposes the following members.

Properties
 | Name | Description
Public property | SystemStateDefinition | Gets or sets the system state definition.
Top
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel.SystemStateDefinition Property

SystemStateDefinitionModelSystemStateDefinition Property

Gets or sets the system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SystemStateDefinition { get; set; }
Public Property SystemStateDefinition As String
    Get
    Set
public:
property String^ SystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member SystemStateDefinition : string with get, set

Property Value

Type: String
The system state definition.
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel Methods

The SystemStateDefinitionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Class

System state dump non-disk system state information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateDumpNonDiskSystemStateInfoStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateDumpNonDiskSystemStateInfoStatusModel
Public Class SystemStateDumpNonDiskSystemStateInfoStatusModel
public ref class SystemStateDumpNonDiskSystemStateInfoStatusModel
type SystemStateDumpNonDiskSystemStateInfoStatusModel =  class end

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateDumpNonDiskSystemStateInfoStatusModel | Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatusModel class
Top
Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.
Public property | Log | Gets or sets the log.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateDumpNonDiskSystemStateInfoStatusModel Constructor

Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateDumpNonDiskSystemStateInfoStatusModel()
Public Sub New
public:
SystemStateDumpNonDiskSystemStateInfoStatusModel()
new : unit -> SystemStateDumpNonDiskSystemStateInfoStatusModel
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Properties

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.
Public property | Log | Gets or sets the log.
Top
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel.Complete Property

SystemStateDumpNonDiskSystemStateInfoStatusModelComplete Property

Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Complete { get; set; }
Public Property Complete As Boolean
    Get
    Set
public:
property bool Complete {
    bool get ();
    void set (bool value);
}
member Complete : bool with get, set

Property Value

Type: Boolean
true if complete; otherwise, false.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel.Log Property

SystemStateDumpNonDiskSystemStateInfoStatusModelLog Property

Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Log { get; set; }
Public Property Log As String
    Get
    Set
public:
property String^ Log {
    String^ get ();
    void set (String^ value);
}
member Log : string with get, set

Property Value

Type: String
The log.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Methods

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStatePathModel Class

System state path.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStatePathModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStatePathModel
Public NotInheritable Class SystemStatePathModel
public ref class SystemStatePathModel sealed
[<SealedAttribute>]
type SystemStatePathModel =  class end

The SystemStatePathModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStatePathModel | Initializes a new instance of the SystemStatePathModel class
Top
Properties
 | Name | Description
Public property | Path | Gets or sets the path.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStatePathModel Constructor

Initializes a new instance of the SystemStatePathModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStatePathModel()
Public Sub New
public:
SystemStatePathModel()
new : unit -> SystemStatePathModel
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel Properties

The SystemStatePathModel type exposes the following members.

Properties
 | Name | Description
Public property | Path | Gets or sets the path.
Top
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel.Path Property

SystemStatePathModelPath Property

Gets or sets the path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel Methods

The SystemStatePathModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStatePathModel Class


SystemStatePropertyValueModel Class

System state property.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStatePropertyValueModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStatePropertyValueModel
Public NotInheritable Class SystemStatePropertyValueModel
public ref class SystemStatePropertyValueModel sealed
[<SealedAttribute>]
type SystemStatePropertyValueModel =  class end

The SystemStatePropertyValueModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStatePropertyValueModel | Initializes a new instance of the SystemStatePropertyValueModel class
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStatePropertyValueModel Constructor

Initializes a new instance of the SystemStatePropertyValueModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStatePropertyValueModel()
Public Sub New
public:
SystemStatePropertyValueModel()
new : unit -> SystemStatePropertyValueModel
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel Properties

The SystemStatePropertyValueModel type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel.Value Property

SystemStatePropertyValueModelValue Property

Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel Methods

The SystemStatePropertyValueModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStatePropertyValueModel Class


SystemStateVerificationResultModel Class

System state verification result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateVerificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateVerificationResultModel
Public Class SystemStateVerificationResultModel
public ref class SystemStateVerificationResultModel
type SystemStateVerificationResultModel =  class end

The SystemStateVerificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationResultModel | Initializes a new instance of the SystemStateVerificationResultModel class
Top
Properties
 | Name | Description
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateVerificationResultModel Constructor

Initializes a new instance of the SystemStateVerificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationResultModel()
Public Sub New
public:
SystemStateVerificationResultModel()
new : unit -> SystemStateVerificationResultModel
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel Properties

The SystemStateVerificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel.IsCompatible Property

SystemStateVerificationResultModelIsCompatible Property

Gets or sets a value indicating whether the system state is compatible.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatible { get; set; }
Public Property IsCompatible As Boolean
    Get
    Set
public:
property bool IsCompatible {
    bool get ();
    void set (bool value);
}
member IsCompatible : bool with get, set

Property Value

Type: Boolean
if the system state is compatible; otherwise, .
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel.ValidationResults Property

SystemStateVerificationResultModelValidationResults Property

Gets or sets the validation results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationStepModel[] ValidationResults { get; set; }
Public Property ValidationResults As SystemStateVerificationStepModel()
    Get
    Set
public:
property array<SystemStateVerificationStepModel^>^ ValidationResults {
    array<SystemStateVerificationStepModel^>^ get ();
    void set (array<SystemStateVerificationStepModel^>^ value);
}
member ValidationResults : SystemStateVerificationStepModel[] with get, set

Property Value

Type: SystemStateVerificationStepModel
The validation results.
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel Methods

The SystemStateVerificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationStepModel Class

System state verification step.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateVerificationStepModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateVerificationStepModel
Public Class SystemStateVerificationStepModel
public ref class SystemStateVerificationStepModel
type SystemStateVerificationStepModel =  class end

The SystemStateVerificationStepModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationStepModel | Initializes a new instance of the SystemStateVerificationStepModel class
Top
Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateVerificationStepModel Constructor

Initializes a new instance of the SystemStateVerificationStepModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationStepModel()
Public Sub New
public:
SystemStateVerificationStepModel()
new : unit -> SystemStateVerificationStepModel
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel Properties

The SystemStateVerificationStepModel type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Message Property

SystemStateVerificationStepModelMessage Property

Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Name Property

SystemStateVerificationStepModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Source Property

SystemStateVerificationStepModelSource Property

Gets or sets the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
The source.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Status Property

SystemStateVerificationStepModelStatus Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
member Status : VerificationStatus with get, set

Property Value

Type: VerificationStatus
The state.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Target Property

SystemStateVerificationStepModelTarget Property

Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Target { get; set; }
Public Property Target As String
    Get
    Set
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}
member Target : string with get, set

Property Value

Type: String
The target.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Task Property

SystemStateVerificationStepModelTask Property

Gets or sets the task.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long Task { get; set; }
Public Property Task As Long
    Get
    Set
public:
property long long Task {
    long long get ();
    void set (long long value);
}
member Task : int64 with get, set

Property Value

Type: Int64
The task.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel Methods

The SystemStateVerificationStepModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateVerificationStepModel Class


TaskParametersModel Class

Specifies a script or executable to be run along with its corresponding command-line arguments.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTaskParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class TaskParametersModel
Public NotInheritable Class TaskParametersModel
public ref class TaskParametersModel sealed
[<SealedAttribute>]
type TaskParametersModel =  class end

The TaskParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | TaskParametersModel | Initializes a new instance of the TaskParametersModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets a comma-separated list of valid arguments required to execute the script.
Public property | Script | Gets or sets the full path and file name of the script.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TaskParametersModel Constructor

Initializes a new instance of the TaskParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel()
Public Sub New
public:
TaskParametersModel()
new : unit -> TaskParametersModel
See Also

Reference

TaskParametersModel Class


TaskParametersModel Properties

The TaskParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets a comma-separated list of valid arguments required to execute the script.
Public property | Script | Gets or sets the full path and file name of the script.
Top
See Also

Reference

TaskParametersModel Class


TaskParametersModel.Arguments Property

TaskParametersModelArguments Property

Gets or sets a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The command-line arguments.
See Also

Reference

TaskParametersModel Class


TaskParametersModel.Script Property

TaskParametersModelScript Property

Gets or sets the full path and file name of the script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}
member Script : string with get, set

Property Value

Type: String
See Also

Reference

TaskParametersModel Class


TaskParametersModel Methods

The TaskParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TaskParametersModel Class


UpdateCredentialsModel Class

Information required to update the credentials for a job
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUpdateCredentialsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class UpdateCredentialsModel
Public NotInheritable Class UpdateCredentialsModel
public ref class UpdateCredentialsModel sealed
[<SealedAttribute>]
type UpdateCredentialsModel =  class end

The UpdateCredentialsModel type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCredentialsModel | Initializes a new instance of the UpdateCredentialsModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UpdateCredentialsModel Constructor

Initializes a new instance of the UpdateCredentialsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UpdateCredentialsModel()
Public Sub New
public:
UpdateCredentialsModel()
new : unit -> UpdateCredentialsModel
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel Properties

The UpdateCredentialsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Top
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel.JobCredentials Property

UpdateCredentialsModelJobCredentials Property

Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The job credentials.
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel.JobOptions Property

UpdateCredentialsModelJobOptions Property

Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The job options.
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel Methods

The UpdateCredentialsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCredentialsModel Class


UsageDataModel Class

Usage data.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUsageDataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class UsageDataModel
Public Class UsageDataModel
public ref class UsageDataModel
type UsageDataModel =  class end

The UsageDataModel type exposes the following members.

Constructors
 | Name | Description
Public method | UsageDataModel | Initializes a new instance of the UsageDataModel class
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | NextCollectionTime | Gets or sets the next collection time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UsageDataModel Constructor

Initializes a new instance of the UsageDataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UsageDataModel()
Public Sub New
public:
UsageDataModel()
new : unit -> UsageDataModel
See Also

Reference

UsageDataModel Class


UsageDataModel Properties

The UsageDataModel type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | NextCollectionTime | Gets or sets the next collection time.
Top
See Also

Reference

UsageDataModel Class


UsageDataModel.Data Property

UsageDataModelData Property

Gets or sets the data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public List<JobUsageDataModel> Data { get; set; }
Public Property Data As List(Of JobUsageDataModel)
    Get
    Set
public:
property List<JobUsageDataModel^>^ Data {
    List<JobUsageDataModel^>^ get ();
    void set (List<JobUsageDataModel^>^ value);
}
member Data : List<JobUsageDataModel> with get, set

Property Value

Type: List JobUsageDataModel
The data.
See Also

Reference

UsageDataModel Class


UsageDataModel.NextCollectionTime Property

UsageDataModelNextCollectionTime Property

Gets or sets the next collection time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset NextCollectionTime { get; set; }
Public Property NextCollectionTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextCollectionTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member NextCollectionTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The next collection time.
See Also

Reference

UsageDataModel Class


UsageDataModel Methods

The UsageDataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UsageDataModel Class


UVRAPersistedStateModel Class

UVRA persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUVRAPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class UVRAPersistedStateModel
Public NotInheritable Class UVRAPersistedStateModel
public ref class UVRAPersistedStateModel sealed
[<SealedAttribute>]
type UVRAPersistedStateModel =  class end

The UVRAPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | UVRAPersistedStateModel | Initializes a new instance of the UVRAPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailoverTime | Gets or sets the failover time.
Public property | ReplicaNics | Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.
Public property | SourceISCSIChapPassword | Gets or sets the iSCSI CHAP password used in mapping the source disk.
Public property | SourceISCSIChapUsername | Gets or sets the iSCSI CHAP username used in mapping the source disk.
Public property | SourceISCSITargetName | Gets or sets the iSCSI target name name used in mapping the source disk.
Public property | SourceMachineInfo | Gets or sets the machine info.
Public property | StartTime | Gets or sets the Time the job was started.
Public property | State | Gets or sets the state.
Public property | StopTime | Gets or sets the Time the job was stopped.
Public property | VolumePersistedState | Gets or sets the volume persisted state.
Public property | VRAVirtualizationConnectionInfo | Gets or sets the VRA engine connection info.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UVRAPersistedStateModel Constructor

Initializes a new instance of the UVRAPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UVRAPersistedStateModel()
Public Sub New
public:
UVRAPersistedStateModel()
new : unit -> UVRAPersistedStateModel
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel Properties

The UVRAPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverTime | Gets or sets the failover time.
Public property | ReplicaNics | Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.
Public property | SourceISCSIChapPassword | Gets or sets the iSCSI CHAP password used in mapping the source disk.
Public property | SourceISCSIChapUsername | Gets or sets the iSCSI CHAP username used in mapping the source disk.
Public property | SourceISCSITargetName | Gets or sets the iSCSI target name name used in mapping the source disk.
Public property | SourceMachineInfo | Gets or sets the machine info.
Public property | StartTime | Gets or sets the Time the job was started.
Public property | State | Gets or sets the state.
Public property | StopTime | Gets or sets the Time the job was stopped.
Public property | VolumePersistedState | Gets or sets the volume persisted state.
Public property | VRAVirtualizationConnectionInfo | Gets or sets the VRA engine connection info.
Top
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.FailoverTime Property

UVRAPersistedStateModelFailoverTime Property

Gets or sets the failover time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTime FailoverTime { get; set; }
Public Property FailoverTime As DateTime
    Get
    Set
public:
property DateTime FailoverTime {
    DateTime get ();
    void set (DateTime value);
}
member FailoverTime : DateTime with get, set

Property Value

Type: DateTime
The failover time.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.ReplicaNics Property

UVRAPersistedStateModelReplicaNics Property

Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VRAInternalVirtualNetworkInterfaceInfoModel[] ReplicaNics { get; set; }
Public Property ReplicaNics As VRAInternalVirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ ReplicaNics {
    array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ value);
}
member ReplicaNics : VRAInternalVirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VRAInternalVirtualNetworkInterfaceInfoModel
The replica nics.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSIChapPassword Property

UVRAPersistedStateModelSourceISCSIChapPassword Property

Gets or sets the iSCSI CHAP password used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSIChapPassword { get; set; }
Public Property SourceISCSIChapPassword As String
    Get
    Set
public:
property String^ SourceISCSIChapPassword {
    String^ get ();
    void set (String^ value);
}
member SourceISCSIChapPassword : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSIChapUsername Property

UVRAPersistedStateModelSourceISCSIChapUsername Property

Gets or sets the iSCSI CHAP username used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSIChapUsername { get; set; }
Public Property SourceISCSIChapUsername As String
    Get
    Set
public:
property String^ SourceISCSIChapUsername {
    String^ get ();
    void set (String^ value);
}
member SourceISCSIChapUsername : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSITargetName Property

UVRAPersistedStateModelSourceISCSITargetName Property

Gets or sets the iSCSI target name name used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSITargetName { get; set; }
Public Property SourceISCSITargetName As String
    Get
    Set
public:
property String^ SourceISCSITargetName {
    String^ get ();
    void set (String^ value);
}
member SourceISCSITargetName : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceMachineInfo Property

UVRAPersistedStateModelSourceMachineInfo Property

Gets or sets the machine info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public MachineInfoModel SourceMachineInfo { get; set; }
Public Property SourceMachineInfo As MachineInfoModel
    Get
    Set
public:
property MachineInfoModel^ SourceMachineInfo {
    MachineInfoModel^ get ();
    void set (MachineInfoModel^ value);
}
member SourceMachineInfo : MachineInfoModel with get, set

Property Value

Type: MachineInfoModel
The machine info.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.StartTime Property

UVRAPersistedStateModelStartTime Property

Gets or sets the Time the job was started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.State Property

UVRAPersistedStateModelState Property

Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel State { get; set; }
Public Property State As JobStateModel
    Get
    Set
public:
property JobStateModel^ State {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member State : JobStateModel with get, set

Property Value

Type: JobStateModel
The state.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.StopTime Property

UVRAPersistedStateModelStopTime Property

Gets or sets the Time the job was stopped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public DateTime StopTime { get; set; }
Public Property StopTime As DateTime
    Get
    Set
public:
property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}
member StopTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.VolumePersistedState Property

UVRAPersistedStateModelVolumePersistedState Property

Gets or sets the volume persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UVRAVolumePersistedStateModel[] VolumePersistedState { get; set; }
Public Property VolumePersistedState As UVRAVolumePersistedStateModel()
    Get
    Set
public:
property array<UVRAVolumePersistedStateModel^>^ VolumePersistedState {
    array<UVRAVolumePersistedStateModel^>^ get ();
    void set (array<UVRAVolumePersistedStateModel^>^ value);
}
member VolumePersistedState : UVRAVolumePersistedStateModel[] with get, set

Property Value

Type: UVRAVolumePersistedStateModel
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.VRAVirtualizationConnectionInfo Property

UVRAPersistedStateModelVRAVirtualizationConnectionInfo Property

Gets or sets the VRA engine connection info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualizationConnectionInfoModel VRAVirtualizationConnectionInfo { get; set; }
Public Property VRAVirtualizationConnectionInfo As VirtualizationConnectionInfoModel
    Get
    Set
public:
property VirtualizationConnectionInfoModel^ VRAVirtualizationConnectionInfo {
    VirtualizationConnectionInfoModel^ get ();
    void set (VirtualizationConnectionInfoModel^ value);
}
member VRAVirtualizationConnectionInfo : VirtualizationConnectionInfoModel with get, set

Property Value

Type: VirtualizationConnectionInfoModel
The VRA engine connection info.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel Methods

The UVRAPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UVRAPersistedStateModel Class


UVRAVolumePersistedStateModel Class

UVRA volume persisted state.
Inheritance Hierarchy
SystemObject
ProtectableItemModel
PhysicalItemModel
VolumeModel
VolumeOptionsModel
DoubleTake.Web.ModelsUVRAVolumePersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class UVRAVolumePersistedStateModel : VolumeOptionsModel
Public NotInheritable Class UVRAVolumePersistedStateModel
    Inherits VolumeOptionsModel
public ref class UVRAVolumePersistedStateModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type UVRAVolumePersistedStateModel =
    class
        inherit VolumeOptionsModel
    end

The UVRAVolumePersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | UVRAVolumePersistedStateModel | Initializes a new instance of the UVRAVolumePersistedStateModel class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | (Inherited from PhysicalItemModel.)
Public property | ClassName | (Inherited from PhysicalItemModel.)
Public property | CreationTime | (Inherited from PhysicalItemModel.)
Public property | DesiredSize | (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | (Inherited from PhysicalItemModel.)
Public property | Id | (Inherited from ProtectableItemModel.)
Public property | IsContainer | (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | (Inherited from ProtectableItemModel.)
Public property | IsSupported | (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | (Inherited from PhysicalItemModel.)
Public property | ItemType | (Inherited from ProtectableItemModel.)
Public property | Label | (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | (Inherited from PhysicalItemModel.)
Public property | Metadata | (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | (Inherited from ProtectableItemModel.)
Public property | Path | (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | (Inherited from PhysicalItemModel.)
Public property | Size | (Inherited from PhysicalItemModel.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | (Inherited from VolumeOptionsModel.)
Public property | VolumeType | (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
VolumeOptionsModel


UVRAVolumePersistedStateModel Constructor

Initializes a new instance of the UVRAVolumePersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public UVRAVolumePersistedStateModel()
Public Sub New
public:
UVRAVolumePersistedStateModel()
new : unit -> UVRAVolumePersistedStateModel
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel Properties

The UVRAVolumePersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | (Inherited from PhysicalItemModel.)
Public property | ClassName | (Inherited from PhysicalItemModel.)
Public property | CreationTime | (Inherited from PhysicalItemModel.)
Public property | DesiredSize | (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | (Inherited from PhysicalItemModel.)
Public property | Id | (Inherited from ProtectableItemModel.)
Public property | IsContainer | (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | (Inherited from ProtectableItemModel.)
Public property | IsSupported | (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | (Inherited from PhysicalItemModel.)
Public property | ItemType | (Inherited from ProtectableItemModel.)
Public property | Label | (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | (Inherited from PhysicalItemModel.)
Public property | Metadata | (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | (Inherited from ProtectableItemModel.)
Public property | Path | (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | (Inherited from PhysicalItemModel.)
Public property | Size | (Inherited from PhysicalItemModel.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | (Inherited from VolumeOptionsModel.)
Public property | VolumeType | (Inherited from PhysicalItemModel.)
Top
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ApplianceSCSIBus Property

UVRAVolumePersistedStateModelApplianceSCSIBus Property

Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
member ApplianceSCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ApplianceSCSIUnitNumber Property

UVRAVolumePersistedStateModelApplianceSCSIUnitNumber Property

Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ApplianceSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DeviceID Property

UVRAVolumePersistedStateModelDeviceID Property

Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
member DeviceID : string with get, set

Property Value

Type: String
The device ID.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DriveIndex Property

UVRAVolumePersistedStateModelDriveIndex Property

Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
member DriveIndex : int with get, set

Property Value

Type: Int32
The index of the drive.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DriveName Property

UVRAVolumePersistedStateModelDriveName Property

Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
member DriveName : string with get, set

Property Value

Type: String
The index of the drive.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.MountPoint Property

UVRAVolumePersistedStateModelMountPoint Property

Gets or sets the mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
The mount point.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.OriginalPath Property

UVRAVolumePersistedStateModelOriginalPath Property

Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Property Value

Type: String
The original path.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.PNPDeviceID Property

UVRAVolumePersistedStateModelPNPDeviceID Property

Gets or sets the PNP device ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
member PNPDeviceID : string with get, set

Property Value

Type: String
The PNP device ID.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReplicaVmSCSIBus Property

UVRAVolumePersistedStateModelReplicaVmSCSIBus Property

Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIBus : int with get, set

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReplicaVmSCSIUnitNumber Property

UVRAVolumePersistedStateModelReplicaVmSCSIUnitNumber Property

Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReverseVolumeSignature Property

UVRAVolumePersistedStateModelReverseVolumeSignature Property

Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ReverseVolumeSignature : byte[] with get, set

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.SourceISCSIBus Property

UVRAVolumePersistedStateModelSourceISCSIBus Property

Gets or sets the iSCSI bus number used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int SourceISCSIBus { get; set; }
Public Property SourceISCSIBus As Integer
    Get
    Set
public:
property int SourceISCSIBus {
    int get ();
    void set (int value);
}
member SourceISCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.SourceISCSIUnitNumber Property

UVRAVolumePersistedStateModelSourceISCSIUnitNumber Property

Gets or sets the iSCSI unit number used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int SourceISCSIUnitNumber { get; set; }
Public Property SourceISCSIUnitNumber As Integer
    Get
    Set
public:
property int SourceISCSIUnitNumber {
    int get ();
    void set (int value);
}
member SourceISCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.VirtualDiskFilename Property

UVRAVolumePersistedStateModelVirtualDiskFilename Property

Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskFilename : string with get, set

Property Value

Type: String
The virtual disk filename.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.VolumeName Property

UVRAVolumePersistedStateModelVolumeName Property

Gets or sets the name of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
member VolumeName : string with get, set

Property Value

Type: String
The name of the volume.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel Methods

The UVRAVolumePersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UVRAVolumePersistedStateModel Class


V2VVirtualMachineModel Class

Describes a virtual machine to be protected by the V2V feature.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsV2VVirtualMachineModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class V2VVirtualMachineModel
Public NotInheritable Class V2VVirtualMachineModel
public ref class V2VVirtualMachineModel sealed
[<SealedAttribute>]
type V2VVirtualMachineModel =  class end

The V2VVirtualMachineModel type exposes the following members.

Constructors
 | Name | Description
Public method | V2VVirtualMachineModel | Initializes a new instance of the V2VVirtualMachineModel class
Top
Properties
 | Name | Description
Public property | ActivationCode | Gets or sets the license key on the virtual machine.
Public property | BiosGuid | Gets or sets the BIOS unique ID for the virtual machine.
Public property | CPUs | Gets or sets the number of processors on the virtual machine.
Public property | Credentials | Gets or sets the credentials used to access the virtual machine.
Public property | DiskFormat | Gets or sets the disk format.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the guest operating system.
Public property | Guid | Gets or sets the unique ID of the virtual machine.
Public property | Memory | Gets or sets the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | Gets or sets the unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | Gets or sets the desired NIC configuration on the replica virtual machine.
Public property | Path | Gets or sets the path of the original source virtual machine.
Public property | SnapshotPath | Gets or sets the location of the virtual machine's snapshot files.
Public property | SystemDirectory | Gets or sets the location of the system directory.
Public property | TargetPath | Gets or sets the target path. Do not use this property. Double-Take uses it internally.
Public property | Volumes | Gets or sets a volume to protect and any changes to its base configuration.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


V2VVirtualMachineModel Constructor

Initializes a new instance of the V2VVirtualMachineModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public V2VVirtualMachineModel()
Public Sub New
public:
V2VVirtualMachineModel()
new : unit -> V2VVirtualMachineModel
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel Properties

The V2VVirtualMachineModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode | Gets or sets the license key on the virtual machine.
Public property | BiosGuid | Gets or sets the BIOS unique ID for the virtual machine.
Public property | CPUs | Gets or sets the number of processors on the virtual machine.
Public property | Credentials | Gets or sets the credentials used to access the virtual machine.
Public property | DiskFormat | Gets or sets the disk format.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the guest operating system.
Public property | Guid | Gets or sets the unique ID of the virtual machine.
Public property | Memory | Gets or sets the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | Gets or sets the unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | Gets or sets the desired NIC configuration on the replica virtual machine.
Public property | Path | Gets or sets the path of the original source virtual machine.
Public property | SnapshotPath | Gets or sets the location of the virtual machine's snapshot files.
Public property | SystemDirectory | Gets or sets the location of the system directory.
Public property | TargetPath | Gets or sets the target path. Do not use this property. Double-Take uses it internally.
Public property | Volumes | Gets or sets a volume to protect and any changes to its base configuration.
Top
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.ActivationCode Property

V2VVirtualMachineModelActivationCode Property

Gets or sets the license key on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ActivationCode { get; set; }
Public Property ActivationCode As String
    Get
    Set
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}
member ActivationCode : string with get, set

Property Value

Type: String
The activation code.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.BiosGuid Property

V2VVirtualMachineModelBiosGuid Property

Gets or sets the BIOS unique ID for the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
The BIOS GUID.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.CPUs Property

V2VVirtualMachineModelCPUs Property

Gets or sets the number of processors on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int CPUs { get; set; }
Public Property CPUs As Integer
    Get
    Set
public:
property int CPUs {
    int get ();
    void set (int value);
}
member CPUs : int with get, set

Property Value

Type: Int32
The CP us.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Credentials Property

V2VVirtualMachineModelCredentials Property

Gets or sets the credentials used to access the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credentials { get; set; }
Public Property Credentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The credentials.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.DiskFormat Property

V2VVirtualMachineModelDiskFormat Property

Gets or sets the disk format.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
member DiskFormat : string with get, set

Property Value

Type: String
The disk format.
Remarks
Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.DisplayName Property

V2VVirtualMachineModelDisplayName Property

Gets or sets the virtual machine display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
The display name.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.GuestOS Property

V2VVirtualMachineModelGuestOS Property

Gets or sets the guest operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
The guest OS.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Guid Property

V2VVirtualMachineModelGuid Property

Gets or sets the unique ID of the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The GUID.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Memory Property

V2VVirtualMachineModelMemory Property

Gets or sets the amount of memory, in bytes, on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
The memory.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.NetworkId Property

V2VVirtualMachineModelNetworkId Property

Gets or sets the unique ID of the virtual machine network.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.NetworkInterfaceInfo Property

V2VVirtualMachineModelNetworkInterfaceInfo Property

Gets or sets the desired NIC configuration on the replica virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] NetworkInterfaceInfo { get; set; }
Public Property NetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ NetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member NetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
The network interface info.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Path Property

V2VVirtualMachineModelPath Property

Gets or sets the path of the original source virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.SnapshotPath Property

V2VVirtualMachineModelSnapshotPath Property

Gets or sets the location of the virtual machine's snapshot files.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotPath { get; set; }
Public Property SnapshotPath As String
    Get
    Set
public:
property String^ SnapshotPath {
    String^ get ();
    void set (String^ value);
}
member SnapshotPath : string with get, set

Property Value

Type: String
The snapshot path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.SystemDirectory Property

V2VVirtualMachineModelSystemDirectory Property

Gets or sets the location of the system directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
member SystemDirectory : string with get, set

Property Value

Type: String
The system directory.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.TargetPath Property

V2VVirtualMachineModelTargetPath Property

Gets or sets the target path. Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
member TargetPath : string with get, set

Property Value

Type: String
The target path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Volumes Property

V2VVirtualMachineModelVolumes Property

Gets or sets a volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel[] Volumes { get; set; }
Public Property Volumes As VolumeOptionsModel()
    Get
    Set
public:
property array<VolumeOptionsModel^>^ Volumes {
    array<VolumeOptionsModel^>^ get ();
    void set (array<VolumeOptionsModel^>^ value);
}
member Volumes : VolumeOptionsModel[] with get, set

Property Value

Type: VolumeOptionsModel
The volumes.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel Methods

The V2VVirtualMachineModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

V2VVirtualMachineModel Class


VHDMappingModel Class

Represents source and target VHD mappings
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVHDMappingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VHDMappingModel
Public NotInheritable Class VHDMappingModel
public ref class VHDMappingModel sealed
[<SealedAttribute>]
type VHDMappingModel =  class end

The VHDMappingModel type exposes the following members.

Constructors
 | Name | Description
Public method | VHDMappingModel | Initializes a new instance of the VHDMappingModel class
Top
Properties
 | Name | Description
Public property | SourceVHD | Gets or sets the source .vhd file.
Public property | TargetVHD | Gets or sets the target .vhd file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VHDMappingModel Constructor

Initializes a new instance of the VHDMappingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VHDMappingModel()
Public Sub New
public:
VHDMappingModel()
new : unit -> VHDMappingModel
See Also

Reference

VHDMappingModel Class


VHDMappingModel Properties

The VHDMappingModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceVHD | Gets or sets the source .vhd file.
Public property | TargetVHD | Gets or sets the target .vhd file.
Top
See Also

Reference

VHDMappingModel Class


VHDMappingModel.SourceVHD Property

VHDMappingModelSourceVHD Property

Gets or sets the source .vhd file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceVHD { get; set; }
Public Property SourceVHD As String
    Get
    Set
public:
property String^ SourceVHD {
    String^ get ();
    void set (String^ value);
}
member SourceVHD : string with get, set

Property Value

Type: String
See Also

Reference

VHDMappingModel Class


VHDMappingModel.TargetVHD Property

VHDMappingModelTargetVHD Property

Gets or sets the target .vhd file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVHD { get; set; }
Public Property TargetVHD As String
    Get
    Set
public:
property String^ TargetVHD {
    String^ get ();
    void set (String^ value);
}
member TargetVHD : string with get, set

Property Value

Type: String
See Also

Reference

VHDMappingModel Class


VHDMappingModel Methods

The VHDMappingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VHDMappingModel Class


VirtualizationConnectionInfoModel Class

Virtualization connection information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualizationConnectionInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualizationConnectionInfoModel
Public NotInheritable Class VirtualizationConnectionInfoModel
public ref class VirtualizationConnectionInfoModel sealed
[<SealedAttribute>]
type VirtualizationConnectionInfoModel =  class end

The VirtualizationConnectionInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizationConnectionInfoModel | Initializes a new instance of the VirtualizationConnectionInfoModel class
Top
Properties
 | Name | Description
Public property | Attach | Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualizationConnectionInfoModel Constructor

Initializes a new instance of the VirtualizationConnectionInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualizationConnectionInfoModel()
Public Sub New
public:
VirtualizationConnectionInfoModel()
new : unit -> VirtualizationConnectionInfoModel
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel Properties

The VirtualizationConnectionInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Attach | Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.Attach Property

VirtualizationConnectionInfoModelAttach Property

Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool Attach { get; set; }
Public Property Attach As Boolean
    Get
    Set
public:
property bool Attach {
    bool get ();
    void set (bool value);
}
member Attach : bool with get, set

Property Value

Type: Boolean
if attach; otherwise, .
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.MonitorId Property

VirtualizationConnectionInfoModelMonitorId Property

Gets or sets the monitor id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
The monitor id.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.PathTransformations Property

VirtualizationConnectionInfoModelPathTransformations Property

Gets or sets the path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.ProcessHardlinks Property

VirtualizationConnectionInfoModelProcessHardlinks Property

Gets or sets a value indicating whether Double-Take should process hardlinks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool ProcessHardlinks { get; set; }
Public Property ProcessHardlinks As Boolean
    Get
    Set
public:
property bool ProcessHardlinks {
    bool get ();
    void set (bool value);
}
member ProcessHardlinks : bool with get, set

Property Value

Type: Boolean
true if Double-Take should process hardlinks; otherwise, false.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.RepsetName Property

VirtualizationConnectionInfoModelRepsetName Property

Gets or sets the name of the repset.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string RepsetName { get; set; }
Public Property RepsetName As String
    Get
    Set
public:
property String^ RepsetName {
    String^ get ();
    void set (String^ value);
}
member RepsetName : string with get, set

Property Value

Type: String
The name of the repset.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel Methods

The VirtualizationConnectionInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualMachineResourceInfoModel Class

Virtual machine resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualMachineResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualMachineResourceInfoModel
Public NotInheritable Class VirtualMachineResourceInfoModel
public ref class VirtualMachineResourceInfoModel sealed
[<SealedAttribute>]
type VirtualMachineResourceInfoModel =  class end

The VirtualMachineResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualMachineResourceInfoModel | Initializes a new instance of the VirtualMachineResourceInfoModel class
Top
Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets cluster VM configuration resource name.
Public property | VmGuid | Gets or sets cluster VM GUID.
Public property | VmResourceName | Gets or sets cluster VM resource name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualMachineResourceInfoModel Constructor

Initializes a new instance of the VirtualMachineResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualMachineResourceInfoModel()
Public Sub New
public:
VirtualMachineResourceInfoModel()
new : unit -> VirtualMachineResourceInfoModel
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel Properties

The VirtualMachineResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets cluster VM configuration resource name.
Public property | VmGuid | Gets or sets cluster VM GUID.
Public property | VmResourceName | Gets or sets cluster VM resource name.
Top
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmCfgResourceName Property

VirtualMachineResourceInfoModelVmCfgResourceName Property

Gets or sets cluster VM configuration resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmCfgResourceName { get; set; }
Public Property VmCfgResourceName As String
    Get
    Set
public:
property String^ VmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member VmCfgResourceName : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmGuid Property

VirtualMachineResourceInfoModelVmGuid Property

Gets or sets cluster VM GUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmGuid { get; set; }
Public Property VmGuid As String
    Get
    Set
public:
property String^ VmGuid {
    String^ get ();
    void set (String^ value);
}
member VmGuid : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmResourceName Property

VirtualMachineResourceInfoModelVmResourceName Property

Gets or sets cluster VM resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmResourceName { get; set; }
Public Property VmResourceName As String
    Get
    Set
public:
property String^ VmResourceName {
    String^ get ();
    void set (String^ value);
}
member VmResourceName : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel Methods

The VirtualMachineResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualSwitchConfigQueryInputModel Class

Inputs for a Virtual Switch monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VirtualSwitchConfigQueryInputModel : QueryInputModel
Public Class VirtualSwitchConfigQueryInputModel
    Inherits QueryInputModel
public ref class VirtualSwitchConfigQueryInputModel : public QueryInputModel
type VirtualSwitchConfigQueryInputModel =
    class
        inherit QueryInputModel
    end

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryInputModel | Initializes a new instance of the VirtualSwitchConfigQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VirtualSwitchConfigQueryInputModel Constructor

Initializes a new instance of the VirtualSwitchConfigQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchConfigQueryInputModel()
Public Sub New
public:
VirtualSwitchConfigQueryInputModel()
new : unit -> VirtualSwitchConfigQueryInputModel
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel Properties

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryInputModelVirtualSwitchInfoColl Property

Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel.VmId Property

VirtualSwitchConfigQueryInputModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel Methods

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryResultModel Class

Represents the results of a Virtual Switch config query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VirtualSwitchConfigQueryResultModel : QueryResultModel
Public Class VirtualSwitchConfigQueryResultModel
    Inherits QueryResultModel
public ref class VirtualSwitchConfigQueryResultModel : public QueryResultModel
type VirtualSwitchConfigQueryResultModel =
    class
        inherit QueryResultModel
    end

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryResultModel | Initializes a new instance of the VirtualSwitchConfigQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VirtualSwitchConfigQueryResultModel Constructor

Initializes a new instance of the VirtualSwitchConfigQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchConfigQueryResultModel()
Public Sub New
public:
VirtualSwitchConfigQueryResultModel()
new : unit -> VirtualSwitchConfigQueryResultModel
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel Properties

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryResultModelVirtualSwitchInfoColl Property

Gets or sets the virtual switch information collection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information collection.
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel.VmId Property

VirtualSwitchConfigQueryResultModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel Methods

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VmCfgSimpleInfoModel Class

VM configuration simple information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmCfgSimpleInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VmCfgSimpleInfoModel
Public Class VmCfgSimpleInfoModel
public ref class VmCfgSimpleInfoModel
type VmCfgSimpleInfoModel =  class end

The VmCfgSimpleInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmCfgSimpleInfoModel | Initializes a new instance of the VmCfgSimpleInfoModel class
Top
Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the bios unique identifier.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | GuestDNSName | Gets or sets the name of the guest DNS.
Public property | GuestOS | Gets or sets the guest os.
Public property | Name | Gets or sets the name.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Uuid | Gets or sets the UUID.
Public property | VmHealth | Gets or sets the vm health.
Public property | VmState | Gets or sets the state of the vm.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmCfgSimpleInfoModel Constructor

Initializes a new instance of the VmCfgSimpleInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmCfgSimpleInfoModel()
Public Sub New
public:
VmCfgSimpleInfoModel()
new : unit -> VmCfgSimpleInfoModel
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel Properties

The VmCfgSimpleInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the bios unique identifier.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | GuestDNSName | Gets or sets the name of the guest DNS.
Public property | GuestOS | Gets or sets the guest os.
Public property | Name | Gets or sets the name.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Uuid | Gets or sets the UUID.
Public property | VmHealth | Gets or sets the vm health.
Public property | VmState | Gets or sets the state of the vm.
Top
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.BiosGuid Property

VmCfgSimpleInfoModelBiosGuid Property

Gets or sets the bios unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string BiosGuid { get; set; }
Public Property BiosGuid As String
    Get
    Set
public:
property String^ BiosGuid {
    String^ get ();
    void set (String^ value);
}
member BiosGuid : string with get, set

Property Value

Type: String
The bios unique identifier.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.ExternalDataRoot Property

VmCfgSimpleInfoModelExternalDataRoot Property

Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.GuestDNSName Property

VmCfgSimpleInfoModelGuestDNSName Property

Gets or sets the name of the guest DNS.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string GuestDNSName { get; set; }
Public Property GuestDNSName As String
    Get
    Set
public:
property String^ GuestDNSName {
    String^ get ();
    void set (String^ value);
}
member GuestDNSName : string with get, set

Property Value

Type: String
The name of the guest DNS.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.GuestOS Property

VmCfgSimpleInfoModelGuestOS Property

Gets or sets the guest os.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
The guest os.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.Name Property

VmCfgSimpleInfoModelName Property

Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.SnapshotDataRoot Property

VmCfgSimpleInfoModelSnapshotDataRoot Property

Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.Uuid Property

VmCfgSimpleInfoModelUuid Property

Gets or sets the UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string Uuid { get; set; }
Public Property Uuid As String
    Get
    Set
public:
property String^ Uuid {
    String^ get ();
    void set (String^ value);
}
member Uuid : string with get, set

Property Value

Type: String
The UUID.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.VmHealth Property

VmCfgSimpleInfoModelVmHealth Property

Gets or sets the vm health.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmHealthEnum VmHealth { get; set; }
Public Property VmHealth As VmHealthEnum
    Get
    Set
public:
property VmHealthEnum VmHealth {
    VmHealthEnum get ();
    void set (VmHealthEnum value);
}
member VmHealth : VmHealthEnum with get, set

Property Value

Type: VmHealthEnum
The vm health.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.VmState Property

VmCfgSimpleInfoModelVmState Property

Gets or sets the state of the vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int VmState { get; set; }
Public Property VmState As Integer
    Get
    Set
public:
property int VmState {
    int get ();
    void set (int value);
}
member VmState : int with get, set

Property Value

Type: Int32
The state of the vm.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel Methods

The VmCfgSimpleInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmCfgSimpleInfoModel Class


VmConfigQueryInputModel Class

Query inputs for monitoring a VmConfig
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVmConfigQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VmConfigQueryInputModel : QueryInputModel
Public Class VmConfigQueryInputModel
    Inherits QueryInputModel
public ref class VmConfigQueryInputModel : public QueryInputModel
type VmConfigQueryInputModel =
    class
        inherit QueryInputModel
    end

The VmConfigQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryInputModel | Initializes a new instance of the VmConfigQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VmId | Gets or sets the VM identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VmConfigQueryInputModel Constructor

Initializes a new instance of the VmConfigQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmConfigQueryInputModel()
Public Sub New
public:
VmConfigQueryInputModel()
new : unit -> VmConfigQueryInputModel
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel Properties

The VmConfigQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VmId | Gets or sets the VM identifier.
Top
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.ExternalDataRoot Property

VmConfigQueryInputModelExternalDataRoot Property

Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.SnapshotDataRoot Property

VmConfigQueryInputModelSnapshotDataRoot Property

Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.VhdPath Property

VmConfigQueryInputModelVhdPath Property

Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.VmId Property

VmConfigQueryInputModelVmId Property

Gets or sets the VM identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The VM identifier.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel Methods

The VmConfigQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryResultModel Class

Represents the results of a Vm config query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVmConfigQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VmConfigQueryResultModel : QueryResultModel
Public Class VmConfigQueryResultModel
    Inherits QueryResultModel
public ref class VmConfigQueryResultModel : public QueryResultModel
type VmConfigQueryResultModel =
    class
        inherit QueryResultModel
    end

The VmConfigQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryResultModel | Initializes a new instance of the VmConfigQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VmConfigQueryResultModel Constructor

Initializes a new instance of the VmConfigQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmConfigQueryResultModel()
Public Sub New
public:
VmConfigQueryResultModel()
new : unit -> VmConfigQueryResultModel
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel Properties

The VmConfigQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VhdPath Property

VmConfigQueryResultModelVhdPath Property

Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VirtualSwitchInfoColl Property

VmConfigQueryResultModelVirtualSwitchInfoColl Property

Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmId Property

VmConfigQueryResultModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmSnapshotDataRoot Property

VmConfigQueryResultModelVmSnapshotDataRoot Property

Gets or sets the vm snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmSnapshotDataRoot { get; set; }
Public Property VmSnapshotDataRoot As String
    Get
    Set
public:
property String^ VmSnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member VmSnapshotDataRoot : string with get, set

Property Value

Type: String
The vm snapshot data root.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmSnapshotFileNames Property

VmConfigQueryResultModelVmSnapshotFileNames Property

Gets or sets the vm snapshot file names.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string[] VmSnapshotFileNames { get; set; }
Public Property VmSnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ VmSnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VmSnapshotFileNames : string[] with get, set

Property Value

Type: String
The vm snapshot file names.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel Methods

The VmConfigQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmConfigQueryResultModel Class


VmdkInfoModel Class

VMDK information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmdkInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VmdkInfoModel
Public NotInheritable Class VmdkInfoModel
public ref class VmdkInfoModel sealed
[<SealedAttribute>]
type VmdkInfoModel =  class end

The VmdkInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmdkInfoModel | Initializes a new instance of the VmdkInfoModel class
Top
Properties
 | Name | Description
Public property | DoDifferenceMirror | Gets or sets a value indicating whether [do difference mirror].
Public property | SourceVmdkUuid | Gets or sets the source VMDK UUID.
Public property | SourceVmUuid | Gets or sets the source VM UUID.
Public property | TargetChangeId | Gets or sets the target change identifier.
Public property | TargetDeviceKey | Gets or sets the target device key.
Public property | TargetDiskOffset | Gets or sets the target disk offset.
Public property | TargetVmdkPath | Gets or sets the target VMDK path.
Public property | TargetVmdkUuid | Gets or sets the target VMDK UUID.
Public property | TargetVmUuid | Gets or sets the target VM UUID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmdkInfoModel Constructor

Initializes a new instance of the VmdkInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmdkInfoModel()
Public Sub New
public:
VmdkInfoModel()
new : unit -> VmdkInfoModel
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel Properties

The VmdkInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | DoDifferenceMirror | Gets or sets a value indicating whether [do difference mirror].
Public property | SourceVmdkUuid | Gets or sets the source VMDK UUID.
Public property | SourceVmUuid | Gets or sets the source VM UUID.
Public property | TargetChangeId | Gets or sets the target change identifier.
Public property | TargetDeviceKey | Gets or sets the target device key.
Public property | TargetDiskOffset | Gets or sets the target disk offset.
Public property | TargetVmdkPath | Gets or sets the target VMDK path.
Public property | TargetVmdkUuid | Gets or sets the target VMDK UUID.
Public property | TargetVmUuid | Gets or sets the target VM UUID.
Top
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.DoDifferenceMirror Property

VmdkInfoModelDoDifferenceMirror Property

Gets or sets a value indicating whether [do difference mirror].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool DoDifferenceMirror { get; set; }
Public Property DoDifferenceMirror As Boolean
    Get
    Set
public:
property bool DoDifferenceMirror {
    bool get ();
    void set (bool value);
}
member DoDifferenceMirror : bool with get, set

Property Value

Type: Boolean
true if [do difference mirror]; otherwise, false.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.SourceVmdkUuid Property

VmdkInfoModelSourceVmdkUuid Property

Gets or sets the source VMDK UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceVmdkUuid { get; set; }
Public Property SourceVmdkUuid As String
    Get
    Set
public:
property String^ SourceVmdkUuid {
    String^ get ();
    void set (String^ value);
}
member SourceVmdkUuid : string with get, set

Property Value

Type: String
The source VMDK UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.SourceVmUuid Property

VmdkInfoModelSourceVmUuid Property

Gets or sets the source VM UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string SourceVmUuid { get; set; }
Public Property SourceVmUuid As String
    Get
    Set
public:
property String^ SourceVmUuid {
    String^ get ();
    void set (String^ value);
}
member SourceVmUuid : string with get, set

Property Value

Type: String
The source VM UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetChangeId Property

VmdkInfoModelTargetChangeId Property

Gets or sets the target change identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetChangeId { get; set; }
Public Property TargetChangeId As String
    Get
    Set
public:
property String^ TargetChangeId {
    String^ get ();
    void set (String^ value);
}
member TargetChangeId : string with get, set

Property Value

Type: String
The target change identifier.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetDeviceKey Property

VmdkInfoModelTargetDeviceKey Property

Gets or sets the target device key.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int TargetDeviceKey { get; set; }
Public Property TargetDeviceKey As Integer
    Get
    Set
public:
property int TargetDeviceKey {
    int get ();
    void set (int value);
}
member TargetDeviceKey : int with get, set

Property Value

Type: Int32
The target device key.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetDiskOffset Property

VmdkInfoModelTargetDiskOffset Property

Gets or sets the target disk offset.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public long TargetDiskOffset { get; set; }
Public Property TargetDiskOffset As Long
    Get
    Set
public:
property long long TargetDiskOffset {
    long long get ();
    void set (long long value);
}
member TargetDiskOffset : int64 with get, set

Property Value

Type: Int64
The target disk offset.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmdkPath Property

VmdkInfoModelTargetVmdkPath Property

Gets or sets the target VMDK path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmdkPath { get; set; }
Public Property TargetVmdkPath As String
    Get
    Set
public:
property String^ TargetVmdkPath {
    String^ get ();
    void set (String^ value);
}
member TargetVmdkPath : string with get, set

Property Value

Type: String
The target VMDK path.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmdkUuid Property

VmdkInfoModelTargetVmdkUuid Property

Gets or sets the target VMDK UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmdkUuid { get; set; }
Public Property TargetVmdkUuid As String
    Get
    Set
public:
property String^ TargetVmdkUuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmdkUuid : string with get, set

Property Value

Type: String
The target VMDK UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmUuid Property

VmdkInfoModelTargetVmUuid Property

Gets or sets the target VM UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmUuid { get; set; }
Public Property TargetVmUuid As String
    Get
    Set
public:
property String^ TargetVmUuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmUuid : string with get, set

Property Value

Type: String
The target VM UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel Methods

The VmdkInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmdkInfoModel Class


VmHealthEnum Enumeration

VM health

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum VmHealthEnum
Public Enumeration VmHealthEnum
public enum class VmHealthEnum
type VmHealthEnum
Members
Member name | Value | Description
Good | 0 | The good
Bad | 1 | The bad
Dormant | 2 | The dormant
See Also

Reference

DoubleTake.Web.Models Namespace


VmHealthQueryInputModel Class

Query input for monitoring the health of a vm
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVmHealthQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VmHealthQueryInputModel : QueryInputModel
Public Class VmHealthQueryInputModel
    Inherits QueryInputModel
public ref class VmHealthQueryInputModel : public QueryInputModel
type VmHealthQueryInputModel =
    class
        inherit QueryInputModel
    end

The VmHealthQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryInputModel | Initializes a new instance of the VmHealthQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VmHealthQueryInputModel Constructor

Initializes a new instance of the VmHealthQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmHealthQueryInputModel()
Public Sub New
public:
VmHealthQueryInputModel()
new : unit -> VmHealthQueryInputModel
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel Properties

The VmHealthQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel.VmId Property

VmHealthQueryInputModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel Methods

The VmHealthQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryResultModel Class

Represents the results of a Vm health query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVmHealthQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class VmHealthQueryResultModel : QueryResultModel
Public Class VmHealthQueryResultModel
    Inherits QueryResultModel
public ref class VmHealthQueryResultModel : public QueryResultModel
type VmHealthQueryResultModel =
    class
        inherit QueryResultModel
    end

The VmHealthQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryResultModel | Initializes a new instance of the VmHealthQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VmHealthQueryResultModel Constructor

Initializes a new instance of the VmHealthQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VmHealthQueryResultModel()
Public Sub New
public:
VmHealthQueryResultModel()
new : unit -> VmHealthQueryResultModel
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel Properties

The VmHealthQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel.VmId Property

VmHealthQueryResultModelVmId Property

Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel Methods

The VmHealthQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmHealthQueryResultModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Class

VRA internal virtual network interface information.
Inheritance Hierarchy
SystemObject
NetworkInterfaceModel
VirtualNetworkInterfaceInfoModel
DoubleTake.Web.ModelsVRAInternalVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VRAInternalVirtualNetworkInterfaceInfoModel : VirtualNetworkInterfaceInfoModel
Public NotInheritable Class VRAInternalVirtualNetworkInterfaceInfoModel
    Inherits VirtualNetworkInterfaceInfoModel
public ref class VRAInternalVirtualNetworkInterfaceInfoModel sealed : public VirtualNetworkInterfaceInfoModel
[<SealedAttribute>]
type VRAInternalVirtualNetworkInterfaceInfoModel =
    class
        inherit VirtualNetworkInterfaceInfoModel
    end

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VRAInternalVirtualNetworkInterfaceInfoModel | Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | (Inherited from NetworkInterfaceModel.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | (Inherited from NetworkInterfaceModel.)
Public property | Gateways | (Inherited from NetworkInterfaceModel.)
Public property | Id | (Inherited from NetworkInterfaceModel.)
Public property | Index | (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | (Inherited from NetworkInterfaceModel.)
Public property | Name | (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VirtualNicType | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID_TestFailover | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
VirtualNetworkInterfaceInfoModel


VRAInternalVirtualNetworkInterfaceInfoModel Constructor

Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VRAInternalVirtualNetworkInterfaceInfoModel()
Public Sub New
public:
VRAInternalVirtualNetworkInterfaceInfoModel()
new : unit -> VRAInternalVirtualNetworkInterfaceInfoModel
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Properties

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | (Inherited from NetworkInterfaceModel.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | (Inherited from NetworkInterfaceModel.)
Public property | Gateways | (Inherited from NetworkInterfaceModel.)
Public property | Id | (Inherited from NetworkInterfaceModel.)
Public property | Index | (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | (Inherited from NetworkInterfaceModel.)
Public property | Name | (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VirtualNicType | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID_TestFailover | (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.BusNumber Property

VRAInternalVirtualNetworkInterfaceInfoModelBusNumber Property

Gets or sets the bus number to be used on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int BusNumber { get; set; }
Public Property BusNumber As Integer
    Get
    Set
public:
property int BusNumber {
    int get ();
    void set (int value);
}
member BusNumber : int with get, set

Property Value

Type: Int32
The bus number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.DeviceNumber Property

VRAInternalVirtualNetworkInterfaceInfoModelDeviceNumber Property

Gets or sets the device number to be used on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int DeviceNumber { get; set; }
Public Property DeviceNumber As Integer
    Get
    Set
public:
property int DeviceNumber {
    int get ();
    void set (int value);
}
member DeviceNumber : int with get, set

Property Value

Type: Int32
The device number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.VRANicId Property

VRAInternalVirtualNetworkInterfaceInfoModelVRANicId Property

Gets or sets the VRA nic id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VRANicId { get; set; }
Public Property VRANicId As String
    Get
    Set
public:
property String^ VRANicId {
    String^ get ();
    void set (String^ value);
}
member VRANicId : string with get, set

Property Value

Type: String
The VRA nic id.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Methods

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAVolumePersistedStateModel Class

VRA volume persisted state.
Inheritance Hierarchy
SystemObject
ProtectableItemModel
PhysicalItemModel
VolumeModel
VolumeOptionsModel
DoubleTake.Web.ModelsVRAVolumePersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public sealed class VRAVolumePersistedStateModel : VolumeOptionsModel
Public NotInheritable Class VRAVolumePersistedStateModel
    Inherits VolumeOptionsModel
public ref class VRAVolumePersistedStateModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type VRAVolumePersistedStateModel =
    class
        inherit VolumeOptionsModel
    end

The VRAVolumePersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | VRAVolumePersistedStateModel | Initializes a new instance of the VRAVolumePersistedStateModel class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | (Inherited from PhysicalItemModel.)
Public property | ClassName | (Inherited from PhysicalItemModel.)
Public property | CreationTime | (Inherited from PhysicalItemModel.)
Public property | DesiredSize | (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | (Inherited from PhysicalItemModel.)
Public property | Id | (Inherited from ProtectableItemModel.)
Public property | IsContainer | (Inherited from ProtectableItemModel.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | (Inherited from ProtectableItemModel.)
Public property | IsSupported | (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | (Inherited from PhysicalItemModel.)
Public property | ItemType | (Inherited from ProtectableItemModel.)
Public property | Label | (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | (Inherited from PhysicalItemModel.)
Public property | Metadata | (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | (Inherited from ProtectableItemModel.)
Public property | Path | (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | (Inherited from PhysicalItemModel.)
Public property | Size | (Inherited from PhysicalItemModel.)
Public property | TotalSize | (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | (Inherited from VolumeOptionsModel.)
Public property | VolumeType | (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
VolumeOptionsModel


VRAVolumePersistedStateModel Constructor

Initializes a new instance of the VRAVolumePersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public VRAVolumePersistedStateModel()
Public Sub New
public:
VRAVolumePersistedStateModel()
new : unit -> VRAVolumePersistedStateModel
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel Properties

The VRAVolumePersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | (Inherited from PhysicalItemModel.)
Public property | ClassName | (Inherited from PhysicalItemModel.)
Public property | CreationTime | (Inherited from PhysicalItemModel.)
Public property | DesiredSize | (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | (Inherited from PhysicalItemModel.)
Public property | Id | (Inherited from ProtectableItemModel.)
Public property | IsContainer | (Inherited from ProtectableItemModel.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | (Inherited from ProtectableItemModel.)
Public property | IsSupported | (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | (Inherited from PhysicalItemModel.)
Public property | ItemType | (Inherited from ProtectableItemModel.)
Public property | Label | (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | (Inherited from PhysicalItemModel.)
Public property | Metadata | (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | (Inherited from ProtectableItemModel.)
Public property | Path | (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | (Inherited from PhysicalItemModel.)
Public property | Size | (Inherited from PhysicalItemModel.)
Public property | TotalSize | (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | (Inherited from VolumeOptionsModel.)
Public property | VolumeType | (Inherited from PhysicalItemModel.)
Top
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ApplianceSCSIBus Property

VRAVolumePersistedStateModelApplianceSCSIBus Property

Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
member ApplianceSCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ApplianceSCSIUnitNumber Property

VRAVolumePersistedStateModelApplianceSCSIUnitNumber Property

Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ApplianceSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DeviceID Property

VRAVolumePersistedStateModelDeviceID Property

Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
member DeviceID : string with get, set

Property Value

Type: String
The device ID.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DriveIndex Property

VRAVolumePersistedStateModelDriveIndex Property

Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
member DriveIndex : int with get, set

Property Value

Type: Int32
The index of the drive.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DriveName Property

VRAVolumePersistedStateModelDriveName Property

Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
member DriveName : string with get, set

Property Value

Type: String
The index of the drive.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.IsGpt Property

VRAVolumePersistedStateModelIsGpt Property

Gets or sets a value indicating whether this instance is a GPT disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsGpt { get; set; }
Public Property IsGpt As Boolean
    Get
    Set
public:
property bool IsGpt {
    bool get ();
    void set (bool value);
}
member IsGpt : bool with get, set

Property Value

Type: Boolean
true if this instance is GPT; otherwise, false.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.MountPoint Property

VRAVolumePersistedStateModelMountPoint Property

Gets or sets the mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
The mount point.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.OriginalPath Property

VRAVolumePersistedStateModelOriginalPath Property

Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Property Value

Type: String
The original path.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.PNPDeviceID Property

VRAVolumePersistedStateModelPNPDeviceID Property

Gets or sets the PNP device ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
member PNPDeviceID : string with get, set

Property Value

Type: String
The PNP device ID.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReplicaVmSCSIBus Property

VRAVolumePersistedStateModelReplicaVmSCSIBus Property

Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIBus : int with get, set

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReplicaVmSCSIUnitNumber Property

VRAVolumePersistedStateModelReplicaVmSCSIUnitNumber Property

Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReverseVolumeSignature Property

VRAVolumePersistedStateModelReverseVolumeSignature Property

Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ReverseVolumeSignature : byte[] with get, set

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.VirtualDiskFilename Property

VRAVolumePersistedStateModelVirtualDiskFilename Property

Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskFilename : string with get, set

Property Value

Type: String
The virtual disk filename.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.VolumeName Property

VRAVolumePersistedStateModelVolumeName Property

Gets or sets the name of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
member VolumeName : string with get, set

Property Value

Type: String
The name of the volume.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel Methods

The VRAVolumePersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VRAVolumePersistedStateModel Class


WinServiceInfoModel Class

Service information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWinServiceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public class WinServiceInfoModel
Public Class WinServiceInfoModel
public ref class WinServiceInfoModel
type WinServiceInfoModel =  class end

The WinServiceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | WinServiceInfoModel | Initializes a new instance of the WinServiceInfoModel class
Top
Properties
 | Name | Description
Public property | IsInstalled | Gets or sets a value indicating whether or not the service is installed.
Public property | IsRunning | Gets or sets a value indicating whether or not the service is running.
Public property | StartMode | Gets or sets the start mode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WinServiceInfoModel Constructor

Initializes a new instance of the WinServiceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public WinServiceInfoModel()
Public Sub New
public:
WinServiceInfoModel()
new : unit -> WinServiceInfoModel
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel Properties

The WinServiceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | IsInstalled | Gets or sets a value indicating whether or not the service is installed.
Public property | IsRunning | Gets or sets a value indicating whether or not the service is running.
Public property | StartMode | Gets or sets the start mode.
Top
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.IsInstalled Property

WinServiceInfoModelIsInstalled Property

Gets or sets a value indicating whether or not the service is installed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsInstalled { get; set; }
Public Property IsInstalled As Boolean
    Get
    Set
public:
property bool IsInstalled {
    bool get ();
    void set (bool value);
}
member IsInstalled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.IsRunning Property

WinServiceInfoModelIsRunning Property

Gets or sets a value indicating whether or not the service is running.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; set; }
Public Property IsRunning As Boolean
    Get
    Set
public:
property bool IsRunning {
    bool get ();
    void set (bool value);
}
member IsRunning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.StartMode Property

WinServiceInfoModelStartMode Property

Gets or sets the start mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public WinServiceStartModeEnum StartMode { get; set; }
Public Property StartMode As WinServiceStartModeEnum
    Get
    Set
public:
property WinServiceStartModeEnum StartMode {
    WinServiceStartModeEnum get ();
    void set (WinServiceStartModeEnum value);
}
member StartMode : WinServiceStartModeEnum with get, set

Property Value

Type: WinServiceStartModeEnum
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel Methods

The WinServiceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WinServiceInfoModel Class


WinServiceStartModeEnum Enumeration

Service start mode

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.2.0.814 (8.2.0.814)
Syntax
C#
VB
C++
F#
Copy
public enum WinServiceStartModeEnum
Public Enumeration WinServiceStartModeEnum
public enum class WinServiceStartModeEnum
type WinServiceStartModeEnum
Members
Member name | Value | Description
Auto | 0 | Auto
Manual | 1 | Manual
Disabled | 2 | Disabled
DelayedAuto | 3 | Delayed auto
See Also

Reference

DoubleTake.Web.Models Namespace